Burg Grub2 in mint

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Burg Grub2 in mint

Postby poision on Mon Mar 08, 2010 4:42 am

hi

anyone tried BURG Grub2 in mint? i ve installed burg but unable to config it.can anyone please guide?
User avatar
poision
Level 3
Level 3
 
Posts: 145
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Linux Mint is funded by ads and donations.
 

Re: Burg Grub2 in mint

Postby remoulder on Sun Apr 04, 2010 9:45 am

Sorry, no idea what you are talking about.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Burg Grub2 in mint

Postby proxima_centauri on Sun Apr 04, 2010 11:29 am

User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Burg Grub2 in mint

Postby breaker on Tue Apr 06, 2010 3:46 am

No, it didn't work for me with the default install. I might try again now that I removed grub2 1.97beta4 and installed GRUB 1.98 grub-common and grub-pc deb packages from the Debian FTP....
rtfm - read the fine manual...
Boot info script: http://ubuntuforums.org/showthread.php?t=1291280
grub2 https://help.ubuntu.com/community/Grub2
PC-BIOS based booting, mbr, boot records; http://thestarman.pcministry.com/
breaker
Level 5
Level 5
 
Posts: 613
Joined: Sun Mar 16, 2008 5:28 am

Re: Burg Grub2 in mint

Postby sahilshinesalways on Wed Jun 02, 2010 12:08 pm

add this apt to ur repository:
ppa:bean123ch/burg

reload synaptic

install burg-pc
and u are done!!
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby poision on Thu Jun 03, 2010 1:49 am

hi sahil

can you please tell me how to config and apply burg after that? i tried some other way but no burg images or os icon came at start up.also can you guide how to apply theme for burg?
User avatar
poision
Level 3
Level 3
 
Posts: 145
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Re: Burg Grub2 in mint

Postby sahilshinesalways on Thu Jun 03, 2010 7:03 am

did u install burg-pc?i suppose u are manually installing it

Install BURG
Edit source.list file(Open terminal from Applications/Accessories/Terminal):
sudo gedit /etc/apt/sources.list
add following into the file and save it.
deb http://ppa.launchpad.net/bean123ch/burg/ubuntu karmic main
deb-src http://ppa.launchpad.net/bean123ch/burg/ubuntu karmic main
Add GPG key:
gpg --keyserver subkeys.pgp.net --recv 55708F1EE06803C5
gpg --export --armor 55708F1EE06803C5 | sudo apt-key add -
update and install:
sudo apt-get update
sudo apt-get install grub-pc
Then,write the new startup code into MBR:
sudo grub-install "(hd0)"
2.Download themes:
wget http://grub4dos.sourceforge.net/themes.tar.bz2
Extract it to /boot/grub/themes:
sudo tar -xjf themes.tar.bz2 -C /boot/grub/themes/
Then,edit /etc/default/grub:
sudo gedit /etc/default/grub
delete the “#”(without quotes) before this:
GRUB_TERMINAL=console
3.Now,edit /etc/grub.d/40_custom:
sudo gedit /etc/grub.d/40_custom
copy and paste following into this file:
set gfxmode="640x480"
set gfxfont="Unifont Regular 16"
loadfont /boot/grub/themes/fonts/unifont.pf2
loadfont /boot/grub/themes/fonts/aqui.pf2
loadfont /boot/grub/themes/fonts/edges.pf2
loadfont /boot/grub/themes/fonts/lime.pf2
loadfont /boot/grub/themes/fonts/7x13B.pf2
loadfont /boot/grub/themes/fonts/smoothansi.pf2
loadfont /boot/grub/themes/fonts/Helvetica-Bold-14.pf2
insmod vbe
insmod png
insmod coreui
load_config /boot/grub/themes/proto/theme.txt
the last line will load the theme.You can change this line to :
ubuntu theme:
load_config /boot/grub/themes/ubuntu/theme.txt
winter theme:
load_config /boot/grub/themes/winter/theme.txt
proto theme:
load_config /boot/grub/themes/proto/theme.txt
Now,use this command to create grub.cfg file:
sudo update-grub
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby sahilshinesalways on Thu Jun 03, 2010 7:05 am

but i think installing it from synaptic will be much more easier....

and hey i guess u didnt installed themes...
and if after installing themes ur screen is still black n white like grub then u can try reinstalling burg-pc.i had that problem in mint 8.
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby poision on Fri Jun 04, 2010 1:27 am

how to do it from synaptic..?

i did some process in mint 8 n my screen was black n os list was just blinking...

can u tell me steps from synaptic.. pls
User avatar
poision
Level 3
Level 3
 
Posts: 145
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Re: Burg Grub2 in mint

Postby sahilshinesalways on Fri Jun 04, 2010 10:21 pm

as i said before, add this apt to ur repository:
ppa:bean123ch/burg

[add repocitories thru synaptic -> settings->repocitories->other softwares->add]

reload synaptic

[u mite need to paste this code in terminal:
sudo apt-get update
]

install burg-pc
insatll burg themes
[plz install both at the same time]
now restart

n u shud see a ubuntu burg theme in reboot,press t to select theme
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby sahilshinesalways on Sat Jun 05, 2010 5:33 am

so poison,having any prblm nw??keep updating,i mite b offline for few days 4m nxt week
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby poision on Sat Jun 05, 2010 2:16 pm

hello Sahil

well i got success in installing burg and its working now..but mess.

i have dell inspiron 14 laptop with corei3 with ATI graphics HD 4300 series and screen resolution 1366x768

after installing burg when i boot resolution is very bad.
how to set up resolution with my laptop so that i get clear burg with background ?

also linux mint startup is very bad,most of time not get linux mint icons n boot splash.

how to fix this screen issue?

please guide me right now its very bad looking burg.

praveen
User avatar
poision
Level 3
Level 3
 
Posts: 145
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Re: Burg Grub2 in mint

Postby sahilshinesalways on Sun Jun 06, 2010 1:11 am

which mint version r u using?7/8/9?
try to configure boot resolution and startup resolution. in mint 9.m out of station for few days so i cant tell u with 100% acuracy since m using "windows" rite nw.in control center there is an startup option.click here and u will b having a dialog box select the appropiate resolution ,put 24 bit color option.i suggest not to put ur higest level of resolution but lil lower;
eg my monitor supports 1280*1024.but io keep the strt up resolution at 800*600,otherwise burg menu will b too small to ur liking...
Last edited by sahilshinesalways on Sun Jun 06, 2010 1:19 am, edited 1 time in total.
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby poision on Sun Jun 06, 2010 1:19 am

i am using mint 9
User avatar
poision
Level 3
Level 3
 
Posts: 145
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Re: Burg Grub2 in mint

Postby sahilshinesalways on Sun Jun 06, 2010 1:19 am

try to configure boot resolution and startup resolution. in mint 9.m out of station for few days so i cant tell u with 100% acuracy since m using "windows" rite nw.in control center there is an startup option.click here and u will b having a dialog box select the appropiate resolution ,put 24 bit color option.i suggest not to put ur higest level of resolution but lil lower;
eg my monitor supports 1280*1024.but io keep the strt up resolution at 800*600,otherwise burg menu will b too small to ur liking...
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby poision on Mon Jun 07, 2010 1:39 am

hi

well i have tried that i have setted resolution according to that but still its not working,better u come back and check for me bro.i will be waiting and also trying by my end also.
User avatar
poision
Level 3
Level 3
 
Posts: 145
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Re: Burg Grub2 in mint

Postby sahilshinesalways on Mon Jun 07, 2010 6:55 am

also linux mint startup is very bad,most of time not get linux mint icons n boot splash.


didnt undrstud dat properly....wats d problem actually?is d display running at lower resolution?or color s r like 16 bit or so?plz elaborate

try to change ur burg theme and see.m nt preety sure wats the matter but it shud hav runned perfectly
Facebook set to deactivate 83 million fake accounts --->http://technoguru.org/?p=609
registered Linux user #510231 | Registered linux machine #421068
User avatar
sahilshinesalways
Level 4
Level 4
 
Posts: 211
Joined: Wed May 05, 2010 1:57 pm

Re: Burg Grub2 in mint

Postby poision on Fri Jun 11, 2010 5:36 am

hi

resolution at burg screen is lower and start up screen of mint also at lower resoultion and scattered line just old VGA support cards.

i have checked in control center resolution setted at higher resultion with 24 bit color scheme.

but still i am facing that issue. how to take screenshot of burg and mint startup screen?i will post picture so that you will get me?or i ll click from cam.
User avatar
poision
Level 3
Level 3
 
Posts: 145
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Re: Burg Grub2 in mint

Postby RainEverAfter on Sat Jun 12, 2010 12:17 am

@ Poison: I think I know where you're coming from. I'm having the same problem.

My Ver: LM9 / Win7 64bit
I followed the instructions from OMG! Ubuntu's post to get BURG installed. After restarting and saw the bootloader where I can get to choose which OS to run, i pressed R to change the resolution and then T to change the theme to Chiva. The resolution is now at 1024x768 and went well until it after I selected LinuxMint 9 to boot from the bootloader's menu, the LM9 boot splash known problem is back where I only see the dotted lines w/o the LM9 logo.

I went back to this link: http://community.linuxmint.com/tutorial/view/37 and verified my StartUp-Manager's resolution and it is on 1024x768 which was the same setting before I installed BURG.

Could it be with the theme that needs some editing, any ideas or suggestions?
I'm a Filipino and still loves Adobo!
RainEverAfter
Level 1
Level 1
 
Posts: 7
Joined: Sat May 22, 2010 12:50 am

Re: Burg Grub2 in mint

Postby RainEverAfter on Sun Jun 13, 2010 9:54 am

Hey everyone! I found the solution to my problem and thought of sharing it as it might work with your case as well...

So go ahead and edit the BURG Configuration file:
Open Terminal and type:
Code: Select all
gksu gedit /etc/default/burg

Look for something like this:
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# In the boot menu, use hotkey 'r' to popup a resolution selection menu.
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=1024x768@32


Edit GRUB_GFXMODE based on your preferred screen resolution
I added the GRUB_GFXPAYLOAD_LINUX because based on the comment from the other forum, it says it's essential for those using nVidia proprietary drivers.

After editing the file, hit save and close
Back to Terminal:
Code: Select all
sudo update-burg

Restart and see if it works...
Source: burg corrupted my bootsplash
I'm a Filipino and still loves Adobo!
RainEverAfter
Level 1
Level 1
 
Posts: 7
Joined: Sat May 22, 2010 12:50 am

Linux Mint is funded by ads and donations.
 
Next

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 12 guests