Can't access tty

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Can't access tty

Postby jinks on Sat Aug 25, 2007 9:51 am

Hi guys
I'm new to this and I was hoping for a little help with Cassandra. I,m not online at home so I had to order the cd and thats also why I wont be able to repley straght away. Well what the problem is that when I try to load the live cd it goes to a blank screen then this text comes up

BusyBox v1.1.3 (Debian 1.1.3-3ubuntu3) Built-in shell (ash) Enter 'help' for a list of built-in commands.

/bin/sh; Can't access tty; job control turned off
(initramfs)

I managed to find out what it means but dont know how to fix it.
Any help would be a God send and thank you :D
jinks
Level 1
Level 1
 
Posts: 2
Joined: Wed Jul 11, 2007 11:00 am

Linux Mint is funded by ads and donations.
 

Postby merlwiz79 on Sat Aug 25, 2007 11:27 am

User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Postby jinks on Wed Aug 29, 2007 10:49 am

Thanks merlwiz79 :D I'll give it a shot. I can't belive I could'nt find that my self and thanks again. I'll post how it turns out.
jinks
Level 1
Level 1
 
Posts: 2
Joined: Wed Jul 11, 2007 11:00 am

Can't Access tty

Postby Serpent105 on Fri Aug 31, 2007 7:13 pm

I have a Dell Optiplex GX150 and I had the same problem with the live CD. I was able to work around it and get the OS installed, but the problem carried over, so every time the OS loads, I get the "can't access tty" error. Entering
"modprobe piix" followed by "exit" resumes the OS startup, and everything works after that, but the problem still remains. Any insight as to how to actually resolve this, would be greatly appreciated. :)
Serpent105
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 31, 2007 1:54 pm

Postby scorp123 on Fri Aug 31, 2007 8:01 pm

Taken from here:

http://ubuntuforums.org/showthread.php?t=421588

At the LiveCD initial boot screen:

o Select F6 for more options
o Add the following option to the beginning of the options list:
break=top

o Press enter to start booting

Ubuntu will start booting, but kick you out to a command prompt; at the prompt type these two commands:
Code: Select all
modprobe piix
exit
You will now boot into the LiveCD normally.

If you choose to install from the LiveCD, you must make the following modifications (or else your installed system will not be able to boot, just like the LiveCD):

o Make note of the device id of the partitions that were used to install (such as /dev/hda1)

-- if you choose to install the '/boot' mount from a different partition make note of it as well (this would be done from the manual partition selection); just a side note -- if you do this, make sure the boot partition is at least 50MB or the install will error at grub setup

o When the install is complete do not reboot -- stay in the LiveCD
o Open a terminal (Applications->Accessories->Terminal)
o You must now mount the installed partitions by typing the following (assuming the install was to /dev/hda1; otherwise replace '/dev/hda1' with the install partition) commands:
Code: Select all
mkdir target
sudo mount /dev/hda1 target


*if you also created a boot partition issue (replace /dev/hda2 with the boot partition) the command:
Code: Select all
sudo mount /dev/hda2 target/boot


Code: Select all
sudo chroot target


o You will now be in a 'chroot' command prompt for your new ubuntu system (be careful here, you are editing with root access!)

o You must edit the /etc/initramfs-tools/modules file; adding a line with the word: piix
-- you should do this with your favorite unix editor; or simply type the command:
Code: Select all
echo piix >> /etc/initramfs-tools/modules


o After modifying the file you must update the system with the command
Code: Select all
update-initramfs -u


o When complete, type 'exit' to exit the chroot env; you can now close the Terminal and reset your system.

Now when you boot you will be in your new shinny Ubuntu system!
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Can't Access tty

Postby Serpent105 on Sat Sep 01, 2007 1:28 pm

That did the trick! Works perfectly now! Thanks a million! :D
Serpent105
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 31, 2007 1:54 pm

Re: Can't Access tty

Postby scorp123 on Sat Sep 01, 2007 2:10 pm

Serpent105 wrote:That did the trick! Works perfectly now! Thanks a million! :D
You're welcome 8)
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

still can't run LiveCD

Postby delinquent on Fri Sep 28, 2007 10:32 am

Even though I added break=top to the options
and then modprobe piix and so on,
I get end-request:I/O dev fd0 error which runs on several lines and again I am thrown back to busybox console.
I also tried to delete "quiet splash" at the option and put break=bottom as it was suggested in this forum to no avail.
Can someone help me solve this?

thanks in advance
delinquent
Level 1
Level 1
 
Posts: 20
Joined: Fri Sep 28, 2007 10:17 am

Re: still can't run LiveCD

Postby scorp123 on Fri Sep 28, 2007 11:16 am

delinquent wrote: end-request:I/O dev fd0
"fd0" is the floppy disk device. Totally irrelevant these days. Whatever your problem is: that message about "fd0" can be safely ignored and is not involved. Try if you see any other error messages ... ?
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

I solved it

Postby delinquent on Fri Sep 28, 2007 6:04 pm

what I did is to add the option (F6) "all generic_ide" and "irqpoll" (without the quotes) instead of
"quiet splash --" at the end of the line. that did the trick!
I could then install mint at last.
delinquent
Level 1
Level 1
 
Posts: 20
Joined: Fri Sep 28, 2007 10:17 am

Postby neodaemon on Sun Oct 07, 2007 1:21 pm

First of all, big thanks to scorp123 for the tips. I had been struggling with the "can't access tty" problem for a while until I came across this thread. I found similar threads - all covering the same problem as this - but they didn't seem to give me enough info to fix this problem. Thanks again scorp123!

2nd, for those who are still having this problem - pay close attention to the device ID of the partitions on which your LinuxMint was installed - just like scorp123 advised. I thought I had done this correctly the first two times, since all the commands were executed without errors; everything seemed to go as planned until I rebooted - then watched in horror as the same "can't access tty" popped up again. I was operating on the wrong mounted file system. Easy enough to fix after I paid closer attention to the device ID of my MINT installation.

Cheers,
neodaemon
Level 1
Level 1
 
Posts: 1
Joined: Sun Oct 07, 2007 1:07 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Derek_S, polypoly and 22 guests