Mint9 super slow, help!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint9 super slow, help!

Postby Lolo Uila on Thu May 20, 2010 8:32 pm

Okay, just tried Mint9 final 32-bit (i386) on my desktop test partition, and it's running super slow. It seems to pause or hang for 2-3 seconds out of every 5 it's running. The only thing that doesn't freeze is the mouse pointer. Anything else I try to do gets this odd pause. Like if I open a window and drag it across the desktop it will be sliding across, then just stick for a couple of seconds, then jump to where the mouse pointer is and continue for a few seconds, then stick again, repeat continuously. Same for media playback, play, pause, play some more, pause again, etc.

System Monitor doesn't show anything unusual. No excessive CPU, RAM or Network usage. I've never run into anything like this before, and I'm stumped. Don't even know where to start looking. Please help.

Note that this same system has been using Mint7 "Gloria" for a long time without issues (and before that, Mint5 Elyssa & Mint3.1 Celina).

Software:
Mint9 Isadora i386 DVD installed to 1st primary partition on HDD

Hardware:
Intel P4 3.4GHz HT CPU
Intel 875P/ICH5R chipset motherboard
2GB of fast OCZ PC3200 DDR RAM
Seagate EIDE/PATA 750GB HDD (Primary Master, no slave)
Pioneer EIDE/PATA DVD burner (Secondary Master, no slave)
ATI Radeon X1950 Pro video card w/512MB RAM (AGP)

Code: Select all
~/Desktop $ lspci
00:00.0 Host bridge: Intel Corporation 82875P/E7210 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82875P Processor to AGP Controller (rev 02)
00:06.0 System peripheral: Intel Corporation 82875P/E7210 Processor to I/O Memory Interface (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corporation 82801ER (ICH5R) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV570 [Radeon X1950 Pro]
01:00.1 Display controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (secondary)
02:06.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev 80)
02:07.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
02:08.0 FireWire (IEEE 1394): Texas Instruments TSB12LV23 IEEE-1394 Controller
Last edited by Lolo Uila on Sun Oct 17, 2010 12:38 pm, edited 2 times in total.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Linux Mint is funded by ads and donations.
 

Re: Mint9 super slow, help!

Postby monkeyboy on Thu May 20, 2010 8:42 pm

Hey Dude
Is "top" showing anything unusual?
If you don't like it, make something better
If you can't make something better, adapt
If you can't do either ball your panties up and cry.

Complaining is like masticating most anyone can do it.
However doing it in public is really hardcore.
User avatar
monkeyboy
Level 5
Level 5
 
Posts: 778
Joined: Mon Oct 13, 2008 11:30 am

Re: Mint9 super slow, help!

Postby Timbot2000 on Fri May 21, 2010 2:05 am

If it makes you feel better, by box with Intel 845 graphics was even worse. Costant freezes and crashes. Seems that the i915 module only really works on i815 and i915, if you are between these numbers youre' out of luck, especially if you are at 845.
Timbot2000
Level 2
Level 2
 
Posts: 68
Joined: Thu Jan 28, 2010 12:10 pm

Re: Mint9 super slow, help!

Postby pnj on Fri May 21, 2010 6:52 am

The same thing here.
Clean install with Mint9 live-cd.

Now the system is super slow.
Systemmonitor and top does not show anything unusual.

Everything was fine before install. Mint7 was running fine.
pnj
Level 1
Level 1
 
Posts: 2
Joined: Wed Jul 29, 2009 11:23 am

Re: Mint9 super slow, help!

Postby pnj on Fri May 21, 2010 2:05 pm

Update: Installed Mint8 Helena. Every thing runs just fine. So the problem must be with Mint 9
pnj
Level 1
Level 1
 
Posts: 2
Joined: Wed Jul 29, 2009 11:23 am

Re: Mint9 super slow, help!

Postby Lolo Uila on Wed May 26, 2010 9:44 am

So... no one else has any input on this? Seems like I'm not the only one with this problem. Some help would be appreciated.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Re: Mint9 super slow, help!

Postby rekik on Wed May 26, 2010 9:59 am

Same problem at my office PC (P4 2.8, NVIDIA mx440), while Mint6 Xfce CE runs well on another partition. I have tried several fixes then abandoned Isadora.
rekik
Level 3
Level 3
 
Posts: 198
Joined: Wed May 06, 2009 5:24 pm

Re: Mint9 super slow, help!

Postby smeden on Wed May 26, 2010 10:40 am

I have also experienced this problem. I suspect it is not a Mint9 problem at all because it started with some updates on Mandriva 2010 Powerpack. I have tried both Mint9 and the new Fedora 13 and the problem remains.

My theory right now is that it has something to do with Nvidia graphics cards because another PC with ATI graphics is not affected by this and runs Mint9 nicely.

Do you all have Nividia cards?
smeden
Level 1
Level 1
 
Posts: 3
Joined: Wed May 26, 2010 10:24 am

Re: Mint9 super slow, help!

Postby rekik on Wed May 26, 2010 12:48 pm

My theory right now is that it has something to do with Nvidia graphics cards because another PC with ATI graphics is not affected by this and runs Mint9 nicely.

Do you all have Nividia cards?


Yes I have an NVIDIA card on my work PC where Isadora is a mess, and at home with an ATI card I have no problem at all.
rekik
Level 3
Level 3
 
Posts: 198
Joined: Wed May 06, 2009 5:24 pm

Re: Mint9 super slow, help!

Postby Lolo Uila on Wed May 26, 2010 7:47 pm

I'm running an ATI (see specs in first post), so it's not Nvidia specific.

Maybe it's an AGP vs PCIe issue (wouldn't be the 1st time)... is everyone with this problem running AGP graphics cards?
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Re: Mint9 super slow, help!

Postby rekik on Thu May 27, 2010 3:19 am

Yes, NVIDIA on AGP
rekik
Level 3
Level 3
 
Posts: 198
Joined: Wed May 06, 2009 5:24 pm

Re: Mint9 super slow, help!

Postby ibm450 on Thu May 27, 2010 7:09 am

Yes AGP 6600GT, i havnt updated anything since fresh install as something in the updates bogged / slowed down the system after a certain update for me.

perhaps it could be the nvidia issue as my previous install the nvidia driver just suddenly crashed and couldn't start the server x thing, no matter what i tried from the forums on here.

so gave up, fresh install and only let it download the nvidia driver after the hardware was detected - so far over 72 recommended updates are awaiting in the update notification shield - but not going to as i cant figure out what update was the root cause for the slow down on my pc, be nice if it had system restore like windows :)
Image
Asus UL50VT laptop ~ LM10 - Unity 12.04 - Win 7
Image
User avatar
ibm450
Level 5
Level 5
 
Posts: 604
Joined: Sun Jan 11, 2009 6:56 am
Location: Kwinana, Western Australia

Re: Mint9 super slow, help!

Postby Lolo Uila on Thu May 27, 2010 4:50 pm

Last time there was a problem with AGP it was an issue of AGP cards being mis-identified as PCIe cards. Unfortunately I don't remember what the fix was... gonna have to do a little digging.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Re: Mint9 super slow, help!

Postby Capt Turk on Thu May 27, 2010 5:27 pm

I've had the same slow down problem with Mint 9. I found it to be the ATI graphics driver. If I don't install it, everything is just fine. As soon as I do, everything slows down and locks up alot, and crashes regularly.

I see it a little bit on Mint 7 also. No where near as bad though. You lose the eye candy, but I've ended up just staying with the vesa drivers. They work a bunch more reliably.
Capt Turk
Level 2
Level 2
 
Posts: 92
Joined: Mon Aug 31, 2009 8:40 pm

Re: Mint9 super slow, help!

Postby smeden on Fri May 28, 2010 5:06 am

It seems to be several completely different reasons for this behavior. In my case the problem was traced to my 1.5 TB WDC Green Sata drive. When I replaced this with a 500 GB WDC hdd Mint9 is running great. All other hardware is the same.

It is interesting to note that there is probably nothing wrong with my 1.5 TB WDC drive. Smart reports it is fine and the drive fitness test from Hitachi also reports this drive as good.

The drive was working nice with Mandriva Powerpack 2010 until recently and the problem must have been introduced with some of the latest updates.
smeden
Level 1
Level 1
 
Posts: 3
Joined: Wed May 26, 2010 10:24 am

Re: Mint9 super slow, help!

Postby Lolo Uila on Fri Jul 30, 2010 8:08 pm

So, has anyone got anything new on this issue? I keep hoping an update will fix it, but no...

I'll bet this is a problem of AGP cards being mis-detected as PCI-E cards. Can anyone tell me how to disable PCI-E support in Mint (Ubuntu)?
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Re: Mint9 super slow, help!

Postby rootkowski on Sat Jul 31, 2010 6:45 am

Hi guys!

Not sure how useful my input here will be, but here it comes. I have experienced similar slow downs with the latest ubuntu as well as Mint 9. I have a radeon x1950 pro PCI-E. So it's not AGP only, sorry. For me the problem is fixed as soon as I turned off desktop effects.

cheers
rootkowski
Level 3
Level 3
 
Posts: 110
Joined: Tue Jun 26, 2007 5:06 am
Location: Wirral, UK

Re: Mint9 super slow, help!

Postby Lolo Uila on Sat Aug 07, 2010 8:35 am

rootkowski wrote:Hi guys!
Not sure how useful my input here will be, but here it comes. I have experienced similar slow downs with the latest ubuntu as well as Mint 9. I have a radeon x1950 pro PCI-E. So it's not AGP only, sorry. For me the problem is fixed as soon as I turned off desktop effects.
cheers
Turning off desktop effects doesn't fix the underlying problem of video acceleration not working correctly. How is video playback on your system after your "fix"?

For me it seems it is, in fact, an AGP issue (as I suspect it is for several others who have posted in this thread).

A few days ago I was rebuilding my niece's computer and ran into the same issue. Mint9 running super slow with an AGP version of a PCI-E video card, a Radeon X1600. I pulled that card and replaced it with an older Radeon X800XT-PE (which was a true AGP card) and Mint9 ran fine. So it seems it is a problem with AGP versions of PCI-E cards.

Mint 7 & 8 run fine on the same computer, so it's definitely an issue with Mint9 (Ubuntu 10.04). This same problem popped up a few years (and several Linux generations) back, but I don't remember what the fix was (and it's likely a different fix would be needed now anyway).

Someone must know how to prevent loading of the PCI-Express bus driver, and/or force Linux to use the AGP bus for video. I'd like to get Mint9 working since it's LTS.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Re: Mint9 super slow, help!

Postby Lolo Uila on Wed Aug 11, 2010 7:44 am

Okay, did some more testing and got some "interesting" results.

Hardware: Intel Northwood P4 CPU on Intel 875p chipset (AGP) motherboard. Tested on 2 different systems, one with a 3.4GHz on a Shuttle brand board, the other a 3.2GHz on a Gigabyte board.

Software: Linux Mint-9 Isadora Main Edition (Gnome) i386 (32-bit) DVD version.

AGP ATI Radeon X800XT works using the default driver (this was one of the last "high end" true AGP cards).

AGP ATI Radeon X1950 Pro causes severe slowdowns and lag. This is a PCI-Express GPU with an AGP-Bridge chip. As I said before, this card worked great with earlier versions of Mint, so this is a new problem with Mint-9 (Ubuntu 10.04).

AGP Nvidia 7900GS works with both the default (open source) and proprietary drivers.

The fact that the Nvidia card worked was a surprise, since I believe it's also a PCI-E GPU on an AGP video card. Not to mention several others in this thread said they were having similar problems with Nvidia cards. Not sure what to make of that, but I popped the Nvidia card in, did a fresh install of Mint-9 and it worked right out of the box. No lag, no slowdowns. I could play 720p HD videos fine on the default install (open source driver). Then I activated the proprietary driver and turned on full desktop effects and it worked great. Finally, I downloaded all the level-1 through level-3 updates, and it's still working great.

So now this is looking like a problem with the open source ATI driver.

When it works the ATI X1950 is quite a bit faster than the Nvidia 7900GS (it also renders a sharper picture), so I'd still like to get this resolved. What's the best course of action now? I'm guessing this is an upstream issue, so should I file a bug report through Ubuntu?

I'd also still like to try disabling PCI-E support. If anyone knows how do that, please post.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Re: Mint9 super slow, help!

Postby Lolo Uila on Wed Aug 11, 2010 6:16 pm

Okay I just noticed something that seems odd (in Synaptic)...

xserver-xorg-video-radeonhd

is not installed. According to the description of this package it is the driver for the Radeon X1950 Pro (and others). I tried installing it manually, but nothing changed. There doesn't seem to be an xorg.conf file any longer, so how do I force Mint to use this driver?
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Linux Mint is funded by ads and donations.
 
Next

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 11 guests