X issue on boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

X issue on boot

Postby jdaily on Wed Jun 02, 2010 7:31 am

I just recently bought an ASUS laptop to keep myself up on things while traveling for work. I just installed mint 9, and on installation, the CD warned me that it didn't have the drivers installed and would have to run in low-graphics mode. I installed and the first boot up did the same thing, though I had to specify nosplash to get to load. I then installed NVidia's proprietary drivers through the mint desktop alert, thinking that this would be the most logical fix.

Now when I boot, whether I specify splash or no splash, it boots with no display. I can tell the machine is still functioning, as it will attempt to read disks and responds to ctrlaltdel, but I cannot for the life of me get it to reconfigure X, install the proper drivers, etc.

I am running:

Geforce 310M
Intel i5-430M
4 gig RAM
Dual-boot with windows 7

suggestions?
jdaily
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 02, 2010 6:56 am

Linux Mint is funded by ads and donations.
 

Re: X issue on boot

Postby interbird1964 on Wed Jun 02, 2010 7:58 am

You could try the kernel-parameter: nvidia.modeset=1 or nvidia.modeset=0
Also besides the closed-source nvidia driver there is the open-source nouveau driver that you could try.
For this driver the kernel-parameter is: nouveau.modeset=1 (or 0)
interbird1964
Level 1
Level 1
 
Posts: 22
Joined: Tue Dec 01, 2009 10:05 pm

Re: X issue on boot

Postby jdaily on Wed Jun 02, 2010 2:40 pm

Where would those commands be entered? Should I go to command line using GRUB or add it to the command to boot (where I have removed the -splash tag)?
jdaily
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 02, 2010 6:56 am

Re: X issue on boot

Postby dawgdoc on Wed Jun 02, 2010 4:56 pm

This post is discussing using the nomodeset option as a kernel parameter and says:
When you boot the CD, press 'e' to edit the first boot option. Use the arrow keys and move down to the 'kernel' line. That is the one that has the 'quiet splash' options. (the line may wrap, press end to get to the end of the line).

When I first located this post I say related ones that mentioned placing the nvidia.modeset=1 or nvidia.modeset=0 options in a similar manner.

Hope this helps.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2716
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: X issue on boot

Postby jdaily on Thu Jun 03, 2010 8:37 am

Alright, I was able to get X to run again by using "nomodeset" (nvidia.modeset did not work). I purged the proprietary drivers auto-installed by mint and manually selected the right drivers from nvidia, rebooted to terminal, installed them, and rebooted again.

Now, each time it loads X crashes and gives the error "(EE) No device detected." It then proceeds to run GNOME in low-graphics mode.

I tried editing xorg.conf to manually choose the NVIDIA PCI slot with BusID "PCI:2:0:0", but this is a no-go. Could it be that the driver is trying to display to one of the monitor/DVI ports?
jdaily
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 02, 2010 6:56 am

Re: X issue on boot

Postby dawgdoc on Fri Jun 04, 2010 8:38 am

Getting a bit stickier.
For the sake of completeness could you post the results of
Code: Select all
inxi -G

and
Code: Select all
lspci

and curiosity leads me ask how things look if you boot from a LiveCD, is the resolution good, does inxi -G give the same results?
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2716
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: X issue on boot

Postby jdaily on Fri Jun 04, 2010 11:07 am

I could print these things, but I have discovered my true issue. It did turn out that the nvidia drivers were not communicating with my displays. lspci listed an integrated graphics card as well, so I went into the BIOS to make sure it was disabled. What I found, however, was no option to turn it off. I noticed that some Sony VAIO users had issues communicating with the laptop LCD, so I tried the suggested fix (for posterity, the fix is to grab your device's EDID manually under windows, output the file in raw format to linux, and manually tell your driver to read with "CustomEDID"). This did not work, so I did a search for my laptop to see if there was a minor adjustment.

My laptop is an ASUS K52JC-X1, one of the new models with the brand-spanking new Nvidia Optimus technology. optimus switches between integrated and dedicated graphics intelligently... and almost completely via software. Nvidia's drivers do not support Optimus on linux, and according to a post on their site they have no plans to do so.

In theory, I should be able to go ahead and run mint with integrated graphics (I'll post whether this works later), but until xorg and the open drivers work out Optimus functionality, I'm fairly certain I'll have to use windows for 3d acceleration. Praise the dual-boot, I guess.
jdaily
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 02, 2010 6:56 am

Re: X issue on boot

Postby dawgdoc on Fri Jun 04, 2010 11:32 am

I'm glad you found a "sort of" solution. It's too bad that you can not select the discreet graphics card as the default instead of the integrated.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2716
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: X issue on boot

Postby jdaily on Fri Jun 04, 2010 11:37 am

I'll keep working on it, and post any "solutions" I find. Should this info be put up as a warning/known issue? People shopping for laptops with the intention of running mint should probably know about this issue. I can put together some links to info if necessary.
jdaily
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 02, 2010 6:56 am

Re: X issue on boot

Postby Gramps50 on Wed Oct 20, 2010 12:18 am

So I take it if you want to run Linux then the ASUS laptops with the NVida Optimus are a waste of money that you can't use the NVida chipset only the builtin Intel chipset. Unless you buy an I7 which doesn't have the builtin video chipset.
LMDE ROCKS!!!
User avatar
Gramps50
Level 4
Level 4
 
Posts: 243
Joined: Sun Dec 13, 2009 1:36 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Zam and 21 guests