Boot Error After Replacing Another Distro

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Boot Error After Replacing Another Distro

Postby bob on Thu Jan 04, 2007 11:17 pm

I'm currently booting 6 distros over two hard drives and periodically dump one and replace it with another testing distro. Mint is one of three 'permanent' distros that have earned their places.

Unfortunately, after dumping Sabayon for a test run of Blag, Mint fails to completely boot, complaining about the change even though the partition size was not affected. Oddly, typing 'reboot' immediately completes the boot to a desktop, however the other partitions are not accessible.

Along with the cute sayings, there's a warning that a manual fix would have to be done. Just wondering how involved that would be and where to find the affected file.
User avatar
bob
Level 1
Level 1
 
Posts: 31
Joined: Sat Nov 18, 2006 8:23 pm

Linux Mint is funded by ads and donations.
 

Postby boilertech on Fri Jan 05, 2007 7:42 am

Sounds like maybe the partitions have changed. When you removed Sabayon for a test run of Blag did you change the file type. (ext3 to ext2 etc)? If so then edit your etc/fstab and comment out the line for that partition (by placing a # in front of the line). Then maybe give mintDesktop a try http://lt.k1011.nutime.de/forum/viewtopic.php?t=540
User avatar
boilertech
Level 1
Level 1
 
Posts: 8
Joined: Sun Dec 31, 2006 3:37 pm

Postby clem on Fri Jan 05, 2007 12:05 pm

Check the /etc/fstab in mint to see if they use UUID... if they do replace them with normal devices names such as /dev/hda1..etc.

I had a similar problem and that fixed it.

Clem
User avatar
clem
Level 15
Level 15
 
Posts: 5548
Joined: Wed Nov 15, 2006 8:34 am

Postby bob on Fri Jan 05, 2007 7:35 pm

Clem, that did it! Simple as substituting /dev/hdb3 for all the UUID info and a reboot. Not that I don't trust you completely, but I did back up my old fstab, just in case... :lol:
User avatar
bob
Level 1
Level 1
 
Posts: 31
Joined: Sat Nov 18, 2006 8:23 pm

Postby Telkwa on Sat Jan 06, 2007 11:24 am

clem -
Are you saying that a person can edit out that UUID stuff as long as the rest of it's correct? You know what i mean, device and permissions.

My Ubuntu 6.06 install just reports the dev and permissions. Mint and Edgy (I believe) added the UUID information and I've been wondering about that ever since.
Telkwa
Level 1
Level 1
 
Posts: 26
Joined: Mon Dec 25, 2006 7:51 pm

Postby bob on Sat Jan 06, 2007 9:03 pm

Can't speak for every instance, but that sure worked for me. I'm able to complete the boot normally and also go into each partition and access files.
User avatar
bob
Level 1
Level 1
 
Posts: 31
Joined: Sat Nov 18, 2006 8:23 pm

Postby clem on Sat Jan 06, 2007 9:52 pm

I haven't read about those IDs yet and how to use them... I don't like them too much though and I noticed that they were more volatile than the partitions themselves. I would recommend replacing them with normal devices names.

I "think"... (not sure at all on this one) that Fedora Core 6 is using them as well.

Clem
User avatar
clem
Level 15
Level 15
 
Posts: 5548
Joined: Wed Nov 15, 2006 8:34 am

Postby clem on Sat Jan 06, 2007 9:54 pm

Also: I must have got that from Slackware... I just like configuration files to be straight and easy to read. These IDs are definitely not good in that respect.

Clem,
now I'd better go and read about them before I say more :) If they were introduced to replace /dev/xxx in fstab there's probably a good reason.
User avatar
clem
Level 15
Level 15
 
Posts: 5548
Joined: Wed Nov 15, 2006 8:34 am

Postby Telkwa on Fri Jan 12, 2007 3:13 am

I gave up on a multi-boot experiment after upgrading or changing one distro would screw the other ones.
Read a discussion on this at Ubuntu Forums - something abot the UUID's being introduced so that physical devices could be moved around within a system and the OS would pick up the devices. That might be great for a system administrator but creates hassles for the rest of us who just want to play around with multi-boots.
Telkwa
Level 1
Level 1
 
Posts: 26
Joined: Mon Dec 25, 2006 7:51 pm

installation&boot

Postby tony on Wed Jan 24, 2007 12:48 pm

hi all,
when multibooting I allways have a fedora partition installed, it doesn't matter which 1,2,---6 as redhat/fedora has the simplest grub config .
method---
After installing fedora x as root open gedit use the open location button and in the dialog enter /etc/grub.conf click open
you will then have the grub conf file.
Print it !!
The bit you are interested in are the lines that start from default
On my machine they are as follws

defautt=1
timeout=5
splashimage=(hd1,0)
#hiddenmenu
title Fedora Core (2.6.19-1.2895.fc6 )
root (hd1,0)
kernel /boot/vmlinuz-2.6.19-1.2895.fc6 ro root=LABEL=/ rhbb quiet
initrd /boot/initrd-2.6.19-1.2895.fc6 .img
#line s added by me to boot mint
title mint
root (hd1,2)
kernel /boot/vmlinuz-2.6.17-10-generic root=?dev/sda3 ro quietsplash
initrd /boot/vmlinuz-2.6.17-10-generic
#line added by Fedora for Windows XP
rootnoverify (hd0,0)
chainloader +1
With this and the Fedora install /rescue disk you can repair or install new distos as needed(as long as you know the kernel you are booting):-)

To use the fedora rescue disk boot with the disk in the drive
at the boot promt enter -linux rescue-
you will get various messages select language keybord and then it find linux systems on the machine
Using the Tab key select the FEDORA DISTRO and OK

A message will come up saying it is mounting sysimage and how to chroot to it click ok press the space bare

At the prompt enter chroot /mnt/sysimage ENTER

back at the promt eter NANO /etc/grub.conf ENTER

YOU should now have a copy of your Fedora grub file scroll down to where you want to put your new entry useing the format :-

title new distro
root (hdx,x)
kernel /boot/newvmlinuz (if the kernel line of new distro includes the root=somthing add it to vmlinuz line)

initrd /boot/new initrd (fedora allways has .img at the end)

Then save using command -ctrl-o

In the dialog box at the bottom entere/etc/grub.conf ENTER
Then Ctrl-x
then reboot

If hiddenenu isnt commented out you will need to ese Esc to see all options any problems in the new bootloader can be fixed by useing the instructions on the boot screen : Its all easier after the first time :-)

Tony

P.S. If you dont have a suitable rescue disk then it is possible to make a boot floppy that gives a grub shell that can be used to enter root.vmlinuz & initrd lines followed by boot

to make a boot floopy :-
as root cd /boot/grub
cat stage1 stage2 | dd of=/dev/fd0

Hope this helps

Oh Dear so sorry :-(

Iforgot to add to my 'use fc rescue to add to the grub.conf if you have lost the MBR completly after re-writing grub, issue the command :-
grub-install /dev/hda
you will then get the device map mine is :-
(hd0) /dev/hda
(hd1) /dev/sda
If there is an error correct it then re run grub-install /dev/hda

also from the chroot installation to makle a boot disk :-

mkbootdisk --device /dev/fd0 kernel-version of running fcx



Tony
tony
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 22, 2006 7:14 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 8 guests