Grub not installed after celena instalation

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Grub not installed after celena instalation

Postby carlos on Wed Oct 03, 2007 10:05 am

Ok need a bit of help here. A friend of mine, an old time xp user wants to try Mint.

He dled and burned celena. When he first tried to install he was locked into the Migration Assistant, well I told him to make sure he avoided using it. Obviously he was able to continue with installation there after.

Well low and behold 30 minutes later Celena was installed. The machine reboots, but no grub screen at all. He made sure to to "esc" right after the bios loads too, so I'm pretty stumped.

BTW, windoze is on one drive (master) and linux is on a 2nd drive (slave).
____________ ________ ______ ____ ___ __ __ _
http://www.designdrifter.com
The Purpose of Life is for DNA to reproduce.
User avatar
carlos
Level 5
Level 5
 
Posts: 526
Joined: Thu Dec 14, 2006 4:30 pm
Location: USA

Linux Mint is funded by ads and donations.
 

Postby Husse on Thu Oct 04, 2007 5:42 am

No grub at all?
Not even after Esc?
Does it boot right into Windows?
If so I think the install got screwed up and no grub was installed
Try to repair grub first
http://www.linuxmint.com/wiki/index.php ... _your_grub
If no success I'm afraid you have to reinstall
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby carlos on Thu Oct 04, 2007 11:13 am

Yep goes straight into windows even after hitting esc... Funny thing is a grub directory is there, we used the ext plugin for xp to see what mint installed.

Thanks Husse, I'll let you know what happens.
____________ ________ ______ ____ ___ __ __ _
http://www.designdrifter.com
The Purpose of Life is for DNA to reproduce.
User avatar
carlos
Level 5
Level 5
 
Posts: 526
Joined: Thu Dec 14, 2006 4:30 pm
Location: USA

Postby Exakun on Thu Oct 04, 2007 4:44 pm

I don't know if you've solved the problem yet, but if you can't get into Linux to fix GRUB you should be able to specify which hard disk to boot from. Typically you press DEL or F12 to get the menu at boot but it depends on your hardware.

Hope this helps :D
Exakun
Level 1
Level 1
 
Posts: 13
Joined: Tue Oct 02, 2007 11:29 pm

Postby Husse on Fri Oct 05, 2007 5:59 am

Funny thing is a grub directory is there

Then you will be able to fix it following the wiki, I'm pretty sure - but .....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Grubbified the wrong darn Drive.

Postby Remowylliams on Fri Oct 05, 2007 4:06 pm

Ok Call this a bug, call this a programmed hatred for Windows..
but I'll tell you right now, Something needs to be fixed before
someone else bumps into this.

Laptop with a USB 2.0 drive connected. And an internal drive with
FreeBSD and Xp

I went through the install proceedure. Made sure to tell mint install
I only want to use sdb (the usb drive that is connected.) Went through
the deal, and rebooted. Everything is great till the boot....

The laptop screen sits with just a _ in the upper left corner.

I figured fine, I'll boot my regular drive, so I flip through the bios,
set it to boot the internal drive and whalla.. I have Grub where there
should be no grub.

Infact I have grub showing me all the lovely things I can boot, including
my XP, never mind it over wrote my bootloader... NGBOOT..
So fine I can boot using grub.. as long as the USB drive is connected.

I can fix my bootloader issue but only because I know what to do. But most people wouldn't know at all.

The fact that Grub hangs because there's no USB drive is quite an Erk..
Can someone please tell me this is something that can be fixed fast?

With all the USB drives available now, I can see people wanting to try
mint linux and be safe with it, only to have their system become
a Grub slave.

Thanks.
Remowylliams
Level 1
Level 1
 
Posts: 6
Joined: Fri Oct 05, 2007 3:45 pm

Re: Grubbified the wrong darn Drive.

Postby merlwiz79 on Fri Oct 05, 2007 8:21 pm

Remowylliams wrote:Ok Call this a bug, call this a programmed hatred for Windows..
but I'll tell you right now, Something needs to be fixed before
someone else bumps into this.

Laptop with a USB 2.0 drive connected. And an internal drive with
FreeBSD and Xp

I went through the install proceedure. Made sure to tell mint install
I only want to use sdb (the usb drive that is connected.) Went through
the deal, and rebooted. Everything is great till the boot....

The laptop screen sits with just a _ in the upper left corner.

I figured fine, I'll boot my regular drive, so I flip through the bios,
set it to boot the internal drive and whalla.. I have Grub where there
should be no grub.

Infact I have grub showing me all the lovely things I can boot, including
my XP, never mind it over wrote my bootloader... NGBOOT..
So fine I can boot using grub.. as long as the USB drive is connected.

I can fix my bootloader issue but only because I know what to do. But most people wouldn't know at all.

The fact that Grub hangs because there's no USB drive is quite an Erk..
Can someone please tell me this is something that can be fixed fast?

With all the USB drives available now, I can see people wanting to try
mint linux and be safe with it, only to have their system become
a Grub slave.

Thanks.
When you installed you probably didn't tell grub to install to hd1(sdb) instead left it with hd0(sda).
You can try to install grub to the USB drive.
Then use the Windows cd to restore the MBR for Windows XP.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Grubbified the wrong darn Drive.

Postby Remowylliams on Sat Oct 06, 2007 9:29 pm

When you installed you probably didn't tell grub to install to hd1(sdb) instead left it with hd0(sda).
You can try to install grub to the USB drive.
Then use the Windows cd to restore the MBR for Windows XP.


I'm not sure where I would be having an opportunity to do this. Would you care to specify where you tell Grub to do this? I'm still not clear why in the world Grub should automatically default to a drive you aren't installing the operating system to.
Remowylliams
Level 1
Level 1
 
Posts: 6
Joined: Fri Oct 05, 2007 3:45 pm

Re: Grubbified the wrong darn Drive.

Postby merlwiz79 on Sat Oct 06, 2007 9:49 pm

Remowylliams wrote:
When you installed you probably didn't tell grub to install to hd1(sdb) instead left it with hd0(sda).
You can try to install grub to the USB drive.
Then use the Windows cd to restore the MBR for Windows XP.


I'm not sure where I would be having an opportunity to do this. Would you care to specify where you tell Grub to do this? I'm still not clear why in the world Grub should automatically default to a drive you aren't installing the operating system to.
The default is hd0 it was an advance setting before you click install.
You can use Linux Mint to reinstall Grub then use the BIOS to select the USB drive as the 1st option.(check if your BIOS allows this before doing anything)

In terminal use these commands.
Code: Select all
sudo grub
root (hd1)
setup (hd1)
quit
sudo grub-install /dev/sdb

Don't for get to edit menu.list from hd0 to hd1
While having BIOS selected for the internal hard drive to boot from, you can use the XP install cd to reinstall XP's MBR.
Just use Repair console to run these commands:
Code: Select all
fixmbr
fixboot
exit

I believe these are all the commands.
Now when you reboot just use the Bios to select the correct hard drive to boot.(Internal if you don't need Grub and USB for Linux Mint)
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Postby Husse on Sun Oct 07, 2007 4:28 pm

The default is hd0 it was an advance setting before you click install.
To clarify - you get a window with something like "This is the settings you are going to install with" (note like)
There is a button "Advanced" and in there you can select the drive you install Grub to
I would like it to somehow tell that you have this choice there more clearly, but this is how ubiquity (the installler) is and I believe we have to do with that
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Much clearer

Postby Remowylliams on Mon Oct 08, 2007 4:16 pm

Husse wrote:
The default is hd0 it was an advance setting before you click install.
To clarify - you get a window with something like "This is the settings you are going to install with" (note like)
There is a button "Advanced" and in there you can select the drive you install Grub to
I would like it to somehow tell that you have this choice there more clearly, but this is how ubiquity (the installler) is and I believe we have to do with that


Thanks, this clears up the confusion a bit and helps to know that maybe somewhere in the future this option / behavior will be changed so it works for the novice as well as for the advanced.

No other drive device should ever be touched by install software that isn't specifically included/selected by the user.
Remowylliams
Level 1
Level 1
 
Posts: 6
Joined: Fri Oct 05, 2007 3:45 pm

Re: Grubbified the wrong darn Drive.

Postby Remowylliams on Mon Oct 08, 2007 4:19 pm

merlwiz79 wrote:
Remowylliams wrote:
When you installed you probably didn't tell grub to install to hd1(sdb) instead left it with hd0(sda).
You can try to install grub to the USB drive.
Then use the Windows cd to restore the MBR for Windows XP.


I'm not sure where I would be having an opportunity to do this. Would you care to specify where you tell Grub to do this? I'm still not clear why in the world Grub should automatically default to a drive you aren't installing the operating system to.
The default is hd0 it was an advance setting before you click install.
You can use Linux Mint to reinstall Grub then use the BIOS to select the USB drive as the 1st option.(check if your BIOS allows this before doing anything)

In terminal use these commands.
Code: Select all
sudo grub
root (hd1)
setup (hd1)
quit
sudo grub-install /dev/sdb

Don't for get to edit menu.list from hd0 to hd1
While having BIOS selected for the internal hard drive to boot from, you can use the XP install cd to reinstall XP's MBR.
Just use Repair console to run these commands:
Code: Select all
fixmbr
fixboot
exit

I believe these are all the commands.
Now when you reboot just use the Bios to select the correct hard drive to boot.(Internal if you don't need Grub and USB for Linux Mint)


Thank you, this information will be of much help to me and others I'm sure.
Remowylliams
Level 1
Level 1
 
Posts: 6
Joined: Fri Oct 05, 2007 3:45 pm

Postby Husse on Tue Oct 09, 2007 8:00 am

No other drive device should ever be touched by install software that isn't specifically included/selected by the user.
Agree - to a point
I believe the MBR of the "first disk" is default for grub - but I may be wrong. But for most people that is the best choice...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Advanced option used

Postby Remowylliams on Tue Oct 09, 2007 4:52 pm

Hi all,
I reinstalled to this drive, using the advanced button at the point where it is available. And it seems it's the only thing it's there for. To let you set what drive grub is to be installed on.

There are a number of problems trying to setup a usb drive as an install drive and I'll try to help outline the problems I found.

1. Once the live disk is installed be sure to 'eject' or unmount the usb drive before trying to partition it. Or you will get errors and nothing is going to work.

2. Be mindful of which drive you are going to partition and use the advanced button to tell the installer to set grub to boot from hd1.

3. Once you've finished installing. Try to figure out why grub still won't boot. :P

to that end here is my menu.lst


## comments and info (snipped)

title Linux Mint, kernel 2.6.20-15-generic
root (hd1,0)
kernel /boot/vmlinuz-2.6.20-15-generic root=/dev/sdb1 ro quiet splash
initrd /boot/initrd.img-2.6.20-15-generic
boot

title Linux Mint, kernel 2.6.20-15-generic (recovery mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.20-15-generic root=/dev/sdb1 ro single
initrd /boot/initrd.img-2.6.20-15-generic
boot

title Linux Mint, kernel memtest86+
root (hd1,0)
kernel /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Home Edition
root (hd0,0)
savedefault
chainloader +1

This is what was created by the installer.

So not being a grub person. I'll need help from here.
Remowylliams
Level 1
Level 1
 
Posts: 6
Joined: Fri Oct 05, 2007 3:45 pm

An Answer found

Postby Remowylliams on Tue Oct 09, 2007 5:30 pm

When the laptop is setup to boot the usb drive, the bios sets it
as hd0 so if you install using the advanced setting, it may make
a menu.lst that looks right but it will be wrong, but what it does
do is keep grub from messing with your drive on the laptop.

This is not a way to influcence the windows lost and found.

So here's the deal. if you used the advanced button to change to
hd1, be sure to edit the menu.lst to reverse your hd numbers, ie..
(hd1,0) becomes (hd0,0) and visa versa.

If you don't use the advanced button your drives boot loader will
be over written by grub because the installer doesn't know better
and someone needs to slap it silly.

:)
Remowylliams
Level 1
Level 1
 
Posts: 6
Joined: Fri Oct 05, 2007 3:45 pm

Postby Husse on Wed Oct 10, 2007 5:52 am

We're aware of the problem with external disks and this must be a problem to all....
I have mentioned this to Clem so he can think about it, but it is not simple....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: tinca and 15 guests