[SOLVED] Can't add freebsd to grub menu

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

[SOLVED] Can't add freebsd to grub menu

Postby wakajawaqa on Fri Oct 22, 2010 10:04 pm

Hi, I just installed Mint 10 on my laptop. I currently have Arch, FreeBSD and Mint installed.

I appended this entry to /etc/grub.d/40_custom

Code: Select all
menuentry "FreeBSD" {
    set root=(hd0,1,a)
    chainloader +1


But the only menu entries I have are Arch and Mint. The same edit to this file worked in Mint 9 and Lubuntu. Can someone please tell me why I can't boot BSD?

FreeBSD is located on the first partition and, of course, I ran update-grub when I was finished.

Thanks
Last edited by wakajawaqa on Sun Oct 24, 2010 5:37 am, edited 1 time in total.
wakajawaqa
Level 1
Level 1
 
Posts: 16
Joined: Wed Sep 16, 2009 3:23 pm

Linux Mint is funded by ads and donations.
 

Re: Can't add freebsd to grub menu

Postby summer of 69 on Sat Oct 23, 2010 2:50 am

Open a terminal and cd to /etc/grub.d.
Then post the outcome of "ls -l" because I would like to check something :wink:
summer of 69
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 16, 2010 8:35 am

Re: Can't add freebsd to grub menu

Postby vincent on Sat Oct 23, 2010 3:19 am

Your entry should look something akin to the following:
Code: Select all
menuentry "FreeBSD" {
insmod ufs2
set root=(hd#,#)
chainloader +1
}


Where the #'s correspond to the hard drive and partition where FreeBSD resides. If FreeBSD resides on sda1, the entry would state (hd0,1). If it was on sda7, then it'd be (hd0,7). I've never seen notation in the form of (hd0,1,a), actually.

Don't forget to run
Code: Select all
sudo update-grub

after you're done tweaking your menu entry.

Just to make sure...you installed Mint's Grub2 into your MBR during the installation, right?
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Can't add freebsd to grub menu

Postby summer of 69 on Sat Oct 23, 2010 3:55 am

I also believe that's the right entry for BSD but my intention was to disable 40_custom and enable the other scripts in /etc//grub.d and run "sudo update-grub"
Then copy and paste the correct entry from /boot/grub/grub.cfg to 40_custom; disable the other scripts and enable 40_custom again followed by "sudo update-grub" :wink:
summer of 69
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 16, 2010 8:35 am

Re: Can't add freebsd to grub menu

Postby wakajawaqa on Sun Oct 24, 2010 5:37 am

I added the insmod ufs2 line and removed the 'a.' It's working now, thanks. I'm still not sure why it worked before, because I hadn't included it up til now.

The 'a,' by the way, should reference the first file system within a slice on FreeBSD.
wakajawaqa
Level 1
Level 1
 
Posts: 16
Joined: Wed Sep 16, 2009 3:23 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 13 guests