Running e2fsck on casper-rw during boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Running e2fsck on casper-rw during boot

Postby robher on Wed Oct 27, 2010 3:57 pm

Hello all,

I created a persistent live USB with Linux Mint 9 Gnome using "Universal USB Installer" ( ... y-as-1-2-3). In order to make the casper-rw file larger than 4 GB, I've created an ext2 partition on the USB drive ( ... -partition).

Everything works great, except for the fact that the casper partition is not cleanly unmounted upon shutdown. If I boot from a different system and run e2fsck on the casper-rw partition, there are always errors.

I've been Googling the issue and there are several reports of this problem. There's even a post in the Mint forums, but no replies (viewtopic.php?f=46&t=51305&p=295110&hilit=e2fsck+casper#p295110).

I came accross a link with instructions on how to run e2fsck on the casper-rw partition during boot ( ... &tb=1&pb=1). It involves modifying the initramfs image in order to run e2fsck right before mounting casper-rw. The instructions were originally written for Ubuntu 8.04, but I've tried to adapt the process and was successful in creating the initramfs and /cdrom/casper/filesystem.squashfs file. However, it is still not working:

mint@mint /cdrom/casper $ dmesg | grep e2fsck
[ 11.648759] EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended

My Linux expertise is rather limited; I don't know much about the boot process, initramfs or squashfs. Right now I'm stuck and would much appreciate some pointers.

Thanks in advance!
Level 1
Level 1
Posts: 6
Joined: Sat Jun 12, 2010 6:58 am

Linux Mint is funded by ads and donations.

Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests