Unable to boot Mint with LILO

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Unable to boot Mint with LILO

Postby Dahldrin on Sun Oct 28, 2007 6:51 pm

Hello, I think that this is something simple that I am overlooking.

Thanks in advance, here is some background. I am trying to install Mint 3.0 XFCE edition on a single SATA drive that already was a dual boot with XP and Slackware. This drive happens to be on a SiL 3114 'RAID' controller (on board).

The live CD boots fine and finds all my drives without a problem. During the install however it says GRUB will not work with xfs and asks if I want to use LILO. Well, ask is not the right word, the message says LILO is recommended but the choices are 'Go Back' and 'Continue.' ?

Continue does nothing and Go Back, seems to continue(what?).

After the installation 'finished' there was no message asking about setting up LILO, so I restarted and not only was the previous LILO still there but the LILO package was not even installed.

I booted of of the CD, mounted my mint partition, chrooted in, installed LILO and tried to run liloconfig, but it said it does not like RAID controllers. So I made my own lilo.conf and after some googling and mounting I got lilo to install it.

Now I get the LILO menu with both Mint and XP and XP works, but Mint gets a kernel panic trying to mount root.

"Kernel panic - not syncing: VFS: Unable to mount root fs on unkown-block(8,2)"

Here is my lilo.conf

boot=/dev/sda
map=/boot/map
compact
prompt
delay=50

image=/vmlinuz
label=Mint
read-only
root=/dev/sda2
other=/dev/sda3
label=XP

and here is my fstab


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda2
UUID=86a7b8fe-05a8-412f-8dd5-4dfe75d64557 / xfs defaults 0 1
# /dev/sda3
UUID=9CBC8A85BC8A59A2 /media/sda3 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sdb1
UUID=5058694C586931C0 /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda1
UUID=eb2c43e1-c01a-4f6c-8858-c2f7e668469d none swap sw 0 0
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hda /media/cdrom1 udf,iso9660 user,noauto 0 0


I am sorry if this is an ignorant question, but I never had this problem installing Fedora, Slack or Gentoo on the same hardware.

I am thinking that maybe I need an append line in my lilo.conf for it to see my SATA controller? But the CD found everything fine.

Again, thanks for reading.
Dahldrin
Level 1
Level 1
 
Posts: 2
Joined: Sun Oct 28, 2007 5:58 pm

Linux Mint is funded by ads and donations.
 

Postby Boo on Mon Oct 29, 2007 7:36 pm

I have not used lilo in years but here goes.

boot off the live CD again, mount sda2 and edit /etc/fstab and change the UUID devices to the /dev/sda? above them.
eg.
UUID=86a7b8fe-05a8-412f-8dd5-4dfe75d64557 / xfs defaults 0 1
to
/dev/sda2 / xfs defaults 0 1

I dont know if lilo knows about UUID but it may make no difference (due to linking of devices).

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby Dahldrin on Tue Oct 30, 2007 9:20 am

Hmm, well I guess your right. It did not make any difference. I commented out the UUID stuff and replaced with /dev/sda2 etc, but I still get the same error.
Dahldrin
Level 1
Level 1
 
Posts: 2
Joined: Sun Oct 28, 2007 5:58 pm

Postby Boo on Wed Oct 31, 2007 1:07 am

if you boot off the live cd, mount /dev/sda2 and then chroot to it, did you run the lilo command after making changes to lilo.conf?

sudo lilo

try doing this again any way.
you have to run the lilo command after any changes to lilo.conf.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am


Return to Installation & Boot

Who is online

Users browsing this forum: killer de bug and 20 guests