X doesn't want to work

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

X doesn't want to work

Postby bluejeans on Sun Nov 18, 2007 5:14 am

i tried the daryna live cd and it worked great in my vaio laptop.... so i installed it to disc.
but when i rebooted off the HD i couldn't get X to start... i rebooted in singe user mode and watched the precess; it loads everything with no problem except that when it's all done i get "warning: not loading the blacklisted module ipv6"
logged in as root i can manuver via command line but as soon as i type "startx" the screen goes completely black (though the computer's still running) and i have to pull the plug to get it to shut down.

any help would be appreciated.
bluejeans
Level 1
Level 1
 
Posts: 3
Joined: Sun Nov 18, 2007 5:01 am

Linux Mint is funded by ads and donations.
 

Postby nick on Sun Nov 18, 2007 7:16 am

Hi

"warning: not loading the blacklisted module ipv6" do

Do not worry about that, it is because it is blacklisted

Try, at single user mode

sudo envy -t

and select your graphics driver to be installed

i.e. Nvidia etc

reboot, if still no X

run

sudo dpkg-reconfigure xserver-xorg.


"and i have to pull the plug to get it to shut down"

Just type

sudo halt


Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby bluejeans on Sun Nov 18, 2007 8:29 pm

Try, at single user mode

sudo envy -t


tried that.

sudo dpkg-reconfigure xserver-xorg.


tried that too... still no x
bluejeans
Level 1
Level 1
 
Posts: 3
Joined: Sun Nov 18, 2007 5:01 am

Postby blu3ness on Sun Nov 18, 2007 8:46 pm

post some logs, it'll help :P
User avatar
blu3ness
Level 1
Level 1
 
Posts: 44
Joined: Sun Oct 28, 2007 1:07 am

Re: X doesn't want to work

Postby bluejeans on Wed Nov 21, 2007 3:23 pm

thanks blu3ness, sorry i'm a bit tardy.

i'm now sure that the problem lies in the the 3d display setting... ( i had an identical situation when booting mandriva yesterday, i got into xconf and disabled all 3d effects/support after which x worked fine) i am now looking for how to do the same in MINT... i don't see xconf, where is the setting in mint to disable 3d ???
bluejeans
Level 1
Level 1
 
Posts: 3
Joined: Sun Nov 18, 2007 5:01 am


Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 25 guests