No grub-entry after upgrading from Celena

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

No grub-entry after upgrading from Celena

Postby finndus on Wed Nov 21, 2007 7:14 am

I know, Clem warned to do this, but i did it...

Now the System won't boot because the only entry shown while booting is the 'memory check'-entry in grub's menu. Grub works, but without a boot-entry...no way.

Can somebody please show me how the entry has to look like? Or is there another way to get the necessary entry back?

Thanks a lot,

finndus
finndus
Level 1
Level 1
 
Posts: 8
Joined: Thu Mar 29, 2007 7:15 am

Linux Mint is funded by ads and donations.
 

Re: No grub-entry after upgrading from Celena

Postby gismondo on Wed Nov 21, 2007 2:06 pm

Use the Mint Live CD and see from there (/media/boot/grub/menu.lst) how your menu.lst should look like...
Anyway I think it's something like this:

# For Linux
title Linux Mint, kernel 2.6.22-14-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.22-14-generic root=/dev/sda1 ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
boot

# For Windows
title Microsoft Windows XP Professional
root (hd0,1)
savedefault
chainloader +1

You could have to change sda1 or hd0...It depends on how is your partiton table

Bye
gismondo
Level 1
Level 1
 
Posts: 12
Joined: Wed Nov 21, 2007 11:09 am

Re: No grub-entry after upgrading from Celena

Postby Guest on Wed Nov 21, 2007 7:18 pm

You could try RESTORE GRUB (use your HD and partition numbers)

1. Pop in the Live CD, boot from it until you reach the desktop.
2. Open a terminal window
3. Type "grub"
4. Type "root (hd0,6)", or whatever your harddisk + boot partition numbers are (my /boot is at /dev/sda7, which translates to hd0,6 for grub).
5. Type "setup (hd0)", or whatever your harddisk number is.
6. Quit grub by typing "quit".
7. Reboot

or download the SuperGrub Live CD:
http://linuxmint.com/forum/viewtopic.php?f=90&t=6875&p=43655#p43655

I hope one of these can get you out of your problem.
Guest
 

Re: No grub-entry after upgrading from Celena

Postby BakUp on Wed Nov 21, 2007 7:23 pm

That guest post was me !

Some how I got logged out :-)
User avatar
BakUp
Level 4
Level 4
 
Posts: 200
Joined: Sun Sep 23, 2007 9:20 am
Location: Minnesota USA

Re: No grub-entry after upgrading from Celena

Postby finndus on Thu Nov 22, 2007 3:05 am

BakUp wrote:That guest post was me !

Some how I got logged out :-)


Hi,

thanks a lot, I'll try tonight...

greetings,
finndus
finndus
Level 1
Level 1
 
Posts: 8
Joined: Thu Mar 29, 2007 7:15 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 19 guests