SOLVED /etc/default/grub: 38: Syntax error:

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

SOLVED /etc/default/grub: 38: Syntax error:

Postby blueXrider on Sat Aug 13, 2011 4:55 pm

root@ms-7032:~$ sudo update-grub
[sudo] password for root:
/etc/default/grub: 38: Syntax error: EOF in backquote substitution

Tried to install 2.6.38-11 kernel using package manager.

Now grub is broken

Following is etc/default/grub.cfg

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap
GRUB_CMDLINE_LINUX=" splash vga=799"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="1024x768x24"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
"GRUB_INIT_TUNE="480 440 1"
Last edited by blueXrider on Tue Aug 23, 2011 12:24 pm, edited 3 times in total.
User avatar
blueXrider
Level 2
Level 2
 
Posts: 74
Joined: Thu Jun 30, 2011 11:49 am

Linux Mint is funded by ads and donations.
 

Re: /etc/default/grub: 38: Syntax error:

Postby Roken on Sat Aug 13, 2011 6:53 pm

You are missing closing quotes at the end of GRUB_CMDLINE_LINUX_DEFAULT and you have a stray quote at the start of GRUB_INIT_TUNE
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: /etc/default/grub: 38: Syntax error:

Postby blueXrider on Wed Aug 17, 2011 11:22 am

Got it fixed, all better now. Thanks
User avatar
blueXrider
Level 2
Level 2
 
Posts: 74
Joined: Thu Jun 30, 2011 11:49 am


Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 11 guests