booting to live CD

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

booting to live CD

Postby morbiddog on Sun Dec 23, 2007 4:41 pm

ok so i am wanting to try out linux mint and i downloaded the live cd and burned the image to a disk and then when i boot to the disk it loads up the linux kernel and everything but when it is done loading linux mint i get an error telling me that it has to run in low graphics mode and that i can configure it to fix this or somthing along those lines. So i hit configure and i select the nvidia geforce 8 series under the driver select and then i hit ok but when i hit ok it just takes me back to this screen http://i212.photobucket.com/albums/cc11 ... x-boot.jpg if it helps at all my graphics card is a geforce 8800gt
and my mobo is an EVGA 680i revision A cpu is an intel core 2 duo E6750
morbiddog
Level 1
Level 1
 
Posts: 1
Joined: Sun Dec 23, 2007 4:30 pm

Linux Mint is funded by ads and donations.
 

Re: booting to live CD

Postby MagnusB on Sun Dec 23, 2007 4:57 pm

It doesn't look like there is anything wrong, but does it lock itself there? Alternatively you could use the vesa driver, and load nvidia driver after install, if that it was you want to do...
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: booting to live CD

Postby kody on Wed Jan 23, 2008 12:40 am

Ah! Found one! I knew there'd be another post with my problem. Problem is, there's no solution! :(

So, I also have an Nvidia 8800GT and am having this exact problem. It comes to this point after no problems with the splash screen or other drivers, flashes 3 times, then brings up the classic 'X' cursor on a blanked screen, then brings up an Ubuntu window stating
Ubuntu is running in low-graphic mode
Your screen and graphics card could not be detected correctly. To use higher resolutions, visual effects or multiple screens, you have to configure the display yourself.

Then there's a selection box where you can check "Always run in low graphics mode"
and three more buttons: "Configure...", "Shut Down", and "Continue".

The configure screen lets you manually pick your monitor, resolution, and graphics card. However, any route I take through that OR simply hitting "continue" end up right back at the same spot that the original post shows with his attached picture. It just sits there. I have the ability to switch to other windows (ctrl-alt-F2 etc), so the computer isn't hung.

I've also tried booting in with safe graphics mode, but that ends up with a failed boot into some sort of busybox thing.

Anyone with a solution?
Please?
Don't make me go back to Vista! Please! ;)
User avatar
kody
Level 1
Level 1
 
Posts: 18
Joined: Fri Apr 06, 2007 3:27 am
Location: North Vancouver, BC, Canada

Re: booting to live CD

Postby kody on Wed Jan 23, 2008 12:59 am

Did some more reading on the wiki and found this...
Problems with the video card and its drivers

This is solved for Cassandra (and Ubuntu 7.0.4) as "Safe graphics mode" now works as it should!

The boot process goes on for a while, you probably see some garbled image on you screen and shortly thereafter you (probably) hear a little sound, but the boot ends with a blank screen This is due to the Xserver not being started, and here follows a solution to that. It is unfortunate that so popular video cards as nVidia 6600 & 8800 (all versions) and some popular ATI cards have this problem.

The reason for it is that the Live CD is using the wrong graphics drivers. When the live CD starts up press F6 and delete the "quiet splash --" ending and type in "break=bottom", then boot with this. If you end up in a "busy box" or so, reboot and type in "break=top" instead.

One member of the forum reported that "break=button" helped - this is really absurd, but worth mentioning.

This will get rid of the Mint/Ubuntu splash screen and stop half way through booting with a command prompt (ignore any error messages for now). This is caused by a bug that discards the setting "Safe graphics mode" (which is vesa) if the card is recognized - in the case of nvidia the driver vesa is replaced with "nv" when X starts.


Which one of these options worked for me? The absurd one! removing quiet splash and adding break=button worked, while the break=top and break=bottom options both resulted in a busybox. For fun, if I typed exit in the busybox, the boot would still continue up until the exact same failure point.

So, CD is booted now... do I risk installing it? :roll:
User avatar
kody
Level 1
Level 1
 
Posts: 18
Joined: Fri Apr 06, 2007 3:27 am
Location: North Vancouver, BC, Canada

Re: booting to live CD

Postby MagnusB on Wed Jan 23, 2008 9:48 am

There is always a risk that if you install with so much troubles it could fail at some point, but I doubt you could totally brick your computer by installing, meaning you can try something else if it fails. I would suggest having a CD, you know to work, in backup if you try to install.
But it could also solve most of the troubles by installing a complete copy to hard drive, it is hard to say...
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: booting to live CD

Postby kody on Wed Jan 23, 2008 2:44 pm

I managed to install without issues. It kept using the vesa driver though.

Now that I've manually installed the latest Nvidia driver (envy didn't work), I'm good to go. Just have to figure out how to properly configure dual monitors... :roll:
User avatar
kody
Level 1
Level 1
 
Posts: 18
Joined: Fri Apr 06, 2007 3:27 am
Location: North Vancouver, BC, Canada


Return to Installation & Boot

Who is online

Users browsing this forum: beanwl, BenBRockN, PatH57 and 13 guests