Complete Newb To Linux Needs Help

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Complete Newb To Linux Needs Help

Postby RonPrower on Mon Jan 07, 2008 1:02 am

All right I don't know if this is the correct forum or not, but I have had problems getting the LiveCD to run and after checking the Wiki and trying to search through the forum I have turned up no solutions to solve this problem.

I downloaded the full version of 4.0 to my computer and burned it to disk making sure the md5 was exactly the same as indicated, it was.

When I boot the CD everything loads fine until I tell it to boot or boot in safe graphics mode. The first solution I tried was the remove the "quiet splash --" option which I did. When I ran it through I would get the following odd error:

end_request I/O error dev fd0 sector 0

It will eventually continue through a series of odd commands and outputs until the system just restarted without notice.

I also tried leaving the quiet splash -- option on and adding the noapci and various other incarnations of it as indicated on the wiki. Whether with them or without and no matter which mode I choose I would get the following error:

ata1.01:exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata1.01:cmd 08/00:08:00:00:00/00:00:00:00:00/f0 tag 0 cdb 0x0 da ta 4096 in

It just keeps repeating over and over and never gets anywhere. I'm really upset because I want to give this OS a try any ideas on what the problem is? My computer is as follows:

BIOS: AMI 062710
MoBo: PC Chips M810MLR
Processor: AMD K7 1.0GHz
Memory: 496MB
Graphics: SiS 730 internal graphics card running at 16MB
Sound: SoundBlaster 16PCI
RonPrower
Level 1
Level 1
 
Posts: 2
Joined: Mon Jan 07, 2008 12:38 am

Linux Mint is funded by ads and donations.
 

Re: Complete Newb To Linux Needs Help

Postby atlef on Mon Jan 07, 2008 7:30 am

When I boot the CD everything loads fine until I tell it to boot or boot in safe graphics mode. The first solution I tried was the remove the "quiet splash --" option which I did. When I ran it through I would get the following odd error:


Do not know if it helps, but try to only remove splash, not quiet.

Atlef
User avatar
atlef
Level 4
Level 4
 
Posts: 306
Joined: Sun Nov 18, 2007 8:20 am
Location: Stavanger NORWAY

Re: Complete Newb To Linux Needs Help

Postby Husse on Mon Jan 07, 2008 7:44 am

I can tell you immediately what the root of your trouble is - it's your motherboard. I suspected that already before I saw your specs - PC Chips is crap (For legal reasons - this is my expert opinion, but not necessarily official Mint policy)
Do you use SATA? If so you have to check the settings for it in BIOS, to tell you what/how I'd have to see the BIOS as I can't find a manual. There should be DMA/PIO mode settings for ATA but for SATA I don't think there is much that is possible to configure. (Possibly legacy)
Why do I suspect your motherboard?
First off because of this error "end_request I/O error dev fd0 sector 0" fd0 is the floppy and this may indicate something with the mobo as the live CD does not in any way tinker with the floppy.
Second and most importantly because of the two other error messages which both begin with ata1 which indicates problems with the IDE (or ATA) controller
Sorry but that's how it is
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Complete Newb To Linux Needs Help

Postby RonPrower on Mon Jan 07, 2008 9:28 am

I'm using the basic IDE cables with my computer. The BIOS has basically no control over any settings with any of the controllers. There are 2 HDDs connected to one IDE and 2 burner drives on the other. The system does seem to try and read the floppy drive when it's trying to boot into Mint for quite a while. Is there a workaround for this, like removing the floppy all together? Or am I just out of luck?
RonPrower
Level 1
Level 1
 
Posts: 2
Joined: Mon Jan 07, 2008 12:38 am

Re: Complete Newb To Linux Needs Help

Postby Husse on Mon Jan 07, 2008 12:16 pm

I don't know if removing the floppy would help. The live CD simply does not utilize it.
But this may help
Never have two hard disks on the same IDE controller - it can work, but ...
So put the slave disk as master on the second IDE and move the master burner as slave to the first IDE or any way you find simple, so that you end up with one hard disk (master) and one optical unit (slave) on each IDE channel. There's a chance it may help as the error message is a bout ata1
If it does not work, temporarily have only the hdd connected to the first IDE channel during installation.
If and when everything is done connect it. Then you have to adjust fstab accordingly - study it and copy the line for the existing burner, but increase it's "dev number" by one. I think that'll work if you get that far
I know that many PC Chips motherboards have an IDE controller that is not Linux friendly
Don't hesitate to ask for help if I'm too "technical"
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Complete Newb To Linux Needs Help

Postby Fred on Mon Jan 07, 2008 3:23 pm

Also, try to remove the floppy from the boot sequence in the bios.... if it will let you.

You might also try to make sure that the bios is set up to boot first from the cd rom drive you are trying to boot from.

Good luck

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 7 guests