Booting stuck on kernel [Linux Mint 12]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Booting stuck on kernel [Linux Mint 12]

Postby timemaster on Tue Jan 10, 2012 6:55 am

Hi there, I love linux mint and I have no problem with it on some other computers,but I am not able to run the installation on laptop HP elite book 8560w. Booting of live cd stopped after kernel initialization output without errors, just stay on black screen.. I expected the start of init, but nothing :( Compatibility mode behaves the same.. I tried again to burn dvd again, but without success :(



Please help


TM
timemaster
Level 1
Level 1
 
Posts: 2
Joined: Tue Oct 06, 2009 12:33 pm

Linux Mint is funded by ads and donations.
 

Re: Booting stuck on kernel [Linux Mint 12]

Postby xenopeek on Tue Jan 10, 2012 7:35 am

Can you share which graphics chip is in this laptop? The HP elite book 8560w isn't a specific laptop, but a range of laptops that come with different flavors of graphics cards. Or please share the exact model name, like HP elite book 8560w LY526EA.

You may try pressing a key during the countdown screen at boot, then pressing Tab to edit boot parameters, and then replace "quiet splash" on the line with "nomodeset". Then continue the boot to see if this helps, or at least lets you see some error.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Booting stuck on kernel [Linux Mint 12]

Postby a123 on Mon Jan 16, 2012 3:34 pm

You are not alone and I too share your problem. I have an HP 8560w and it won't boot Linux mint. I have done some checking and it looks like many people are having problems with HP 8560w running linux (see https://bugs.launchpad.net/ubuntu/+sour ... bug/870071 and http://phoronix.com/forums/showthread.p ... se-Mint%29 ).

I bought this machine specifically because HP and CostCentral indicated it would run Linux, but not really. Some post suggest you can run it in nouveau.modeset=0 boot, but I was only able to get the machine to do that in a different distro.

I have decided to ask CostCentral and HP to take the machine back. It is unfortunate because it has huge horsepower, and excellent for CAD, but it doesn't meet my needs for running Linux.

If you can figure out how to get this to work in nouveau.modeset=0 boot, please let me know. I can't figure it out.
a123
Level 1
Level 1
 
Posts: 2
Joined: Mon Jan 16, 2012 2:57 pm

Re: Booting stuck on kernel [Linux Mint 12]

Postby mads on Mon Jan 16, 2012 3:55 pm

a123 wrote:...If you can figure out how to get this to work in nouveau.modeset=0 boot, please let me know. I can't figure it out.

How to add kernel parameter "nouveau.modeset=0" to kernel line before booting:
1. Start from live DVD and click ENTER to see GRUB menu
2. Highlight the Linux Mint entry and press the 'e” key to edit the boot command before booting
3. Use the cursor keys to navigate to the line that ends with "quiet splash", and add nouveau.modeset=0 after quiet splash
4. When you are done editing the kernel line, press Ctrl-x to boot

@ edit
Changed a few details (see next post by Vincent)
1. Start from live DVD and click ENTER to see GRUB menu
2. Press the 'Tab' key to edit the boot command line
3. Use the cursor keys to navigate to "quiet splash", and add nouveau.modeset=0 after quiet splash
4. When you are done editing the kernel line, press Ctrl-x to boot
Last edited by mads on Mon Jan 16, 2012 4:58 pm, edited 1 time in total.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Booting stuck on kernel [Linux Mint 12]

Postby xenopeek on Mon Jan 16, 2012 4:04 pm

@ mads, those instructions are for adding kernel parameters to an installed Linux Mint. From the DVD you have to press Tab (not 'e') to edit boot parameters, and you only get one line to edit.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Booting stuck on kernel [Linux Mint 12]

Postby mads on Mon Jan 16, 2012 4:17 pm

Vincent Vermeulen wrote:@ mads, those instructions are for adding kernel parameters to an installed Linux Mint. From the DVD you have to press Tab (not 'e') to edit boot parameters, and you only get one line to edit.

Thanks Vincent. :)
I have edited my post to reflect your corrections.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Booting stuck on kernel [Linux Mint 12]

Postby t2dcarla on Sat Jan 21, 2012 3:52 pm

Thanks for the advise to use nouveau.modeset=0. It got the Live CD to boot but after install I'm having a similar problem. The machine boots up but hangs with a black screen. I think all this is related to my nvidia graphics card. Anway, how do I modify the grub boot loader to include the nouveau.modeset=0 option after install? I should note that I don't ever see the grub menu and that I selected "auto login" during the install which in retrospect is probably a mistake.

Thanks
t2dcarla
Level 1
Level 1
 
Posts: 4
Joined: Thu Nov 03, 2011 11:53 am

Re: Booting stuck on kernel [Linux Mint 12]

Postby mads on Sat Jan 21, 2012 4:33 pm

t2dcarla, you need to edit /etc/default/grub file:

Before:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
After:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

And then update grub:
sudo update-grub
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Booting stuck on kernel [Linux Mint 12]

Postby t2dcarla on Sat Jan 21, 2012 5:13 pm

mads,
Thanks for the info. Forgive my ignorance but how do I "sudo update-grub" if I can not get to a command line because the machine hangs on boot? I can boot to Lubuntu on a usb so that I can see the target boot drive with the grub config files on it however.

Thanks.
t2dcarla
Level 1
Level 1
 
Posts: 4
Joined: Thu Nov 03, 2011 11:53 am

Re: Booting stuck on kernel [Linux Mint 12]

Postby t2dcarla on Sun Jan 22, 2012 4:59 pm

Still hung up on this issue. Anyone with experience on changing grub configurations that reside on a disk other than the one that you've booted to? Thanks.
t2dcarla
Level 1
Level 1
 
Posts: 4
Joined: Thu Nov 03, 2011 11:53 am

Re: Booting stuck on kernel [Linux Mint 12]

Postby t2dcarla on Sun Jan 22, 2012 4:59 pm

Still hung up on this issue. Anyone with experience on changing grub configurations that reside on a disk other than the one that you've booted to? Thanks.
t2dcarla
Level 1
Level 1
 
Posts: 4
Joined: Thu Nov 03, 2011 11:53 am

Re: Booting stuck on kernel [Linux Mint 12]

Postby stigen on Fri Mar 30, 2012 8:19 pm

Same issue on an HP Elitebook 8760w, NVidea card, 64 bit CPU and 64 bit Mint version 12, Live DVD
But I could resolve the problem by following this installation procedure:

- boot from Live DVD and bring up the boot menu
- in de boot menu, press tab. Add the following boot option: nouveau.modeset=0
- boot using those settings
- Live CD was booted, with minimal graphics resolution
- Install Linux Mint
- After installation: "Continue testing" (DO NOT YET REBOOT)
- open a terminal

do the following in the terminal

chroot:
$ sudo mount /dev/rootdevicename /target
[only if you installed /boot on a different partition] $ sudo mount /dev/bootdevicename /target/boot
$ sudo mount --bind /dev /target/dev
$ sudo mount --bind /dev/pts /target/dev/pts
$ sudo mount --bind /proc /target/proc
$ sudo chroot /target

now, install all updates on the system just installed:
$ sudo apt-get update
$ sudo apt-get upgrade
(could take a while)
$ sudo reboot

remove the Live DVD cdrom (to boot from hard disk)

You get the boot menu in the boot loader on your HDD
Press e to edit the comand line options.
Look for the line which boots linux, (contains quiet and splash words)
add nouveau.modeset=0 on that same line
F10 to boot

Now, Mint boots from your Hard Disk, but still with minimal graphics resolution.

After booting, A hardware icon appearch in the top bar. When clicked, Mint proposed to install proprietary NVIDEA drivers. After installing those, on my system, Linux Mint 12 could be started from the boot menu, without adding the nouveau.modeset=0.
And Linux Mint booted with full resolution capabilities.

So I guess this was all a driver issue...
stigen
Level 1
Level 1
 
Posts: 1
Joined: Fri Mar 30, 2012 8:03 pm

Re: Booting stuck on kernel [Linux Mint 12]

Postby mauromol on Tue Jun 05, 2012 2:58 am

I faced the same problem with Linux Mint 12 LXDE and an ancient Graphics Blaster Riva TNT graphics card.

Here is how I solved it (thanks to this thread and http://ubuntuforums.org/showthread.php?t=1613132):

- to install, I followed the directions in this thread; that is, when booting from the CD-ROM, I pressed Enter to make the boot menu appear, pressed TAB to show the boot options and added nomodeset (separated by a space) as the last entry of the line; then, I pressed Enter to start the boot process
- after installing, to avoid the same problem to happen when booting from the hard disk, I solved in this way: after the POST phase of the BIOS, holding down the SHIFT key makes the GRUB menu to show up; then, pressing "e" on the first menu item shows you the GRUB options to boot from the hard disk; the kernel boot options are shown in the line that starts with "linux /boot"; after moving the cursor to that line and pressing End to go to its end, I added nomodeset as the last parameter (separated by a space); then I pressed F10 to let the boot process continue

In this way, also booting from the hard disk worked. Then, I applied the suggestions given here to make GRUB pass the nomodeset boot parameter to the kernel by default, that is I edited /etc/default/grub and added nomodeset (separated by a space) as the last parameter of the GRUB_CMDLINE_LINUX_DEFAULT line. Then, I ran sudo update-grub to apply the change.

Unfortunately, with my video card there seems to be no proprietary video driver available to avoid to apply the nomodeset parameter. Video performance is really poor, however at least the default nouveau driver is recognizing the maximum refresh rate of my CRT monitor in the correct way (I think it's the first time I see a Linux distribution to get it right with that monitor, without forcing me to play with the modelines of the X.org configuration!!).

By the way, is there any difference between using nomodeset and nouveau.modeset=0?

Mauro.
mauromol
Level 1
Level 1
 
Posts: 31
Joined: Wed Jul 13, 2011 6:46 am
Location: Pino Torinese (TO) - Italy

Re: Booting stuck on kernel [Linux Mint 12]

Postby mauromol on Fri May 24, 2013 9:35 am

After a long time I found a better solution to my own problem with an ancient nVidia Riva TNT graphics card (Creative Graphics Blaster Riva TNT).
Using nomodeset fixes the hang at startup, but disables KMS, hence the nouveau framebuffer driver will not be used at all (see: http://nouveau.freedesktop.org/wiki/KernelModeSetting/).

I've found my problem is due to this bug: https://bugs.freedesktop.org/show_bug.cgi?id=27211
The better solution is the one suggested there, that is to use "nouveau.noaccel=1" kernel boot parameter rather than "nomodeset". In this way I can at least have a high definition console, although I've not tested if this will also cause some better performance in X (right now, with this driver I'm using a derivative of a Debian Squeeze distribution with no X server at all, while at the time I initially wrote here I was using a Linux Mint 12 LXDE distribution).

So, for what I can say, I think that the actual problem should be fixed in newer distributions (which ship newer kernel versions).
However, if you still need to use an old distribution, like Mint 12 o Debian Squeeze, use "nouveau.noaccel=1" kernel boot parameter, otherwise "nomodeset" as a last option.
mauromol
Level 1
Level 1
 
Posts: 31
Joined: Wed Jul 13, 2011 6:46 am
Location: Pino Torinese (TO) - Italy

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: austin.texas, Mark Phelps and 11 guests