Mint wont read XD card

Forum rules
Before you post please read this

Mint wont read XD card

Postby Vociferous666 on Sat Feb 02, 2008 2:37 am

Specs:
Linux Mint 4.0 Daryna
Compaq Presario v2630us
Texas Instruments Card Reader
AMD Turion
512 MB RAM
ATI graphics

everything on the system except the card reader works fine

ok so when i insert an XD picture card the status light blinks once and then does nothing,
the computer recently had XP on it and XP read the XD card
however, when i inserted an SD card into the slot, the status light lit up and blinked and the card popped up on the mint desktop.

linux will not automatically mount the volume.
i cant find how to manually mount the volume.
when i did LSPCI in terminal i get this:

05:09.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
05:09.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
05:09.4 Generic system peripheral [0805]: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller

i am running the same linux on my laptop
Ricoh card reader
nVidia graphics

AMD Turion X2
dual boot XP MCE
mine will not read the card either, but when i boot to XP it asks if i want to format the card

i inserted the card into a newer compaq laptop running xp pro and it read the card just fine

how can i know if linux even sees the card?

how can i manually mount the card and activate the volume? its fat32

if none of this works, is it possible to reinstall/recompile the drivers?

is the driver in more than one part, could the XD driver be screwed if SD works fine on the same reader?

im very curious about all of these things.
Vociferous666
Level 1
Level 1
 
Posts: 9
Joined: Sat Feb 02, 2008 2:28 am

Linux Mint is funded by ads and donations.
 

Re: Mint wont read XD card

Postby alvaro.sim on Sat Feb 02, 2008 5:59 am

when you plug in the card reader you sould see with dmesg something like
Code: Select all
[45289.532000] sd 3:0:0:0: [sdc] Attached SCSI removable disk
[45289.532000] sd 3:0:0:0: Attached scsi generic sg3 type 0
[45289.532000] sd 3:0:0:1: [color=#FF0000][sdd][/color] Attached SCSI removable disk
[45289.532000] sd 3:0:0:1: Attached scsi generic sg4 type 0
[45289.532000] sd 3:0:0:2: [sde] Attached SCSI removable disk
[45289.532000] sd 3:0:0:2: Attached scsi generic sg5 type 0
[45289.536000] sd 3:0:0:3: [sdf] Attached SCSI removable disk
[45289.536000] sd 3:0:0:3: Attached scsi generic sg6 type 0
[45289.536000] sd 3:0:0:4: [sdg] Attached SCSI removable disk
[45289.536000] sd 3:0:0:4: Attached scsi generic sg7 type 0


after you see where the card is binded to try to mount it with mount command :)
alvaro.sim
Level 1
Level 1
 
Posts: 13
Joined: Sun Jan 27, 2008 1:46 pm
Location: Paris

Re: Mint wont read XD card

Postby Vociferous666 on Sat Feb 02, 2008 4:27 pm

ok all i see in dmesg is this:

[ 174.168000] tifm_core: SmartMedia/xD card detected in socket 0:2

the card reader is actually built into the computer.
so i did dmesg and looked through and didnt see nething, then i put the card in and did another dmesg and that line i jut pasted in here was the only thing added to the end of the output of dmesg
Vociferous666
Level 1
Level 1
 
Posts: 9
Joined: Sat Feb 02, 2008 2:28 am

Re: Mint wont read XD card

Postby alvaro.sim on Sat Feb 02, 2008 5:29 pm

well try ti put the card on the reader then do a
Code: Select all
fdisk -l

you should see the partition
alvaro.sim
Level 1
Level 1
 
Posts: 13
Joined: Sun Jan 27, 2008 1:46 pm
Location: Paris

Re: Mint wont read XD card

Postby Vociferous666 on Sun Feb 03, 2008 4:11 pm

fdisk -l didnt do nething as far as i can see.
i did fdisk -l and started up gparted, but it still didnt see the memory card.
i tried to read the xd card in my own machine running mint also but using the Ricoh built in card reader doing all the same things, but my computer doesnt even recognize the card being inserted.
it does see my sd card when i insert that.
i dont think the card reader hardware even sees the xd card.
the light doesnt even blink or anything.
in the compaq computer the light at least blinks and i can see a change in dmesg.
how can i rebuild the drivers?
is there a way to find a more complete driver?
Vociferous666
Level 1
Level 1
 
Posts: 9
Joined: Sat Feb 02, 2008 2:28 am

Re: Mint wont read XD card

Postby lfelipe on Wed Jul 16, 2008 7:19 pm

I am having the same problem...the only difference is that it's a Memorystick ProDuo, not XD card.

I have an Acer TravelMate 5710-6013, with Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD), running Mint 5 - Elyssa.

How can I make it to mount the card?
User avatar
lfelipe
Level 1
Level 1
 
Posts: 9
Joined: Fri Feb 16, 2007 8:09 pm
Location: Brazil

Re: Mint wont read XD card

Postby T J Tulley on Fri Jul 18, 2008 9:08 am

I don't know whether this will help here, but I found (after some difficulty mounting a Fujifilm DCR2-161 card reader) that an xD card is filetype MSDOS. My long story is in the Hardware Support forum, Topic:
Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

[SOLVED] Re: Mint wont read XD card

Postby lfelipe on Mon Jul 21, 2008 6:05 pm

People,

I found this tutorial searching the net:
https://bugs.launchpad.net/ubuntu/+sour ... bug/222557

Doing exactly what is said there, my MemoryStick Pro Duo is now mounting just fine.

Just do these steps:

svn co -r155 http://svn.berlios.de/svnroot/repos/tif ... nk/driver/
cd driver/
wget http://www.sw83.de/misc/tifm_ms.patch
patch -p0 < tifm_ms.patch
make
sudo make install

And restart the computer. It must mount your card automatically.
User avatar
lfelipe
Level 1
Level 1
 
Posts: 9
Joined: Fri Feb 16, 2007 8:09 pm
Location: Brazil

Re: Mint wont read XD card

Postby seabreeze on Tue Sep 29, 2009 4:54 pm

Sorry to drag this back from over a year ago, but I am having the same problem with a card reader.

The link above in -
wget http://www.tu-chemnitz.de/~sweh/tifm_ms.patch
doesn't seem to be there any more.

Most of these and other posts I've read about solving this are dated mid- to late-2008. Later there are comments that this issue has been solved in kernel 2.6.31-10.32. I notice I'm using 2.6.28.11-generic (Gloria).

Any suggestions?
seabreeze
Level 1
Level 1
 
Posts: 43
Joined: Wed Sep 23, 2009 6:17 am
Location: Dunedoo - New South Wales - Australia

Re: Mint wont read XD card

Postby T J Tulley on Tue Sep 29, 2009 5:52 pm

I contributed to this topic and after a struggle it was solved. That was using Elyssa about a year ago - since then Gloria has been installed and I hadn't used the cardreader since then until now.

I've just connected it to a USB drive and it is working fine.

I opened Computer and with a card inserted it shows there as 2.1 GB Media - I double-clicked on it and it then mounted and shows on the desktop. Double-click there shows first the folder of images on the card, named DCIM. Then that opens to show the folder 100_Fuji since it's a Fuji camera. Finally that opens to show the individual image files. They open with Eye of Gnome Image Viewer, which is part of Gloria.

Hope this helps. My cardreader is Fujifilm DCR2-161
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: Mint wont read XD card

Postby seabreeze on Tue Sep 29, 2009 6:11 pm

I've tried a few things, following posts, and I did find that file uploaded elsewhere. Now that I've rebooted the reader now works. The downside is I really don't know which of the procedures was the solution. :oops:

There are now about 20 files in my /driver directory starting with tifm, flash, xd, etc. Talk about stumbling around in the dark.
seabreeze
Level 1
Level 1
 
Posts: 43
Joined: Wed Sep 23, 2009 6:17 am
Location: Dunedoo - New South Wales - Australia

Linux Mint is funded by ads and donations.
 

Return to Mounting Partitions

Who is online

Users browsing this forum: No registered users and 2 guests