Full of Problem, need a help please...

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Full of Problem, need a help please...

Postby wa2n on Sat Feb 09, 2008 8:38 am

Hi...

I really don't understand, currently I'm trying to install Cassandra 3.0 on my computer. But problems keep on showing...
After installation progress, I can't reboot into GNOME. Linux says that my root partition is currently in read-only mode and need to run fsck manually, so I do the following:
# mount -n -o remount,rw /
# fsck
Then I can go into my GNOME without problem, though I still don't understand because I never seen this problem before.
But there is still problems, when I hit the Ctrl+Alt+Backspace key, my GNOME dissappear and it only shows me a blue screen with these messages :
"Could not start the X server (your graphical environment) due to some internal error. Please contact your system administrator or check your syslog to diagnose. In the meantime this display will be disabled. Please restart gdm when the problem is corrected.".
Then I restart my computer, but the Linux says that my root partition is in read-only mode (again). I'm not sure what is happening, so I try to restart my computer again. But then guess what? I LOST MY GRUB!!!!

It says "GRUB Error 17", so I can't use my Linux. Actually I've tried to install it again, but these problem keeps on showing after I hit the Ctrl+Alt+Backspace key... Can anyone explain to me what is happened here? What should I do?

I really confused and a little stress right now, please answer me with a clear answer since I'm not an expert on Linux.
Any help would be greatly appreciated.
Thanks...
wa2n
Level 1
Level 1
 
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Linux Mint is funded by ads and donations.
 

Re: Full of Problem, need a help please...

Postby Husse on Sat Feb 09, 2008 3:56 pm

If it was not for
root partition is in read-only mode

I would say you've ended up in UUID hell
http://www.linuxmint.com/wiki/index.php ... _a_problem
root partition is in read-only mode rings a bell, I think I've done something in that area but can't find it
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Full of Problem, need a help please...

Postby wa2n on Sun Feb 10, 2008 10:48 pm

Thanks Husse, but what should I do then? :cry:

The problem starts after I hit the Ctrl+Alt+Backspace key, it doesn't restart the GNOME and I got an error message
"Could not start the X server bla bla bla....". After restart it, it seems like my root partition is not detected (unknown partition) and it gives me an error message "GRUB error 17". It happens even I started with a fresh installation.

Any suggestion ?
Thanks...
wa2n
Level 1
Level 1
 
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Re: Full of Problem, need a help please...

Postby newW2 on Mon Feb 11, 2008 12:43 am

It is something that can be fixed. You could use Supergrub disk; and if you get the machine to boot you'll need to make sure that fstab and grub menu list are correct afterward. Or you can do this with the Live Cd and a few easy cli commands in terminal.

So as Husse and the wiki tell you, boot using the live cd. Also as Husse has written in the wiki, the disks should be mounted and if not you can do so using Gparted.

Once you have booted, and verified that the drives are mounted, open a terminal and do the following:
Code: Select all
sudo vol_id /dev/sdbx -u

Where x is the location of the offending partition. This cli entry will display the UUID you need to change (note it's a good idea to run the command (sudo_vol_id /dev/partition-you-want-the-vol-id-of -u) for all the disk numbers to have them handy because you need to change those that are listed wrong in fstab (see following for ftab).

Once you have all the UUID's written down, enter the following in the terminal:
Code: Select all
sudo gedit /etc/fstab

This will list the fstab file and you'll find, at the very least, that your root "/" mount point uuid in fstab is different than the one listed by the vol_id command. Replace the UUID for the offending partition or partitions with the uuid's you got from vol_id command.
Looks like fun? Actually, you'll see that many people (including me) tell you to use device names for the partitions and forget the uuid. Device names don't care about uuid volume ids. So once you get booted into your installed Linux Mint DE, you'll want to edit the grub menu list file and the fstab file as suggested in the wiki. That is unless you like trying to correctly enter those uuid values. Just get rid of them.
Here's an example fstab using the uuid. It is followed with an edit to remove the uuid for each device (partition) name. The device names are already there in the fstab file, they are commented out with the # symbol. Remove the # symbol in front of the device name, and delete the uuid; leaving the mount point and the rest of the line. Repeat for the rest of the partitions.

Example using UUID volume identifier in fstab:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=e8e008a4-8c6b-4db0-8729-b337eb747078 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda2
UUID=96493987-17df-478e-9611-05c54204502c /home ext3 defaults 0 2
# /dev/sdb1
UUID=74a5c397-c764-426e-8498-f43c8df06c1d none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/hdb /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0

What the above fstab looks like after deleting the UUID volume identifier for the partition:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 / ext3 defaults,errors=remount-ro 0 1
/dev/sda2 /home ext3 defaults 0 2
/dev/sdb1 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/hdb /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0

Have fun.
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Re: Full of Problem, need a help please...

Postby wa2n on Mon Feb 11, 2008 3:08 am

Thanks newW2,
but it seems like Linux didn't recognize my root partition, and while I'm running via liveCD I can not mount my root partition,
so I can't access those files. I asked uncle Google about this "GRUB error 17" and I found that it happened because Linux didn't recognize the root/boot partition.
Since I can't access these files, what should I do then?
wa2n
Level 1
Level 1
 
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Re: Full of Problem, need a help please...

Postby Husse on Mon Feb 11, 2008 7:13 am

via liveCD I can not mount my root partition,

Sure about that?
Open gparted from the menu - that will mount the partitions
On the other hand
do you manage to boot and this happens when you restart X?
Then the problem is something else (or not)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Full of Problem, need a help please...

Postby wa2n on Mon Feb 11, 2008 7:42 am

I am really sure, I have opened the gnome partition manager and I can see my root partition, but Linux says it as an unknown partition. I think this is the main problem that make my Linux can't find the GRUB.
No Husse, I still didn't manage to boot. Or maybe the problem is on the hardware, maybe its VGA Card?
I will try to change my VGA Card and try a new installation, hope this will works.

Anyway, thank you for your replies.
wa2n
Level 1
Level 1
 
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Re: Full of Problem, need a help please...

Postby AlexSlocker on Mon Feb 11, 2008 11:12 am

Is the computer hard drive recent? I mean, I've had this similar problem. On the place I used to work we use GNU/Linux as well. One day a sudden electric shutdown made the file system corruptes. From that day it happened something similar two more times and we always thought it was about the electric shutdown. Finally we get to the conclusion that it must be the hard drive, because we notice always the problem in the same sectors, and we try different distros as well (Fedora, Ubuntu and Linux Mint). Also when doing certain task the hard drive sounds like 'scratching', I know all the hard drives scratch in some moments, but this one does almost every time you open a folder.

My idea, based on that experience, is that your hard drive might be broken, perhaps in the first sectors, included MBR and some others. And the problem when you hit Ctrl + Alt + Backspace might be that the system cannot read xorg.conf properly. I know these generate weirder questions like, ok, but if the hard drive is broken, why it boots for the very first time? I have no answer, but this is the most logical solution I can figure.

As an advice, try other distros or operative systems and see if the problem is there as well. Do not test Ubuntu, because, as long as Linux Mint is based on it, the errors LM might have, may be in Ubuntu also.

I hope you'll find the problem.
AlexSlocker
 

Re: Full of Problem, need a help please...

Postby wa2n on Mon Feb 11, 2008 11:03 pm

Thank you AlexSlocker, it means that I really need to backup my data first, before it's too late.
I will try to install it with another distros, or maybe try with another harddisk drive and give a report about the results.

Thanks
wa2n
Level 1
Level 1
 
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Re: Full of Problem, need a help please...

Postby newW2 on Mon Feb 11, 2008 11:25 pm

Force mount of all drives in fstab:
sudo mount -a force

Of course Super Grub Disk (SGD). I did see that you had tried SGD:
http://sgd.benjamin-butschko.de/?section=download

RESTORE GRUB IN 3 STEPS
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 32 guests