GRUB after changing Win 2000 to XP

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

GRUB after changing Win 2000 to XP

Postby themad on Mon Feb 25, 2008 6:33 am

I had Windows 2000 and Mint Linux, and I changed Windows 2000 on XP. To get GRUB back, I fixed GRUB with Mint Live CD and GRUB worked, Mint is booting succesfully, but when I try to boot Windows XP, there is an error. I can't boot it. I also tried to restore GRUB by Super Grub Disk, but there is the same error.
When I restore Windows's MBR by Super Grub Disk, Windows is booting normaly (but there isn't GRUB loading).

How could I do (without re-installing Mint) to make GRUB with Windows XP?

sudo fdisk -l
Code: Select all
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe5aae5aa

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               2        2432    19527007+   f  W95 Ext'd (LBA)
/dev/sda2            2433        2681     2000092+  82  Linux swap / Solaris
/dev/sda3            2682        5171    20000925   83  Linux
/dev/sda4   *        5172        9729    36612135    b  W95 FAT32
/dev/sda5               2        2432    19526976    b  W95 FAT32


cat /boot/grub/menu.lst
Code: Select all
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
default         0

gfxmenu=/etc/grub/message.mint

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout         10

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title         Windows 95/98/NT/2000
# root          (hd0,0)
# makeactive
# chainloader   +1
#
# title         Linux
# root          (hd0,1)
# kernel        /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sda3 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,2)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## ## End Default Options ##

title           Linux Mint, kernel 2.6.22-14-generic
root            (hd0,2)
kernel          /boot/vmlinuz-2.6.22-14-generic root=/dev/sda3 ro quiet splash
initrd          /boot/initrd.img-2.6.22-14-generic
boot

title           Linux Mint, kernel 2.6.22-14-generic (recovery mode)
root            (hd0,2)
kernel          /boot/vmlinuz-2.6.22-14-generic root=/dev/sda3 ro single
initrd          /boot/initrd.img-2.6.22-14-generic
boot

title           Linux Mint, kernel memtest86+
root            (hd0,2)
kernel          /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title           Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title           Microsoft Windows 2000 Professional
root            (hd0,0)
savedefault
makeactive
chainloader     +1
Sorry for my English
themad
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 25, 2008 6:12 am

Linux Mint is funded by ads and donations.
 

Re: GRUB after changing Win 2000 to XP

Postby gismondo on Mon Feb 25, 2008 7:17 am

What kind of error do you get when you try to boot windows??
Then, did you try reinstalling Grub after having fixed Windows MBR (with Super Grub Disk or with fixmbr from WinXP Cd)??
To install Grub...
http://www.gnu.org/software/grub/manual ... stall.html
gismondo
Level 1
Level 1
 
Posts: 12
Joined: Wed Nov 21, 2007 11:09 am

Re: GRUB after changing Win 2000 to XP

Postby Husse on Mon Feb 25, 2008 7:20 am

I don't see anything that's wrong
And my menu.lst has the following to boot XP
Code: Select all
# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1

And that's what you have except for title which is irrelevant
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: GRUB after changing Win 2000 to XP

Postby themad on Mon Feb 25, 2008 4:06 pm

It's error 12: Invalid device requested.

Title isn't important. I could also write there "System which is destroying computer" (I think)
Sorry for my English
themad
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 25, 2008 6:12 am

Re: GRUB after changing Win 2000 to XP

Postby Fred on Mon Feb 25, 2008 11:54 pm

themad,

Your english is fine. :-)

Lets try this. Fix your Windows install back so it boots directly into Windows.

Now use your Supergrub disk to boot into Mint. Don't try to "fix" anything with Supergrub. Just use it to boot into Mint.

Look in the menu and find a program called Gparted. Open that program and post a screen shot of your partition table.

If you haven't changed your menu.lst since you posted it, that should give us the information we need to make everything work. Hopefully. :-)

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA


Return to Installation & Boot

Who is online

Users browsing this forum: robdog, Rush and 9 guests