mint not booting properly at all

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

mint not booting properly at all

Postby timmmy on Wed Feb 27, 2008 8:07 am

Posted this at the end of a thread i was reading earlier on but i think my problem may be different so, new thread!

HI,

having same problem as above but cant seem to solve it with what i've found so far. I can only get to a command line by booting recovery mint linux(daryna)... I have a dual boot set up mint & XP pro with 4 main partitions (first one is dell utility, second is XP, third is extended for linus mint [holds / , /home & /swap] and fourth partition is an NTFS formatted for XP). I have installed Mint light. When I turn on PC its doesnt automatically go to the grub menu, it give me a screen with linux mint background pic and a text box in top left corner that look a bit like this:
/ ----- pstk------------------rstk--- \
: :
: :
: :
: :
:0 5ffae. a :
:1 5ff8a. a :
:2 2c244. 4 :
:3 147. 9: 0: fffffff. 5:
:4 a. 1: 1: 1462. 5:
\--------------------------------------/

pressing enter then takes me to the grub menu where i can adequately boot into XP.

When I try to boot to linux Mint however there are a few problems...
something only happens when booting into recovery mode (ie normal boot fails miserably)

then i get a few bad file names in sda1 (the dell utility drive I think) with error message
fsck died with exit status 8
[fail]
*File system check failed.

i get a shell in recovery mode but pressing ctl-D doesnt boot normally as suggested by the messages...

what gives? any quick fix? is the dell utility partition causing problems? I noticed when I was making partitions in gparted from live CD that there was a triangle with ! beside the dell utility drive. Is the problem related to this in any way?
why is linux even having a look at that partition if i contained mint to sda3-6?
Anyone with suggestions?
timmmy
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 27, 2008 7:46 am

Linux Mint is funded by ads and donations.
 

Re: mint not booting properly at all

Postby timmmy on Wed Feb 27, 2008 9:13 am

okay... new development. I changed the /etc/fstab following this in the wiki http://www.linuxmint.com/wiki/index.php ... _a_problem

commenting out the UUID seems to have done something positive:
selecting the linux mint OS option got me to the log in screen. However after putting in username and password there is a permission problem with the $HOME/.dmrc file??? its telling me the $HOME directory must be owned by user and have 644 permissions...

this leads to something about GTK+ initialisation problems and thence no login and no session. Failsafe gnome session gives identical result. i am able to get to the terminal with the failsafe terminal session. here I changed the ownership of $HOME (/home/me) to 644 (sudo chown 644 /home/me) and exited and tried logging in again...to no avail. same thing happens again and im brought back to the login screen (which looks slick by the way you mint developpers ;))

also, there is still the weird screen after powering on PC as described above with the need to press enter twice to reach grub menu.

Anyone??




no go
timmmy
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 27, 2008 7:46 am

Re: mint not booting properly at all

Postby timmmy on Thu Feb 28, 2008 5:53 am

OK a little more info on this liggle major problem here. When I installed this is what I did:

I manually re-partitioned the hard drive from the live CD gparted:
- shrunk the two windows partitions
- made a new extended partition into which i then made two ext3 partitions and a swap partition.

i then went to manual install from the live CD and made one of the ext 3 partitions /root and one of them /home while the swap was detected automatically as swap. Could the permission and login problem stem from this tinkering? I am fairly new to linux (have xubuntu 7.10 running sweetly on my laptop not a bother since december last) and id like to get mint looking good and working on me desktop, so please, anyone with ideas on how i can fix this????
timmmy
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 27, 2008 7:46 am

Re: mint not booting properly at all

Postby timmmy on Fri Feb 29, 2008 5:29 am

AH come on guys... some help... please?
timmmy
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 27, 2008 7:46 am


Return to Installation & Boot

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 26 guests