Change Keyboard Layout login solved

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Change Keyboard Layout login solved

Postby Thainop on Thu Feb 28, 2008 2:55 pm

How can I change keyboard layout on Login/password page, from US English to US Dvorak?

Mint Main edition Daryna. It wast fine a week ago then revert back to US English today, I can't change it back (@ login). However, once Nautilus load, the layout automatically correct itself to Dvorak.
Thainop
Level 1
Level 1
 
Posts: 11
Joined: Wed Aug 01, 2007 9:07 am

Linux Mint is funded by ads and donations.
 

Re: Change Keyboard Layout login

Postby Husse on Fri Feb 29, 2008 7:30 am

sudo gedit /etc/X11/xorg.conf

And find section "InputDevice" and change Option to:

Option "XkbLayout" "us Dvorak"

I'm not sure if it is called "us Dvorak" so please check first
This should work
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Change Keyboard Layout login

Postby Thainop on Sat Mar 01, 2008 12:41 am

[Solved]
Thanks a lot Husse. Your instructions are great. It is corrected now.
Note: When I first change on xorg.conf , after boot up something like Gnome keyboard tried to change it back to US qwerty (for xkeyboard), but I didn't let it change. So the second time, it didn't ask me or try to change it back anymore. Everything stand as Dvorak as I want. Thanks.
Thainop
Level 1
Level 1
 
Posts: 11
Joined: Wed Aug 01, 2007 9:07 am

Re: Change Keyboard Layout login

Postby Thainop on Sat Mar 01, 2008 3:54 am

I have found a better command on xorg.conf . This change will not break gnome keyboard. So I do this:
Option "XkbLayout" "us"
Option "XkbVariant" "dvorak"

They are in the Section "InputDevice"
Thainop
Level 1
Level 1
 
Posts: 11
Joined: Wed Aug 01, 2007 9:07 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 14 guests