[Solved] Enable Lightdm in LM 13 Maya

Questions about applications and software
Forum rules
Before you post please read this

[Solved] Enable Lightdm in LM 13 Maya

Postby pfjap.paco on Mon May 21, 2012 11:07 pm

I prefer LightDM to MDM, so I tried to install it. However, the system fails to boot after installing LightDM, and seems to still be trying to run MDM in the boot sequence. This renders the system unbootable unless running
Code: Select all
sudo dpkg-reconfigure mdm
in the recovery session.

Has anybody found a way to run LightDM in Maya?
Last edited by pfjap.paco on Mon May 28, 2012 9:29 am, edited 1 time in total.
"Even a dead thing can go with the stream, but only a living thing can go against it." - G.K. Chesterton

Dell Studio 1555 running Linux Mint 13 Maya LTS x86_64/Windows 7 x86/Ubuntu 12.04 Precise Pangolin LTS x86_64
User avatar
pfjap.paco
Level 1
Level 1
 
Posts: 26
Joined: Sun Nov 27, 2011 10:01 pm
Location: United States

Linux Mint is funded by ads and donations.
 

Re: Enable Lightdm in LM 13 Maya

Postby esteban1uy on Tue May 22, 2012 1:34 am

LightDM... ugh!
Too much Ubuntu for my taste and really few configuration options. But if you want it, you can do it this way (Maya+Cinnamon):

Go to synaptic and install the packages lightdm and lightdm-gtk-greeter.
At certain point you'll be asked to choose the default session manager, select lightdm.
DO NOT REBOOT OR LOGOFF!
Now open nautilus with root privileges (sudo nautilus at a terminal), navigate to /etc/lightdm/ and edit the file lightdm.conf to look like this:
Code: Select all

[SeatDefaults]
greeter-session=lightdm-gtk-greeter
user-session=cinnamon
allow-guest=false


And lightdm-gtk-greeter.conf to this:
Code: Select all
#
# background = Background file to use, either an image path or a color (e.g. #772953)
# theme-name = GTK+ theme to use
# font-name = Font to use
# xft-antialias = Whether to antialias Xft fonts (true or false)
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
# show-language-selector (true or false)
#
[greeter]
background=/usr/share/backgrounds/linuxmint-maya/gelsan_green.png
theme-name=Mint-Z
icon-theme-name=Mint-X
font-name=Ubuntu 10
xft-antialias=true
xft-dpi=96
xft-hintstyle=slight
xft-rgba=rgb


Now you can reboot.

If you want autologin, just add the following lines to lightdm.conf (use your own user login name):
Code: Select all
autologin-user=YOUR_USER_LOGIN
autologin-user-timeout=0
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Enable Lightdm in LM 13 Maya

Postby Rüssel on Thu May 24, 2012 5:58 pm

esteban1uy wrote:LightDM... ugh!
Too much Ubuntu for my taste and really few configuration options. But if you want it, you can do it this way (Maya+Cinnamon):

Go to synaptic and install the packages lightdm and lightdm-gtk-greeter.
At certain point you'll be asked to choose the default session manager, select lightdm.
DO NOT REBOOT OR LOGOFF!
Now open nautilus with root privileges (sudo nautilus at a terminal), navigate to /etc/lightdm/ and edit the file lightdm.conf to look like this:
Code: Select all

[SeatDefaults]
greeter-session=lightdm-gtk-greeter
user-session=cinnamon
allow-guest=false


And lightdm-gtk-greeter.conf to this:
Code: Select all
#
# background = Background file to use, either an image path or a color (e.g. #772953)
# theme-name = GTK+ theme to use
# font-name = Font to use
# xft-antialias = Whether to antialias Xft fonts (true or false)
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
# show-language-selector (true or false)
#
[greeter]
background=/usr/share/backgrounds/linuxmint-maya/gelsan_green.png
theme-name=Mint-Z
icon-theme-name=Mint-X
font-name=Ubuntu 10
xft-antialias=true
xft-dpi=96
xft-hintstyle=slight
xft-rgba=rgb


Now you can reboot.

If you want autologin, just add the following lines to lightdm.conf (use your own user login name):
Code: Select all
autologin-user=YOUR_USER_LOGIN
autologin-user-timeout=0


Can you do this only in Maya + Cinnamon, or also in Maya + MATE the same way?
Linux Mint Donor #2676
Rüssel
Level 1
Level 1
 
Posts: 19
Joined: Sun May 20, 2012 1:50 pm

Re: Enable Lightdm in LM 13 Maya

Postby esteban1uy on Thu May 24, 2012 6:22 pm

Rüssel wrote:Can you do this only in Maya + Cinnamon, or also in Maya + MATE the same way?


I don't know. That way I'm sure it works for Maya+Cinnamon.
For Maya+MATE I guess you should change:
Code: Select all
user-session=cinnamon

to:
Code: Select all
user-session=mate


But I'm not sure.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Enable Lightdm in LM 13 Maya

Postby cwwgateway on Thu May 24, 2012 8:29 pm

Installing LightDM works on MATE. The greeter in ubuntu is unity-greeter, not lightdm-gtk-greeter. I'm not sure how to configure unity-greeter to have a different background, though.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: Enable Lightdm in LM 13 Maya

Postby esteban1uy on Thu May 24, 2012 8:45 pm

cwwgateway wrote:Installing LightDM works on MATE. The greeter in ubuntu is unity-greeter, not lightdm-gtk-greeter. I'm not sure how to configure unity-greeter to have a different background, though.

Well... unity-greeter uses the same background as the default user (as in Ubuntu) and it adds that horrid dotted screen overlay... and the infamous "Ubuntu 12.04" text below the password box!
I'm sorry, but I prefer the unbranded lightdm-gtk-greeter a thousand times (sudo apt-get install lightdm-gtk-greeter).
Maybe I'm too much purist but I would hate to see a beautiful Mint Maya branded as Ubuntu, but of course, that's up to each one's taste.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Enable Lightdm in LM 13 Maya

Postby cwwgateway on Thu May 24, 2012 9:46 pm

esteban1uy wrote:
cwwgateway wrote:Installing LightDM works on MATE. The greeter in ubuntu is unity-greeter, not lightdm-gtk-greeter. I'm not sure how to configure unity-greeter to have a different background, though.

Well... unity-greeter uses the same background as the default user (as in Ubuntu) and it adds that horrid dotted screen overlay... and the infamous "Ubuntu 12.04" text below the password box!
I'm sorry, but I prefer the unbranded lightdm-gtk-greeter a thousand times (sudo apt-get install lightdm-gtk-greeter).
Maybe I'm too much purist but I would hate to see a beautiful Mint Maya branded as Ubuntu, but of course, that's up to each one's taste.

I only say that because I assume the poster wanted LightDM the same way Ubuntu has it. The average user sees things and relates the name to what he sees. The gtk greater looks different than the lightdm that he has seen with ubuntu. Personally, I hate the Ubuntu lightdm just like you (Especially those dots - I hate those dots so much :evil: ) and I really like MDM.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: Enable Lightdm in LM 13 Maya

Postby pfjap.paco on Thu May 24, 2012 11:07 pm

cwwgateway wrote:
esteban1uy wrote:
cwwgateway wrote:Installing LightDM works on MATE. The greeter in ubuntu is unity-greeter, not lightdm-gtk-greeter. I'm not sure how to configure unity-greeter to have a different background, though.

Well... unity-greeter uses the same background as the default user (as in Ubuntu) and it adds that horrid dotted screen overlay... and the infamous "Ubuntu 12.04" text below the password box!
I'm sorry, but I prefer the unbranded lightdm-gtk-greeter a thousand times (sudo apt-get install lightdm-gtk-greeter).
Maybe I'm too much purist but I would hate to see a beautiful Mint Maya branded as Ubuntu, but of course, that's up to each one's taste.

I only say that because I assume the poster wanted LightDM the same way Ubuntu has it. The average user sees things and relates the name to what he sees. The gtk greater looks different than the lightdm that he has seen with ubuntu. Personally, I hate the Ubuntu lightdm just like you (Especially those dots - I hate those dots so much :evil: ) and I really like MDM.


Oh goodness, no. Haha, I would hate having the Ubuntu logo all over my lovely Maya. I just prefer the much cleaner look of LightDM, but just so the information is out there, it's pretty easy to edit the unity-greeter using [sudo? try sudo if using plain dconf doesn't work] dconf (under com>canonical>unity-greeter) so I completely edited the thing to my tastes (Mint Logo, Maya wallpaper, black background, etc.) On that note though, has anybody gotten a hold of a Linux Mint 13 logo?
"Even a dead thing can go with the stream, but only a living thing can go against it." - G.K. Chesterton

Dell Studio 1555 running Linux Mint 13 Maya LTS x86_64/Windows 7 x86/Ubuntu 12.04 Precise Pangolin LTS x86_64
User avatar
pfjap.paco
Level 1
Level 1
 
Posts: 26
Joined: Sun Nov 27, 2011 10:01 pm
Location: United States

Re: Enable Lightdm in LM 13 Maya

Postby Monsta on Fri May 25, 2012 9:14 am

cwwgateway wrote:Especially those dots - I hate those dots so much :evil:

If you mean these dotted lines in the user list, they can be easily removed by editing (as root of course)
Code: Select all
/usr/share/lightdm-gtk-greeter/greeter.ui
and removing the string that says
Code: Select all
<property name="enable_grid_lines">horizontal</property>

Of course, you have to be aware that it's a hack and the file may be overwritten on the next lightdm update. :)
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: Enable Lightdm in LM 13 Maya

Postby cwwgateway on Fri May 25, 2012 4:32 pm

Monsta wrote:
cwwgateway wrote:Especially those dots - I hate those dots so much :evil:

If you mean these dotted lines in the user list, they can be easily removed by editing (as root of course)
Code: Select all
/usr/share/lightdm-gtk-greeter/greeter.ui
and removing the string that says
Code: Select all
<property name="enable_grid_lines">horizontal</property>

Of course, you have to be aware that it's a hack and the file may be overwritten on the next lightdm update. :)

Thanks. I still prefer MDM, though.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: Enable Lightdm in LM 13 Maya

Postby gfreeau on Sat May 26, 2012 2:08 pm

I'm back to using lightdm with mint backgrounds, I'm not a fan of the theme for linuxmint MDM, it should have a user list by default, typing in your username is unnecessary. I saw a fix for this in this thread: viewtopic.php?f=190&t=101338&p=584179, but if you add it in, you would need to edit many other elements as they rely on the blank space to print messages etc.

I converted several old mdm things from gnome-look and couldn't find anything I liked, is anyone using an mdm theme that is simple, mint based themed with a user list?
Image
gfreeau
Level 1
Level 1
 
Posts: 33
Joined: Wed Nov 30, 2011 5:49 pm

Re: Enable Lightdm in LM 13 Maya

Postby Rehdon on Sun May 27, 2012 8:59 am

MDM in LM 13 sure looks like a regression when compared to LightDM in LM 13, I guess the choice was done on pure technical grounds (namely, LightDM lacks configurability ... but IMHO the average user doesn't need a lot when it comes to the 'choose user' screen) but LM 13 now looks uglier and less user friendly (LightDM: bigger font, better graphics, you only had to type your password).

Hope the devs will choose a better theme and default MDM settings for the next LM version, or go back to LightDM.

Rehdon
Rehdon
Level 3
Level 3
 
Posts: 144
Joined: Tue Nov 29, 2011 9:18 am

Re: Enable Lightdm in LM 13 Maya

Postby cwwgateway on Sun May 27, 2012 12:13 pm

Rehdon wrote:MDM in LM 13 sure looks like a regression when compared to LightDM in LM 13, I guess the choice was done on pure technical grounds (namely, LightDM lacks configurability ... but IMHO the average user doesn't need a lot when it comes to the 'choose user' screen) but LM 13 now looks uglier and less user friendly (LightDM: bigger font, better graphics, you only had to type your password).

Hope the devs will choose a better theme and default MDM settings for the next LM version, or go back to LightDM.

Rehdon

Beauty is in the eyes of the beholder. Personally, I like the default MDM so much better than LightDM. I happen to have a different theme, but I really like the default theme too. Maybe you dislike it, but a lot of mint users really like it, so it was done for the looks as well as the customization. It's like saying LightDM was a regression compared to GDM - Some people liked GDM better, but most Ubuntu users liked LightDM better. I'm not saying that you should like MDM, and I'm happy that you really like LightDM, but saying that "MDM in LM 13 sure looks like a regression when compared to LightDM in LM 13, I guess the choice was done on pure technical grounds [...] but LM 13 now looks uglier and less user friendly" is insensitive. If you had said something about in your opinion, I'd be happy, but to say that it "sure looks like a regression" is saying that it's a regression for everybody, and that's kind of insensitive. Again, I'm happy if you feel it's a regression for you, but to say that it is a regression for everybody is not correct.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: Enable Lightdm in LM 13 Maya

Postby Monsta on Mon May 28, 2012 6:51 am

BTW, I didn't realize right away that lightdm always uses the default icon theme, so specifying
Code: Select all
icon-theme-name=Mint-X
in the configuration file is quite useless. At first I just couldn't figure out what exactly I don't like in that strange "computer" icon :)
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: Enable Lightdm in LM 13 Maya

Postby pfjap.paco on Mon May 28, 2012 9:27 am

Have any of you tried out eOS's Pantheon Greeter yet?

Image

^this^ is why I love LightDM
"Even a dead thing can go with the stream, but only a living thing can go against it." - G.K. Chesterton

Dell Studio 1555 running Linux Mint 13 Maya LTS x86_64/Windows 7 x86/Ubuntu 12.04 Precise Pangolin LTS x86_64
User avatar
pfjap.paco
Level 1
Level 1
 
Posts: 26
Joined: Sun Nov 27, 2011 10:01 pm
Location: United States

Re: Enable Lightdm in LM 13 Maya

Postby cwwgateway on Mon May 28, 2012 2:09 pm

pfjap.paco wrote:Have any of you tried out eOS's Pantheon Greeter yet?

Image

^this^ is why I love LightDM

I have to say, that looks pretty good.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: [Solved] Enable Lightdm in LM 13 Maya

Postby Konstigt on Fri Jun 01, 2012 1:33 pm

Don't know how to subscribe to a topic in this forum sw so I reply with a post to do it..
Konstigt
Level 1
Level 1
 
Posts: 36
Joined: Mon Sep 12, 2011 2:49 am

Re: [Solved] Enable Lightdm in LM 13 Maya

Postby cwwgateway on Fri Jun 01, 2012 10:59 pm

Konstigt wrote:Don't know how to subscribe to a topic in this forum sw so I reply with a post to do it..

When you are looking at the thread, go to the bottom of the page and click "subscribe to thread."
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: [Solved] Enable Lightdm in LM 13 Maya

Postby kmb42vt on Mon Jun 04, 2012 12:31 pm

Just to add to the conversation, I finally had to switch login managers altogether since MDM kept crashing to a blank screen at each boot/reboot. Apparently, there's a problem with the MDM login screen disappearing after 1 or 2 seconds for those of us who run the proprietary Nvidia driver. It doesn't happen with the Nouveau driver (which I won't use) and it doesn't happen with any other login manager that I've tried (GDM and LightDM). I finally settled on LightDM despite the Ubuntu branding along with installing "light-themes" just so the LightDM login screen was themed properly.

I tried everything I could think of to modify LightDM to get rid of the horizontal dotted grid and get rid of the "Ubuntu 12.04" text at the bottom left of the login screen but to no avail (I don't particularly like how switching to the "lightdm-gtk-greeter" looks). Using Dconf doesn't work (even as root) and modifying the "/etc/lightdm" files doesn't work either--the LightDM login screen always remains the same despite any modification I try.

Ah well, no big deal. I may eventually go with GDM as it more resembles the original Linux Mint login screen of versions past despite the black background. I just wish MDM would be fixed so it works with the Nvidia driver installed.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)
User avatar
kmb42vt
Level 5
Level 5
 
Posts: 929
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont

Re: [Solved] Enable Lightdm in LM 13 Maya

Postby Monsta on Mon Jun 04, 2012 1:12 pm

kmb42vt wrote:get rid of the "Ubuntu 12.04" text at the bottom left of the login screen

Not very hard, actually: viewtopic.php?f=211&t=103684
Just remember it's a hack which may very well be reverted on the next package update.

kmb42vt wrote:Using Dconf doesn't work (even as root)

It's not supposed to work as root in this case. You need to edit these settings as a user named "lightdm".

kmb42vt wrote:and modifying the "/etc/lightdm" files doesn't work either--the LightDM login screen always remains the same despite any modification I try.

Unity-greeter doesn't seem to care about anything in /etc/lightdm.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: Pilosopong Tasyo and 11 guests