M13/Mate - Set Language

Questions about applications and software
Forum rules
Before you post please read this

M13/Mate - Set Language

Postby w0ipl on Mon Jul 02, 2012 3:41 am

When I set the language default to US English everything works fine for ten or so minutes. When I go to a number of different forums, Firefox seems to "forget" what language I had set. It . . does . . stay with English but uses UK English and Aussie English in the spell checker. I re-check US English and it is fine until I log off, then it reverts to UK English.

I have tried setting it both from the Control Panel and using Right Click within input fields. It accepts the change and then "forgets" again a little later.

I tried deleting the non-US language support, but several of the files are common.
I just looked, and it had "forgotten" as I closed out one forum and came over here.
VERY frustrating!

Any Suggestions?

Thanks
Pat
w0ipl
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 02, 2012 4:51 pm

Linux Mint is funded by ads and donations.
 

Re: M13/Mate - Set Language

Postby remoulder on Mon Jul 02, 2012 7:19 am

The language settings for firefox are independent of the system settings, you need to install the relevant language add-on in FF.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: M13/Mate - Set Language

Postby w0ipl on Mon Jul 02, 2012 2:32 pm

remoulder wrote:The language settings for firefox are independent of the system settings, you need to install the relevant language add-on in FF.


OK, I find . . . nothing . . . in Preferences about setting the language independently of the system settings.
Where would I find that information?

Update: 12:44 MDT
I also checked in the synaptic package manager and found the I DO have the English language package for Firefox installed.

I'm still looking for why it changes from US English to UK English (BIG differences in spelling for the spell checker) at seemingly random intervals.

Edit 7/3/12: 04:12 MDT
Tried using Libre Office Write and it also had the US English changed to UK English.
Most US people do not really like the Euro spelling, in US documents. :shock:
w0ipl
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 02, 2012 4:51 pm

Re: M13/Mate - Set Language

Postby remoulder on Tue Jul 03, 2012 7:45 am

w0ipl wrote:Most US people do not really like the Euro spelling, in US documents

I suspect most UK residents would regard that as an asinine if not arrogant remark coming from an American! :lol:
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: M13/Mate - Set Language

Postby w0ipl on Tue Jul 03, 2012 2:14 pm

remoulder wrote:
w0ipl wrote:Most US people do not really like the Euro spelling, in US documents

I suspect most UK residents would regard that as an asinine if not arrogant remark coming from an American! :lol:


Possibly, but UK people drive on the side of the road that allows them to wield their sword with the right hand. :roll: :lol:
w0ipl
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 02, 2012 4:51 pm

Re: M13/Mate - Set Language

Postby peridox91 on Wed Sep 05, 2012 11:05 pm

w0ipl wrote:
remoulder wrote:The language settings for firefox are independent of the system settings, you need to install the relevant language add-on in FF.


OK, I find . . . nothing . . . in Preferences about setting the language independently of the system settings.
Where would I find that information?

Update: 12:44 MDT
I also checked in the synaptic package manager and found the I DO have the English language package for Firefox installed.

I'm still looking for why it changes from US English to UK English (BIG differences in spelling for the spell checker) at seemingly random intervals.

Edit 7/3/12: 04:12 MDT
Tried using Libre Office Write and it also had the US English changed to UK English.
Most US people do not really like the Euro spelling, in US documents. :shock:


I am also on M13/MATE. It bothered me so much as I am a Biblical studies student and so have Greek and Hebrew installed... so it used the Greek spell checker, weird, huh? and so everything was red-squiggled. In Firefox's Edit-->Pref-->Content-->[Language] Choose, I had English installed as Default language. But it still didn't remember the language. So what I ended up doing was disabling all the language dictionaries in Tools-->Add-On-->Languages. STILL HAD GREEK AS SPELLCHECKER!! GRRR...

Then, I went to MintMenu-->Language Support and, I moved my Greek language, to the end (and it may be in faded gray font, but I moved it nonetheless), even though English-US was on top. I then "refreshed" by clicking on Apply System-Wide (though I did that before), and now, somehow my Firefox is finally working well using English-US. I.e. theatre is red-squiggly-marked, so I know that it's not British English or something.

So basically, this worked for me:

Check Firefox Default Language (under Edit-->Preferences-->Content-->Choose).
THEN go to Add-ons and disable any and all non-English US (or whatever dictionary) and restart [and, if after all this your language checker still doesn't work, then possibly make sure it was English (make sure you have an English-US dictionary installed via Firefox Add-Ons]
THEN go to MintMenu-->Language Support, and make sure English-US is on top of the list and then hit Apply System-Wide.

Hopefully that should do the trick. It did for me. Finally, not seeing red-squiggles under every word, because it's not GREEK! (because I'm typing in English!!!)
peridox91
Level 1
Level 1
 
Posts: 9
Joined: Wed Jun 06, 2012 9:40 am

Change Default/Remove Firefox Spellcheck dictionaries/langua

Postby peridox91 on Tue Sep 25, 2012 11:58 am

I finally solved my own problem!!!

Had to use terminal though, as you will need sudo (root) privileges!!!

In order to remove a language pack/spellcheck dictionary from firefox, you need to go to Terminal (or use GUI, but you won't be able to delete unless logged in as root, which is bad idea)

cd = change directory to
ls = reviews contents
sudo gives you root privileges
rm = remove permanently

Code: Select all
$ cd /usr/lib/firefox/dictionaries
$ ls
$ sudo rm xxx.aff // or xxx.dic

then you're done. restart your firefox
peridox91
Level 1
Level 1
 
Posts: 9
Joined: Wed Jun 06, 2012 9:40 am

Re: Change Default/Remove Firefox Spellcheck dictionaries/la

Postby luyseyal on Thu Oct 24, 2013 11:38 am

peridox91 wrote:
Code: Select all
$ cd /usr/lib/firefox/dictionaries
$ ls
$ sudo rm xxx.aff // or xxx.dic



That will work until myspell is updated.

Code: Select all
$ ls -ld /usr/lib/firefox/dictionaries
lrwxrwxrwx 1 root root 20 May 22 12:20 /usr/lib/firefox/dictionaries -> ../../share/hunspell
$ cd ../../share/hunspell
$ ls -l
drwxr-xr-x   2 root root   4096 May 22 12:24 ./
drwxr-xr-x 371 root root  12288 Oct 18 09:50 ../
-rw-r--r--   1 root root  28518 Dec 14  2011 en_AU.aff
-rw-r--r--   1 root root 557918 Dec 14  2011 en_AU.dic
-rw-r--r--   1 root root  74492 Jul  6  2011 en_GB.aff
-rw-r--r--   1 root root 701646 Jul  6  2011 en_GB.dic
-rw-r--r--   1 root root  11352 Dec  8  2011 en_US.aff
-rw-r--r--   1 root root 696462 Dec  8  2011 en_US.dic
-rw-r--r--   1 root root  36223 Jul  6  2011 en_ZA.aff
-rw-r--r--   1 root root 595937 Jul  6  2011 en_ZA.dic
$ dpkg -S /usr/lib/hunspell/en_AU.aff
myspell-en-au: /usr/share/hunspell/en_AU.aff


That means that the myspell packages are the culprit.

Go into Synaptic (or whatever) and remove the myspell language packs that you don't want.

Then, restart Firefox.

That will fix it unless one of those packages becomes a dependency of something else. To fix that requires Apt magic which I don't care to mess with, myself.

-l
luyseyal
Level 1
Level 1
 
Posts: 1
Joined: Thu Oct 24, 2013 11:30 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 19 guests