LM13/Cinnamon --> MATE = Broken Packages

Questions about applications and software
Forum rules
Before you post please read this

LM13/Cinnamon --> MATE = Broken Packages

Postby johnb0647 on Mon Sep 03, 2012 10:26 pm

I was running Ubuntu 11.04 with home on a separage partition. I did a clean install of LM13/Cinnamon. Used it a week or so but ran into problems with my graphics card (ATI/AMD FGLRX). Converted to MATE. Everything seems OK. Did 162 "recommended" updates. Result: broken packages.

The following packages have unmet dependencies:
libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.2-0ubuntu3.1) but 8.0.3+8.0.2-0ubuntu3.2 is to be installed
Breaks: libgl1-mesa-glx:i386 (!= 8.0.2-0ubuntu3.1) but 8.0.3+8.0.2-0ubuntu3.2 is to be installed
libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 8.0.3+8.0.2-0ubuntu3.2) but 8.0.2-0ubuntu3.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I'm no expert but it seems the OS and the package may be looking for different versions of something.

Tried 'apt-get -f install' and anything else the forums indicated might be helpful.

johnb@Max ~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libgl1-mesa-glx
The following packages will be upgraded:
libgl1-mesa-glx
1 upgraded, 0 newly installed, 0 to remove and 21 not upgraded.
10 not fully installed or removed.
Need to get 0 B/104 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing libgl1-mesa-glx (--configure):
libgl1-mesa-glx:amd64 8.0.2-0ubuntu3.1 cannot be configured because libgl1-mesa-glx:i386 is in a different version (8.0.3+8.0.2-0ubuntu3.2)
dpkg: error processing libgl1-mesa-glx:i386 (--configure):
libgl1-mesa-glx:i386 8.0.3+8.0.2-0ubuntu3.2 cannot be configured because libgl1-mesa-glx:amd64 is in a different version (8.0.2-0ubuntu3.1)
dpkg: dependency problems prevent configuration of libglu1-mesa:
libglu1-mesa depends on libgl1-mesa-glx | libgl1; however:
Package libgl1-mesa-glx is not configured yet.
Package libgl1 is not installed.
Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libglu1-mesa (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglu1-mesa:i386:
libglu1-mesa:i386 depends on libgl1-mesa-glx | libgl1; however:
Package libgl1-mesa-glx:i386 is not configured yet.
Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libglu1-mesa:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of compiz-plugins-default:
compiz-plugins-default depends on libgl1-mesaNo apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
-glx | libgl1; however:
Package libgl1-mesa-glx is not configured yet.
Package libgl1 is not installed.
Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing compiz-plugins-default (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of compiz-gnome:
compiz-gnome depends on compiz-plugins-default (= 1:0.9.7.8-0ubuntu1.4); however:
Package compiz-plugins-default is not configured yet.
dpkg: error processing compiz-gnome (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of compiz:
compiz depends on compiz-plugins-default (>= 1:0.9.7.8-0ubuntu1.4); however:
Package compiz-plugins-default is not configured yet.
compiz depends on compiz-gnome | compiz-kde; however:
Package compiz-gnome is not configured yet.
Package compiz-kde is not installed.
dpkg: error processing compiz (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of compiz-plugins:
compiz-plugins depends on compiz-plugins-default (= 1:0.9.7.8-0ubuntu1.4); however:
Package compiz-plugins-default is not configured yet.
compiz-plugins depends on libgl1-mesa-glx | libgl1; however:
Package libgl1-mesa-glx is not configured yet.
Package libgl1 is not installed.
Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
Package libgl1-mesa-glx which provides libgl1 is not configured yet.
compiz-plugins depends on libglu1-mesa | libglu1; however:
Package libglu1-mesa is not configured yet.
Package libglu1 is not installed.
Package libglu1-mesa:i386 which provides libglu1 is not configured yet.
Package libglu1-mesa which provides libglu1 is not configured yet.
dpkg: error processing compiz-plugins (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mate-screensaver:
mate-screensaver depends on libgl1-mesa-glx | libgl1; however:
Package libgl1-mesa-glx is not configured yet.
Package libgl1 is not installed.
Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing mate-screensaver (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nux-tools:
nux-tools depends on libgl1-mesa-glx | libgl1; however:
Package libgl1-mesa-glx is not configured yet.
Package libgl1 is not installed.
Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing nux-tools (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libgl1-mesa-glx
libgl1-mesa-glx:i386
libglu1-mesa
libglu1-mesa:i386
compiz-plugins-default
compiz-gnome
compiz
compiz-plugins
mate-screensaver
nux-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)



When I start MATE I get: The panel encountered a problem while loading OAFIID:MATE_mintMenu.
I DO NOT delete minMenu and it appears to be operating correctly although it may be missing some options.

This problem seems related related to the original.

Any suggestions?
johnb0647
Level 1
Level 1
 
Posts: 29
Joined: Sun Mar 11, 2012 10:02 am

Linux Mint is funded by ads and donations.
 

Re: LM13/Cinnamon --> MATE = Broken Packages

Postby johnb0647 on Wed Sep 19, 2012 9:20 pm

I'm still fighting this.

After hours studying the error log and trying to google terms I don't understand the critical points seem to be:

libgl1-mesa-glx : Depends on: libglapi-mesa (= 8.0.2-0ubuntu3.1)
but version 8.0.3+8.0.2-0ubuntu3.2 is to be installed
which Breaks: libgl1-mesa-glx:i386 (!= 8.0.2-0ubuntu3.1)

Together with: libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 8.0.3+8.0.2-0ubuntu3.2)
but version 8.0.2-0ubuntu3.1 is to be installed

Apparently a circular arguement.

After googling and reading dozens of threads, some dating back to 2007, the only guy who claimed to have had the problem and fixed it said:
"the way to resolve the problem was to download all the packages from sid manually and install them"

but in unrelated posts several apparent guru's said (more or less) "never install directly from Debian SID" because the packages haven't been vetted for Ubuntu's changes..... let alone those of Mint.... and sooner or later the omissions will kill you.

So I still have no idea what to do. I keep hoping that a subsequent update to something will fix the problem.
johnb0647
Level 1
Level 1
 
Posts: 29
Joined: Sun Mar 11, 2012 10:02 am

Re: LM13/Cinnamon --> MATE = Broken Packages

Postby johnb0647 on Wed Sep 26, 2012 8:58 pm

No improvements and as additional updates come along the list of broken or "unconfigured" packages increases. The latest list is below.

Questions:

Is it possible to install LM 13 AMD 64 MATE on top of LM 13 AMD 64 CINNAMON without losing all my config and installed apps?

Is this likely to resolve my problem?

This is my primary computer and I'm concerned that some update will come along that will REALLY break things and leave me non-functional for days/weeks.

Latest list of problem packages after updates downloaded and installed 9/27/12

E: libgl1-mesa-glx: libgl1-mesa-glx:amd64 8.0.2-0ubuntu3.1 cannot be configured because libgl1-mesa-glx
E: libglu1-mesa: dependency problems - leaving unconfigured
E: compiz-plugins-default: dependency problems - leaving unconfigured
E: compiz-gnome: dependency problems - leaving unconfigured
E: compiz: dependency problems - leaving unconfigured
E: compiz-plugins: dependency problems - leaving unconfigured
E: mate-screensaver: dependency problems - leaving unconfigured
E: nux-tools: dependency problems - leaving unconfigured
johnb0647
Level 1
Level 1
 
Posts: 29
Joined: Sun Mar 11, 2012 10:02 am

Re: LM13/Cinnamon --> MATE = Broken Packages

Postby NEAILD on Fri Nov 16, 2012 1:40 am

I had the same problem and found a solution:
http://ubuntuforums.org/showthread.php?t=1940733

Code:
dpkg --force-depends --purge libgl1-mesa-glx
sudo apt-get -f install

at which point only one unity was still "broken". I repeated the process, like this:

Code:
dpkg --force-depends --purge "broken unity" it was libgl1-mesa-glx:i386 in my case
sudo apt-get -f install
NEAILD
Level 1
Level 1
 
Posts: 1
Joined: Fri Nov 16, 2012 1:34 am

Re: LM13/Cinnamon --> MATE = Broken Packages

Postby Blackbirds on Wed Jul 09, 2014 8:01 pm

Thanks this worked for me too!!!

My topic
Greetz
Blackbirds
Level 1
Level 1
 
Posts: 14
Joined: Thu Jun 26, 2014 5:09 am


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 24 guests