(SOLVED) No Maya startup sound

Questions about applications and software
Forum rules
Before you post please read this

Re: No Maya startup sound

Postby riki on Thu Sep 27, 2012 2:41 am

Mik3e wrote:For your information, I had a login sound with my original '13' install, but it disappeared for some reason. Here's what worked for me to get it back:

1. In a terminal I ran 'play /usr/share/sounds/linuxmint-login.wav' and got the appropriate sound.
2. I checked Startup Applications and there was no entry for 'startup sound', so I created one with the above command.
3. I rebooted and got the startup sound.

It was that simple, but I haven't had it working long enough to have confidence it won't disappear again. One theory I'll check out if it does disappear again is that un-checking 'startup sound' has the effect of removing it rather than only disabling it.


Thanks for coming in Mik3e. I've done what worked for you a num,ber of times but unfortunately it doesn't work for me. The command works with the terminal (I get the sound) and the correct entry checked in Startup Applications but still total silence on reboot.
Riki

Image
User avatar
riki
Level 4
Level 4
 
Posts: 370
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK

Linux Mint is funded by ads and donations.
 

Re: No Maya startup sound

Postby riki on Thu Sep 27, 2012 2:54 am

Would you believe it. I got sound! All I have done is re-entering the command in Startup Applications instead of, as previously, browsing for the wav file and adding it from Sounds and bingo job done. Obviously the path via the file system (usr>share>sounds) doesn't work. Thanks a million Mik.
Riki

Image
User avatar
riki
Level 4
Level 4
 
Posts: 370
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK

Re: (SOLVED) No Maya startup sound

Postby riki on Thu Sep 27, 2012 4:26 am

@mik3e

Does your logout sound work? I've tried unsuccessfully with the command "play /usr/share/sounds/linuxmint-logout.wav"
Riki

Image
User avatar
riki
Level 4
Level 4
 
Posts: 370
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK

Re: (SOLVED) No Maya startup sound

Postby Mik3e on Thu Sep 27, 2012 9:57 pm

The sound works but I don't have a 'Shutdown Applications' tool to store and run shutdown applications.
Mik3e
Level 2
Level 2
 
Posts: 83
Joined: Sat Jan 01, 2011 2:54 pm

Re: (SOLVED) No Maya startup sound

Postby danellisuk on Thu Nov 08, 2012 7:39 pm

[ANOTHER SOLUTION]
I also had the issue where there was no "system ready" or "login" sound, but sound would be fine once logged in. This was with a fresh install of Linux Mint 13 MATE edition (64bit). It turns out to be because I have a USB sound card (an external Lexicon Omega).

The reason it works once logged in is because PulseAudio was selecting the correct sound card (the only one available). But the login screen (mdm) is running as root and is not configured to use PulseAudio. It is therefor trying to play the audio directly using ALSA.

When I tried to play a wav directly using ALSA, using the aplay command as root, I received the following error:-

Code: Select all
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
play FAIL formats: can't open output file `default': snd_pcm_open error: No such file or directory


So then I listed the audio devices:

Code: Select all
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Omega [Lexicon Omega], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Omega [Lexicon Omega], device 1: USB Audio [USB Audio #1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Here you can see the soundcard is card 1. There is no card 0.

To fix this I edited /etc/modprobe.d/alsa-base.conf and changed the line:-

Code: Select all
options snd-usb-audio index=-2


to

Code: Select all
options snd-usb-audio index=0


Also note that my system had this line twice for some reason, so I just commented out the one at the end of the file. Finally rebooted and it all worked.
Daniel Ellis
2006 - 2012, Ubuntu 6.06 through to Ubuntu 10.04 LTS
November 2012 - Present, Mint 13 (MATE on desktops and laptops, XFCE on netbook)
danellisuk
Level 1
Level 1
 
Posts: 2
Joined: Thu Nov 08, 2012 7:21 pm
Location: Kent, UK

Re: (SOLVED) No Maya startup sound

Postby northcamel on Wed Jan 16, 2013 6:37 am

northcamel
Level 1
Level 1
 
Posts: 15
Joined: Wed Dec 05, 2012 10:51 pm

Previous

Return to Software & Applications

Who is online

Users browsing this forum: Bing [Bot], karlchen and 20 guests