LibreOffice menu bar display issues

Questions about applications and software
Forum rules
Before you post please read this

LibreOffice menu bar display issues

Postby ben01 on Tue Oct 23, 2012 4:09 am

The menus, menu bars, context menu, font menu, and font size menu only intermitently display text (some display as usual, some don't - not following any logical pattern that I can see). In place of the regular text, it just displays an underscore. All LibreOffice applications are like this, some to a greater extent than others. In addition, when I first login and click the Mint menu, a border appears, but nothing else. I must click somewhere else, and then click the menu again to see any programs. Also, text is sometimes partially displayed and sometimes not displayed at all in my KeePass password manager.
Attached is a screen shot of LibreOffice Writer showing what I mean.

I am running Linux Mint Maya 13 on my desktop.

I first noticed these issues after installing wine and theWord Bible software (or more specifically, after copying some Thai fonts to the wine fonts folder).
I have reinstalled LibreOffice (checked all related LibreOffice packages as "mark for reinstallation" in synaptic package manager and then applied changes). That didn't help anything.

So, my question is, how do I make menu, font, etc. text reapear in my LibreOffice aplications? I've been using Linux for a while, but am still somewhat of a newbie.
Attachments
Screenshot-Untitled 1 - LibreOffice Writer.png
Screenshot-Untitled 1 - LibreOffice Writer.png (37.76 KiB) Viewed 428 times
ben01
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 23, 2012 1:07 am

Linux Mint is funded by ads and donations.
 

Re: LibreOffice menu bar display issues

Postby jaythespacehound on Tue Oct 23, 2012 7:56 am

Which desktop are you using?

I suspect you're missing some fonts...
Try ensuring you have Thai language support installed.
jaythespacehound
Level 1
Level 1
 
Posts: 37
Joined: Tue Oct 23, 2012 2:37 am

Re: LibreOffice menu bar display issues

Postby ben01 on Tue Oct 23, 2012 8:15 am

I have Mint Maya 13 installed, that's what you mean, right?
I do have thai language installed, but reinstalled just to make sure. Still the same.

However, to be clear, the LibreOffice interface is not supposed to be Thai. I read mainly english, but have used Writer extensivly for Thai as well and have experienced no problems until now. I was merely puting thai fonts in the wine fonts folder so that Thai in theWord (running under wine) would display correctly (which it still doesn't, if anyone knows how to fix that, let me know).
Last edited by ben01 on Tue Oct 23, 2012 9:25 am, edited 1 time in total.
ben01
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 23, 2012 1:07 am

Re: LibreOffice menu bar display issues

Postby jaythespacehound on Tue Oct 23, 2012 9:00 am

Yup I figured, but sometimes funkyness ensues.
But no I didn't mean Maya I meant which interface shell are you using?
As in, Cinnamon, MATE or XFCE?
jaythespacehound
Level 1
Level 1
 
Posts: 37
Joined: Tue Oct 23, 2012 2:37 am

Re: LibreOffice menu bar display issues

Postby ben01 on Tue Oct 23, 2012 9:21 am

It's Mate
ben01
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 23, 2012 1:07 am

Re: LibreOffice menu bar display issues

Postby ben01 on Tue Oct 23, 2012 9:35 am

Ok, turning off Gnome Compositing in Control Center/Desktop Settings completely fixes the problem in both LibreOffice and KeePass. There's a small chance I could be wrong here, but I believe everything looked just fine with compositing before installing wine. Has anyone had a simular experience? or does anyone have any sugestions on how to run both compositing and wine, and have all programs still look right?
ben01
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 23, 2012 1:07 am

Re: LibreOffice menu bar display issues

Postby interbird1964 on Mon Nov 05, 2012 3:11 am

Is seems to be a compositing and resource problem in Libre Office.
Using Metacity instead of Compiz works when compositing is turned off.
Using xfwm4 as a WM also works.
Cinnamon triggers the problem because it uses a compositing WM.
I also read posts where KDE with compositing enabled triggering the problem.
This would point to a compositing problem in LibreOffice.

Also, decreasing the font-size enables more items, indicating a possible
resource problem in LibreOffice.

For me, running LMDE/MATE/Compiz, setting Smoothing from Greyvalues to Subpixel
solved the problem. So, you might get lucky too...
interbird1964
Level 1
Level 1
 
Posts: 22
Joined: Tue Dec 01, 2009 10:05 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: all41 and 17 guests