SOLVED! no sound or image in aMsn!

Questions about applications and software
Forum rules
Before you post please read how to get help

SOLVED! no sound or image in aMsn!

Postby AAB on Thu May 01, 2008 10:16 pm

Hello everyone,
I'm a newbie too, but not in Linux. :D I used to use Ubuntu feisty 7.04 but came across Linux Mint that I like so far. 8) Not much difference with Ubuntu because it got the same kernel. I was not a specialist with ubuntu, but I do have one same problem:
aMsn doesn't let my webcam work! I have no sound nor video image! :?: The preferences are set on snack2lib that I've installed with synaptic. When I've downloaded aMsn with Tcl/Tk 8.5 (instead 8.4) I had a little bit more luck because he was searching for my webcam. I've got a Philips ToUcam. The webcam that was selected in the installation of the webcam was not mine!!!!
Could anyone help me on this? :(
It would be great!
Hear ya!
Last edited by AAB on Tue May 06, 2008 9:44 am, edited 2 times in total.
AAB
Level 1
Level 1
 
Posts: 8
Joined: Thu May 01, 2008 4:04 pm
Location: Belgium

Linux Mint is funded by ads and donations.
 

Re: no sound or image in aMsn!

Postby MagnusB on Fri May 02, 2008 10:59 am

It might be your webcam not working, use
Code: Select all
lsusb

Which should return something like:
Bus 001 Device 003: ID 064e:a110 Suyin Corp.
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c51a Logitech, Inc.
Bus 002 Device 001: ID 0000:0000

In my case my webcam is the first listing, Suyin Corp. Use the ID and Google to find the correct driver with this string:
Code: Select all
064e:a110 ubuntu

Replace the ID with your, of course.
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: no sound or image in aMsn!

Postby AAB on Fri May 02, 2008 12:00 pm

This is what I get:

dolphin@dolphin-desktop:~$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 005: ID 05fe:2001 Chic Technology Corp.
Bus 002 Device 006: ID 0471:0310 Philips PCVC730K WebCam [pwc]
Bus 002 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 003: ID 03f0:4d11 Hewlett-Packard
Bus 001 Device 001: ID 0000:0000
dolphin@dolphin-desktop:~$


Wich one should I take now?
AAB
Level 1
Level 1
 
Posts: 8
Joined: Thu May 01, 2008 4:04 pm
Location: Belgium

Re: no sound or image in aMsn!

Postby MagnusB on Fri May 02, 2008 12:10 pm

Bus 002 Device 006: ID 0471:0310 Philips PCVC730K WebCam [pwc]
EDIT:
Take a look at https://help.ubuntu.com/community/Webcam
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: no sound or image in aMsn!

Postby AAB on Fri May 02, 2008 12:37 pm

Thanks for the answers!
I've looked at the liste of pwc if my webcam is supported. He is. Do I have to reboot before it works?
The explanation on the site that you gave me is not easy. I see different installations possible to use, but I don't understand those drivers. :oops:
The drivers ov51x, ov51xx, etc...can you use it for all webcams? What is it used for? And about "Recording to an AVI file"....? why saving a chatsession between friends? or taking images? For the people who are just having a chat with vriends, they don't need this, do they?

Thanks in advance :D
AAB
Level 1
Level 1
 
Posts: 8
Joined: Thu May 01, 2008 4:04 pm
Location: Belgium

Re: no sound or image in aMsn!

Postby AAB on Fri May 02, 2008 1:09 pm

Ok, sorry, I've clicked a little bit more on the links and saw what webcam this was for.
I used thought "lsmod | grep pwc" and everything looked fine! It was recognized. But I've (apparently) got problems with aMsn.
This is the error message:

Loading TkCximage failed. This module is needed to run aMsn.
Please compile aMsn first, instructions on how to compile are
located in the file INSTALL.

But I installed aMsn with the tar-package, so normally it should have compiled itself, no?
AAB
Level 1
Level 1
 
Posts: 8
Joined: Thu May 01, 2008 4:04 pm
Location: Belgium

Re: no sound or image in aMsn!

Postby MagnusB on Fri May 02, 2008 1:24 pm

Try removing aMSN and install it from the repositories, it looks like you have a bad install.
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: no sound or image in aMsn!

Postby AAB on Fri May 02, 2008 1:31 pm

Ok, help me out here please. Refresh my memory ........

How do I do that again? :? :)
AAB
Level 1
Level 1
 
Posts: 8
Joined: Thu May 01, 2008 4:04 pm
Location: Belgium

Re: no sound or image in aMsn!

Postby MagnusB on Fri May 02, 2008 2:53 pm

In a terminal:
Code: Select all
sudo aptitude install amsn
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: no sound or image in aMsn!

Postby AAB on Fri May 02, 2008 11:52 pm

Thanks! But I did a re-installation of linuxmint! The problem was that I wanted to separate the "/boot" and the "/ " because of reading it on a site. Apparently those 2 belong together! ....I have 2 HDD in SATA, unplugged my second HDD to be sure to install on the first one. After installing I tried aMsn again (that was installed by default) but it told me that there was a newer verser and that I had to download it! Because of the fact that I had an older version my webcam couldn't be configurated. So my question again is:

1) How can I uninstall aMsn? When I do this with synaptic, will there be dependencies left on my drive of the old aMsn? will I still need them with the new version (0.97R) of aMsn? or how can I delete them?
2) Synaptic Package Manager contains dependencies where I have no knowledge about. I even don't know what they're used for. I was told that when you install a package, the dependencies needed for those packages will install by themselves if necessary. Is that true? So when uninstalling packages, the dependencies will leave to? No orphan packages anymore?
3) After uninstalling aMsn, how can I easily install this from their site? Because we've got a lot of possibilities! For Linux, windows, packages, etc..... I know that the packages has to be compiled, but I'm not that far yet in understanding building packages! If I take the tar.bz for Linux, I have to open a terminal and type the code: tar -jxvf <filename> but never the less it won't be configurated! In Ubuntu I had Gdebi to install my packages. I found Gdebi in System Tools here in LinuxMint, but it can't see my desktop!?It is empty! So I suppose I have to cut and past the packages, downloaded on my desktop, in my home folder? (How come Gdebi don't see anything on my desktop?) :?:
4) How to configure aMsn for the best? In preferences you find a lot of things that you can change and install, but to have audio possibilities or webcam images (because I suppose that the two still don't work together?) how to do this? What should I use for sound preference? The Snacklibrarie installed by default? or another one? what is the code for that? The other items above, about the home folder, email command, etc.... where can I find all that? The help is apparently not installed, for nothing of all my applications I saw, so how to install help function for my complete OS?

Well, I hope that someone can help me on at least one of these items..... :oops: That would be great! :D Thanks a lot.
AAB
Level 1
Level 1
 
Posts: 8
Joined: Thu May 01, 2008 4:04 pm
Location: Belgium

Re: no sound or image in aMsn!

Postby AAB on Mon May 05, 2008 5:48 pm

Hy everyone,
I found out how to get aMsn installed properly and how to configure my webcam. :D Like it's already said, the sound is disturbed (it looks like I had a huge amount of Helium) but everything is up and running. :D

It IS very importand how you install aMsn, in which consecutive ways I mean. So let me explain this again for you (how I did it!...):

Uninstalling aMsn if you already had install it or had a bad install! code in terminal: sudo remove amsn
Look in your synaptic package manager which version of Tcl/Tk you have! If Tcl8.4 or Tcl8.5 is not installed, download it from here this extension comes with the aMsnpackage ;)

Install the package with this tutorial

Open amsn and configure it with the tab account-preferences.

If your webcam is not supported, it depends on wich webcam you have, install a driver for it. you need to find the driver of your webcam (search in google, you certainly will find one!!!). Install the driver and go to the preferences of amsn and configure your webcam's images and sound.
I have a Philips webcam. my driver is a simple pwc-driver that is present in the synaptic package manager. It DOES need the libsnack2!!!!! so make sure to install this to!
In preferences in aMsn, change in the tab 'others' the sound to Snack library!

That was it for me... I hope this will help someone!
Bye.
AAB
Level 1
Level 1
 
Posts: 8
Joined: Thu May 01, 2008 4:04 pm
Location: Belgium

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: jimallyn and 19 guests