Linux Mint stops before login screen.

Questions about applications and software
Forum rules
Before you post please read how to get help

Linux Mint stops before login screen.

Postby Daweed on Fri May 02, 2008 8:37 am

Please help and heal my disappointment. Like title says , everything stops before login screen and turn to black. I am not a total newbie , I use mint for about 4 months. On the login before this ,I didn't install any program, and it can only be some bug. Before this happens, I've noticed that it displays that some vdr is missing , and in the avahi daemon line , some DNR or DNS word is added. I've been updating it often, and it may be because of that, I don't know, but only thing that I know is that my LINUX DOESN'T WORK. Please help guys!!
User avatar
Daweed
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 15, 2008 9:43 pm

Linux Mint is funded by ads and donations.
 

Re: Linux Mint stops before login screen.

Postby Daweed on Fri May 02, 2008 12:43 pm

Please!!!
User avatar
Daweed
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 15, 2008 9:43 pm

Re: Linux Mint stops before login screen.

Postby 67GTA on Fri May 02, 2008 1:20 pm

Try booting into recovery mode to see what errors it gives.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: Linux Mint stops before login screen.

Postby Lantesh on Fri May 02, 2008 4:31 pm

I have on occasion had this happen, and as far as I can tell it's Xwindows failing to load properly. Hitting control-alt-backspace typically fixes things for me. That combination of keys reloads Xwindows. Good luck.
Lantesh
Level 6
Level 6
 
Posts: 1219
Joined: Sat Apr 12, 2008 1:02 pm

Re: Linux Mint stops before login screen.

Postby Daweed on Sat May 03, 2008 3:35 pm

Sorry, but that didn't helped. Same problem still... :( I am thinking of switching to another distro, but I know that there is not better than Mint, but stabillity lacks in this green OS
User avatar
Daweed
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 15, 2008 9:43 pm

Re: Linux Mint stops before login screen.

Postby newW2 on Sat May 03, 2008 3:52 pm

Go to terminal (ctrl-alt-f5) and type in:
sudo dpkg-reconfigure -phigh xserver-xorg

That will reset your X configuration to the default.
After you use that command type:
sudo reboot.
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Re: Linux Mint stops before login screen.

Postby Daweed on Sat May 03, 2008 4:33 pm

That didn't helped too, I think that its not problem in xserver, I even configured xserver manually after that , but . . . :( . Linux video disk recorder seems not to be running ( computer says), and I think thats maybe the problem, or not? And I don't want to reinstall the system, because it will be the proof to me that the Windows is more secure... :(
User avatar
Daweed
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 15, 2008 9:43 pm

Re: Linux Mint stops before login screen.

Postby newW2 on Sat May 03, 2008 4:53 pm

You said you haven't installed anything. No other distribution in another partition? And you didn't select dist-upgrade in the package manager ... right?
What was the results of the boot in recovery mode?
Did you try to reinstall the graphics driver? In terminal screen enter sudo envy -t.
Sorry there isn't much information other than black screen - that usually means graphics.
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Re: Linux Mint stops before login screen.

Postby Daweed on Sun May 04, 2008 11:44 am

Yes, I didn't install anything, no dist upgrades,no other distros, and everything starts ok in the recovery mode. I don't have drivers installed by envy , just by rest. driv. manager... and offcourse xgl. I've reinstalled system, using reiserfs except ext3, and now , everything works faster under emerald. I think that updates ****** my system, or something was wrong with my radeon 9800pro. which is not 100% compatible with Linux( openGL, rendering). But one question still annoys me. I've updated my Linux before, and use it for 4 months, and nothing ****** it untill now, for no reason :( Thanks guys... I think that this question must be considered by team which takes care of weird bugs :)
Last edited by Oscar799 on Mon May 03, 2010 4:53 am, edited 2 times in total.
Reason: Offensive language removed
User avatar
Daweed
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 15, 2008 9:43 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Google Adsense [Bot], Yahoo [Bot] and 28 guests