Unable to install yEd

Questions about applications and software
Forum rules
Before you post please read this

Unable to install yEd

Postby ioctlvoid on Sun Jan 27, 2013 4:09 pm

I am unable to install yEd on Linux Mint 14 (XFCE, 64-bit).

I execute the following command:

Code: Select all
sh yEd-3.10.1_32-bit_setup.sh


Which gives me the following error:

Code: Select all
libmawt.so: libXtst.so.6: cannot open shared object file: No such file or directory


I have tried this as a regular user, and as root.

I have tried to switch to using the Sun JRE instead of the default OpenJDK.

When I search for: find / -mount -name "libXtst.so.6" I can see I have it in:
/usr/lib/x86_64-linux-gnu/libXtst.so.6

How do I resolve this issue?

Edit:

Code: Select all
export LD_LIBRARY_PATH="/usr/lib/x86_64-linux-gnu"
sh yEd-3.10.1_32-bit_setup.sh
libmawt.so: libXtst.so.6: wrong ELF class: ELFCLASS64


So apparently this requires the 32-bit version of that library. Where can I get that and how do I install that on Linux Mint 14?
ioctlvoid
Level 1
Level 1
 
Posts: 28
Joined: Tue Jan 08, 2013 9:23 am

Linux Mint is funded by ads and donations.
 

Re: Unable to install yEd

Postby xenopeek on Sun Jan 27, 2013 4:38 pm

This is probably a 32-bit build of yEd? Then you would need the 32-bit version of that library. You can either install ia32-libs-multiarch to get most common libraries also install in 32-version, or you can install just this library in 32-bit version. For that you would install libxtst6:i386.

Helpful commands:
Code: Select all
locate libXtst.so.6

Finds much faster than find, as it searches an index database of files instead of the filesystem itself.

Then once you have found the path of the library, you can ask which package installed it:
Code: Select all
dpkg -S /usr/lib/x86_64-linux-gnu/libXtst.so.6

It tells you this comes from the libxtst6:amd64 packages. Replace amd64 with i386 to install the 32-bit version.
Forum Rules | IRC Channel Rules
Image
Arch Linux / 64-bit / Gnome Shell
User avatar
xenopeek
Level 21
Level 21
 
Posts: 13692
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to install yEd

Postby ioctlvoid on Sun Jan 27, 2013 4:44 pm

xenopeek wrote:This is probably a 32-bit build of yEd? Then you would need the 32-bit version of that library. You can either install ia32-libs-multiarch to get most common libraries also install in 32-version, or you can install just this library in 32-bit version. For that you would install libxtst6:i386.

Helpful commands:
Code: Select all
locate libXtst.so.6

Finds much faster than find, as it searches an index database of files instead of the filesystem itself.

Then once you have found the path of the library, you can ask which package installed it:
Code: Select all
dpkg -S /usr/lib/x86_64-linux-gnu/libXtst.so.6

It tells you this comes from the libxtst6:amd64 packages. Replace amd64 with i386 to install the 32-bit version.


Thanks, installing ia32-libs-multiarch worked.
ioctlvoid
Level 1
Level 1
 
Posts: 28
Joined: Tue Jan 08, 2013 9:23 am


Return to Software & Applications

Who is online

Users browsing this forum: jotrago and 16 guests