[SOLVED] Libre Office only opens with Sudo

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] Libre Office only opens with Sudo

Postby grandtheft_jiujitsu on Sun Feb 03, 2013 8:42 am

Hey gang, I have a slight problem trying to open LibreOffice applications. When I try to open them normally (GUI or by terminal) I get the following error message:

Code: Select all
The application cannot be started.
Failed to updatefile:///home/savagedzen/.config/libreoffice/3/user/extensions/bundled/lastsynchronized


For a little background, I was messing with Grub themes and couldn't see my boot options. So I booted from a live USB, backed up my personal data, re-installed mint from the live USB, and restored my data. Now I can't seem to open LibreOffice (or any of its applications) unless I do so as root/sudo (ie: the applications will work normally if I open them as w/ a sudo command or "open as root" with the GUI)

I've tried re-installing them via synaptic package manager but to no avail. I also had a look at this thread [http://forums.linuxmint.com/viewtopic.php?f=47&t=96573&p=552374&hilit=libre+office+failed#p552374] and couldn't find anything to get it working. Any suggestions would be greatly appreciated. Thanks!



******EDIT****** Problems solved. However, I didn't delete the thread in case someone has a similar issue. I found out that one of my important documents was being protected (a good thing). As a result, only the owner as SU could open it; thus since you access the file from opening LibreOffive you needed to be SU to open LibreOffice in general. Now, I had checked the permissions ("ls -l") of the application shortcuts, but hadn't thought to check individual files. The solution I used was to open my /home/user/Documents folder as root and located a file that had a padlock icon on it. I right clicked -> properties -> permissions -> changed Group access to "read and write." Worked for me, hopefully helps someone else too.
Keep your desktop smooth, clean, and sexy.
Asus N53SVxv1 - Linux Mint 15 - Cinnamon - Kernel (playing)
grandtheft_jiujitsu
Level 1
Level 1
 
Posts: 21
Joined: Sun Aug 26, 2012 11:31 pm
Location: Georgia, USA

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 23 guests