Dependency hell

Questions about applications and software
Forum rules
Before you post please read this

Dependency hell

Postby fabben on Mon Feb 11, 2013 8:58 am

Hi!

I just did an upgrade and my /boot partition on 64 MB went full. (It was partionated automaticly by the Linux Mint installer).

There was some old kernels there, and I deleted the oldest one, initrd.img-3.2.0-23-generic.

But now I'm in some kind of "dependency hell". Can someone give me some help with this? I don't even know if I dare to reboot the machine...

cat /etc/apt/sources.list:
Code: Select all
deb http://packages.linuxmint.com/ maya main upstream import
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ precise partner
deb http://packages.medibuntu.org/ precise free non-free

uname -a:
Code: Select all
Linux sune 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:41:24 UTC 2013 i686 i686 i386 GNU/Linux

apt-get upgrade:
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.1~) but 0.99ubuntu13.1 is installed
E: Unmet dependencies. Try using -f.
sune boot #

And then I tried to do it with the "-f" flag:
Code: Select all
sune boot # apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-34-generic linux-headers-3.2.0-34 icedtea-7-jre-cacao
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  initramfs-tools
The following packages will be upgraded:
  initramfs-tools
1 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
9 not fully installed or removed.
Need to get 0 B/49.0 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue [Y/n]?
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on initramfs-tools-bin (<< 0.99ubuntu13.1~); however:
  Version of initramfs-tools-bin on system is 0.99ubuntu13.1.
dpkg: error processing initramfs-tools (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing plymouth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-theme-ubuntu-text:
 plymouth-theme-ubuntu-text depends on plymouth; however:
  Package plymouth is not configured yet.
dpkg: error processing plymouth-theme-ubuntu-text (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-label:
 plymouth-label depends on plymouth (= 0.8.2-2ubuntu31); however:
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                       No apport report written because MaxReports is reached already
                                                                                                       Package plymouth is not configured yet.
dpkg: error processing plymouth-label (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mountall:
 mountall depends on plymouth; however:
  Package plymouth is not configured yet.
dpkg: error processing mountall (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of upstart:
 upstart depends on mountall; however:
  Package mountall is not configured yet.
dpkg: error processing upstart (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mysql-server-5.5:
 mysql-server-5.5 depends on upstart-job; however:
  Package upstart-job is not installed.
  Package upstart which provides upstart-job is not configured yet.
 mysql-server-5.5 depends on upstart (>= 0.6.7-2); however:
  Package upstart is not configured yet.
dpkg: error processing mysql-server-5.5 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 initramfs-tools
 plymouth
 ubuntu-minimal
 plymouth-theme-ubuntu-text
 plymouth-label
 mountall
 upstart
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
sune boot #

Please, I don't know what to do. :-/
Last edited by xenopeek on Mon Feb 11, 2013 9:26 am, edited 1 time in total.
Reason: Moved from LMDE forum to Main Edition forum; added code tags to terminal output.
fabben
Level 1
Level 1
 
Posts: 6
Joined: Mon Feb 11, 2013 8:48 am

Linux Mint is funded by ads and donations.
 

Re: Dependency hell

Postby xenopeek on Mon Feb 11, 2013 9:37 am

Have you done an "apt update" first? Else upgrading will try to install old packages...

It looks like initramfs-tools-bin is already upgrade to the 0.99ubuntu13.1 version but your initramfs-tools package is still at 0.99ubuntu13. Can you try the following?
Code: Select all
apt-get update
apt-get install -f initramfs-tool
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14561
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Dependency hell

Postby fabben on Mon Feb 11, 2013 9:42 am

Thank you. Yes, I have done "apt-get update" a lot of times.
Code: Select all
sune boot # apt-get install -f initramfs-tools
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-34-generic linux-headers-3.2.0-34 icedtea-7-jre-cacao
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
  initramfs-tools
1 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
9 not fully installed or removed.
Need to get 0 B/49.0 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on initramfs-tools-bin (<< 0.99ubuntu13.1~); however:
  Version of initramfs-tools-bin on system is 0.99ubuntu13.1.
dpkg: error processing initramfs-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing plymouth (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            No apport report written because MaxReports is reached already
             dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-theme-ubuntu-text:
 plymouth-theme-ubuntu-text depends on plymouth; however:
  Package plymouth is not configured yet.
dpkg: error processing plymouth-theme-ubuntu-text (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-label:
 plymouth-label depends on plymouth (= 0.8.2-2ubuntu31); however:
  Package plymouth is not configured yet.
dpkg: error processing plymouth-label (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mountall:
 mountall depends on plymouth; however:
  Package plymouth is not configured yet.
dpkg: error processing mountall (--coNo apport report written because MaxReports is reached already
                                                                                                   No apport report written because MaxReports is reached already
                                                                                                                                                                 No apport report written because MaxReports is reached already
                                                  No apport report written because MaxReports is reached already
                                                                                                                No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
                                                               nfigure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of upstart:
 upstart depends on mountall; however:
  Package mountall is not configured yet.
dpkg: error processing upstart (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mysql-server-5.5:
 mysql-server-5.5 depends on upstart-job; however:
  Package upstart-job is not installed.
  Package upstart which provides upstart-job is not configured yet.
 mysql-server-5.5 depends on upstart (>= 0.6.7-2); however:
  Package upstart is not configured yet.
dpkg: error processing mysql-server-5.5 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 initramfs-tools
 plymouth
 ubuntu-minimal
 plymouth-theme-ubuntu-text
 plymouth-label
 mountall
 upstart
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
sune boot #
fabben
Level 1
Level 1
 
Posts: 6
Joined: Mon Feb 11, 2013 8:48 am

Re: Dependency hell

Postby xenopeek on Mon Feb 11, 2013 10:03 am

Right, that was the easiest approach... You can check which upgrades where completed earlier (look at timestamp beginning of the line) with:
Code: Select all
grep " upgrade " /var/log/dpkg.log

Just putting that here as it might be useful later.

Alright, if nobody else has a better idea, I have two riskier alternatives you may try. First one is to downgrade the initramfs-tools-bin package to the version that initramfs-tools is expecting. To do so, first download the older version of the package and then install the downloaded file with dpkg (replace amd64 with i386 if you are on 32 bit).
Code: Select all
apt-get download initramfs-tools-bin=0.99ubuntu13
dpkg -i initramfs-tools-bin_0.99ubuntu13_amd64.deb

If that works, great! Try the apt-get upgrade again, share any new or further errors here.

If it doesn't work, let's first install the 0.99ubuntu13.1 version of initramfs-tools-bin again and then try the same trick with dpkg to download and install initramfs-tools version 0.99ubuntu13.1 manually.
Code: Select all
apt-get download initramfs-tools-bin=0.99ubuntu13.1
dpkg -i initramfs-tools-bin_0.99ubuntu13.1_amd64.deb
apt-get download initramfs-tools=0.99ubuntu13.1
dpkg -i initramfs-tools_0.99ubuntu13.1_all.deb
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14561
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Dependency hell

Postby fabben on Mon Feb 11, 2013 10:25 am

Code: Select all
sune boot # grep " upgrade " /var/log/dpkg.log
2013-02-11 13:17:41 upgrade base-files 6.5ubuntu6.4 6.5ubuntu6.5
2013-02-11 13:21:11 upgrade initramfs-tools-bin 0.99ubuntu13 0.99ubuntu13.1
2013-02-11 13:21:11 upgrade libdrm2 2.4.32-1ubuntu1 2.4.39-0ubuntu0.1
2013-02-11 13:21:11 upgrade libdrm-intel1 2.4.32-1ubuntu1 2.4.39-0ubuntu0.1
2013-02-11 13:21:11 upgrade libdrm-nouveau1a 2.4.32-1ubuntu1 2.4.39-0ubuntu0.1
2013-02-11 13:21:11 upgrade libdrm-radeon1 2.4.32-1ubuntu1 2.4.39-0ubuntu0.1
2013-02-11 13:21:11 upgrade libnih-dbus1 1.0.3-4ubuntu9 1.0.3-4ubuntu9.1
2013-02-11 13:21:12 upgrade libnih1 1.0.3-4ubuntu9 1.0.3-4ubuntu9.1
2013-02-11 13:21:12 upgrade upstart 1.5-0ubuntu7 1.5-0ubuntu7.2
2013-02-11 13:21:12 upgrade plymouth-label 0.8.2-2ubuntu30 0.8.2-2ubuntu31
2013-02-11 13:21:12 upgrade plymouth 0.8.2-2ubuntu30 0.8.2-2ubuntu31
2013-02-11 13:21:12 upgrade libplymouth2 0.8.2-2ubuntu30 0.8.2-2ubuntu31
2013-02-11 13:21:12 upgrade mountall 2.36.3 2.36.4
2013-02-11 13:21:12 upgrade gstreamer0.10-plugins-bad 0.10.22.3-2ubuntu2.1 0.10.22.3-2ubuntu2.2
2013-02-11 13:21:12 upgrade libgstreamer-plugins-bad0.10-0 0.10.22.3-2ubuntu2.1 0.10.22.3-2ubuntu2.2
2013-02-11 13:21:13 upgrade language-pack-en 1:12.04+20120801 1:12.04+20130128
2013-02-11 13:21:13 upgrade language-pack-en-base 1:12.04+20120801 1:12.04+20130128
2013-02-11 13:21:13 upgrade language-pack-gnome-en 1:12.04+20120801 1:12.04+20130128
2013-02-11 13:21:13 upgrade language-pack-gnome-en-base 1:12.04+20120801 1:12.04+20130128
2013-02-11 13:21:15 upgrade libav-tools 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:15 upgrade libpostproc52 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:15 upgrade libavfilter2 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:15 upgrade libswscale2 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:15 upgrade libavdevice53 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:15 upgrade libavformat53 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:15 upgrade libavcodec53 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:15 upgrade libavutil51 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:16 upgrade xserver-common 2:1.11.4-0ubuntu10.8 2:1.11.4-0ubuntu10.11
2013-02-11 13:21:16 upgrade libgl1-mesa-dri 8.0.4-0ubuntu0.2 8.0.4-0ubuntu0.3
2013-02-11 13:21:16 upgrade xserver-xorg-core 2:1.11.4-0ubuntu10.8 2:1.11.4-0ubuntu10.11
2013-02-11 13:21:16 upgrade libgl1-mesa-glx 8.0.4-0ubuntu0.2 8.0.4-0ubuntu0.3
2013-02-11 13:21:16 upgrade libglapi-mesa 8.0.4-0ubuntu0.2 8.0.4-0ubuntu0.3
2013-02-11 13:21:16 upgrade mysql-common 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:17 upgrade libmysqlclient18 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:17 upgrade libssh-4 0.5.2-1ubuntu0.12.04.1 0.5.2-1ubuntu0.12.04.2
2013-02-11 13:21:17 upgrade libxatracker1 8.0.4-0ubuntu0.2 8.0.4-0ubuntu0.3
2013-02-11 13:21:17 upgrade mysql-server 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:19 upgrade mysql-server-5.5 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:22 upgrade mysql-client 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:22 upgrade mysql-client-5.5 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:22 upgrade mysql-client-core-5.5 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:22 upgrade mysql-server-core-5.5 5.5.28-0ubuntu0.12.04.3 5.5.29-0ubuntu0.12.04.1
2013-02-11 13:21:22 upgrade libglu1-mesa 8.0.4-0ubuntu0.2 8.0.4-0ubuntu0.3
2013-02-11 13:21:23 upgrade isc-dhcp-client 4.1.ESV-R4-0ubuntu5.5 4.1.ESV-R4-0ubuntu5.6
2013-02-11 13:21:23 upgrade isc-dhcp-common 4.1.ESV-R4-0ubuntu5.5 4.1.ESV-R4-0ubuntu5.6
2013-02-11 13:21:23 upgrade ubuntu-minimal 1.267 1.267.1
2013-02-11 13:21:23 upgrade plymouth-theme-ubuntu-text 0.8.2-2ubuntu30 0.8.2-2ubuntu31
2013-02-11 13:21:23 upgrade dkms 2.2.0.3-1ubuntu3 2.2.0.3-1ubuntu3.1
2013-02-11 13:21:23 upgrade firefox 18.0+build1-0ubuntu0.12.04.3 18.0.2+build1-0ubuntu0.12.04.1
2013-02-11 13:21:24 upgrade firefox-gnome-support 18.0+build1-0ubuntu0.12.04.3 18.0.2+build1-0ubuntu0.12.04.1
2013-02-11 13:21:24 upgrade firefox-locale-en 18.0+build1-0ubuntu0.12.04.3 18.0.2+build1-0ubuntu0.12.04.1
2013-02-11 13:21:24 upgrade fuse-exfat 0.9.8-1 1.0.1-1
2013-02-11 13:21:24 upgrade libtelepathy-glib0 0.18.0-1ubuntu1 0.18.2-0ubuntu1
2013-02-11 13:21:24 upgrade gir1.2-telepathyglib-0.12 0.18.0-1ubuntu1 0.18.2-0ubuntu1
2013-02-11 13:21:24 upgrade grub-pc 1.99-21ubuntu3.7 1.99-21ubuntu3.9
2013-02-11 13:21:24 upgrade grub-pc-bin 1.99-21ubuntu3.7 1.99-21ubuntu3.9
2013-02-11 13:21:25 upgrade grub2-common 1.99-21ubuntu3.7 1.99-21ubuntu3.9
2013-02-11 13:21:25 upgrade grub-common 1.99-21ubuntu3.7 1.99-21ubuntu3.9
2013-02-11 13:21:25 upgrade jockey-gtk 0.9.7-0ubuntu7.4 0.9.7-0ubuntu7.7
2013-02-11 13:21:25 upgrade jockey-common 0.9.7-0ubuntu7.4 0.9.7-0ubuntu7.7
2013-02-11 13:21:25 upgrade php5-cli 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade php5-mysql 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade php5-ldap 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade php5-curl 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade php5-gd 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade php5-gmp 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade php5-pgsql 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade libapache2-mod-php5 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade php5-common 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:26 upgrade linux-libc-dev 3.2.0-36.57 3.2.0-37.58
2013-02-11 13:21:27 upgrade php5 5.3.10-1ubuntu3.4 5.3.10-1ubuntu3.5
2013-02-11 13:21:27 upgrade vino 3.4.2-0ubuntu1.1 3.4.2-0ubuntu1.2
2013-02-11 13:21:27 upgrade xserver-xorg-video-intel 2:2.17.0-1ubuntu4.2 2:2.17.0-1ubuntu4.3
2013-02-11 13:21:27 upgrade xserver-xorg-video-qxl 0.0.16-2 0.0.16-2ubuntu0.1
2013-02-11 13:21:27 upgrade ffmpeg 4:0.8.4-0ubuntu0.12.04.1 4:0.8.5-0ubuntu0.12.04.1
2013-02-11 13:21:27 upgrade gnome-settings-daemon 3.4.2-0ubuntu0.6 3.4.2-0ubuntu0.6.2
sune boot #

fabben
Level 1
Level 1
 
Posts: 6
Joined: Mon Feb 11, 2013 8:48 am

Re: Dependency hell

Postby fabben on Mon Feb 11, 2013 10:30 am

I am so glad you trying to help me. :) There is the results so far:

Code: Select all
sune boot # uname -a
Linux sune 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:41:24 UTC 2013 i686 i686 i386 GNU/Linux
sune boot # apt-get download initramfs-tools-bin=0.99ubuntu13
Get:1 Downloading initramfs-tools-bin 0.99ubuntu13 [9,900 B]
Fetched 9,900 B in 0s (136 kB/s)               
sune boot # dpkg -i initramfs-tools-bin_0.99ubuntu13_i386.deb
dpkg: warning: downgrading initramfs-tools-bin from 0.99ubuntu13.1 to 0.99ubuntu13.
(Reading database ... 241019 files and directories currently installed.)
Preparing to replace initramfs-tools-bin 0.99ubuntu13.1 (using initramfs-tools-bin_0.99ubuntu13_i386.deb) ...
Unpacking replacement initramfs-tools-bin ...
Setting up initramfs-tools-bin (0.99ubuntu13) ...
sune boot #


No problem here. Then I tried upgrading:

Code: Select all
sune boot # apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
The following packages will be upgraded:
  initramfs-tools initramfs-tools-bin
2 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
9 not fully installed or removed.
Need to get 0 B/58.9 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 241019 files and directories currently installed.)
Preparing to replace initramfs-tools-bin 0.99ubuntu13 (using .../initramfs-tools-bin_0.99ubuntu13.1_i386.deb) ...
Unpacking replacement initramfs-tools-bin ...
Setting up initramfs-tools-bin (0.99ubuntu13.1) ...
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on initramfs-tools-bin (<< 0.99ubuntu13.1~); however:
  Version of initramfs-tools-bin on system is 0.99ubuntu13.1.
dpkg: error processing initramfs-tools (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing plymouth (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of plymouth-theme-ubuntu-text:
 plymouth-theme-ubuntu-text depends on plymouth; however:
  Package plymouth is not configured yet.
dpkg: error processing plymouth-theme-ubuntu-text (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of plymouth-label:
 plymouth-label depends on plymouth (= 0.8.2-2ubuntu31); however:
  Package plymouth is not configured yet.
dpkg: error processing plymouth-label (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mountall:
 mountall depends on plymouth; however:
  Package plymouth is not configured yet.
dpkg: error processing mountall (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of upstart:
 upstart depends on mountall; however:
  Package mountall is not configured yet.
dpkg: error processing upstart (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mysql-server-5.5:
 mysql-server-5.5 depends on upstart-job; however:
  Package upstart-job is not installed.
  Package upstart which provides upstart-job is not configured yet.
 mysql-server-5.5 depends on upstart (>= 0.6.7-2); however:
  Package upstart is not configured yet.
dpkg: error processing mysql-server-5.5 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 initramfs-tools
 plymouth
 ubuntu-minimal
 plymouth-theme-ubuntu-text
 plymouth-label
 mountall
 upstart
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
sune boot #


Now I'll try your last suggestion.
fabben
Level 1
Level 1
 
Posts: 6
Joined: Mon Feb 11, 2013 8:48 am

Re: Dependency hell

Postby fabben on Mon Feb 11, 2013 10:36 am

Unfortunately it didn't helped :-/

Code: Select all
sune boot # apt-get download initramfs-tools-bin=0.99ubuntu13.1
Get:1 Downloading initramfs-tools-bin 0.99ubuntu13.1 [9,912 B]
Fetched 9,912 B in 0s (134 kB/s)
sune boot # dpkg -i initramfs-tools-bin_0.99ubuntu13_i386.deb
dpkg: warning: downgrading initramfs-tools-bin from 0.99ubuntu13.1 to 0.99ubuntu13.
(Reading database ... 241019 files and directories currently installed.)
Preparing to replace initramfs-tools-bin 0.99ubuntu13.1 (using initramfs-tools-bin_0.99ubuntu13_i386.deb) ...
Unpacking replacement initramfs-tools-bin ...
Setting up initramfs-tools-bin (0.99ubuntu13) ...
sune boot # apt-get download initramfs-tools=0.99ubuntu13.1
Get:1 Downloading initramfs-tools 0.99ubuntu13.1 [49.0 kB]
Fetched 49.0 kB in 0s (331 kB/s)
sune boot # dpkg -i initramfs-tools_0.99ubuntu13.1_all.deb
(Reading database ... 241019 files and directories currently installed.)
Preparing to replace initramfs-tools 0.99ubuntu13 (using initramfs-tools_0.99ubuntu13.1_all.deb) ...
Unpacking replacement initramfs-tools ...
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on initramfs-tools-bin (>= 0.99ubuntu13.1); however:
  Version of initramfs-tools-bin on system is 0.99ubuntu13.
dpkg: error processing initramfs-tools (--install):
 dependency problems - leaving unconfigured
Processing triggers for doc-base ...
Processing 1 changed doc-base file...
Registering documents with scrollkeeper...
Processing triggers for man-db ...
Errors were encountered while processing:
 initramfs-tools
sune boot #
fabben
Level 1
Level 1
 
Posts: 6
Joined: Mon Feb 11, 2013 8:48 am

Re: Dependency hell

Postby xenopeek on Mon Feb 11, 2013 10:51 am

You made a mistake in that last attempt, you installed initramfs-tools-bin_0.99ubuntu13_i386.deb while you should install initramfs-tools-bin_0.99ubuntu13.1_i386.deb. So try the install commands anew with:
Code: Select all
dpkg -i initramfs-tools-bin_0.99ubuntu13.1_i386.deb
dpkg -i initramfs-tools_0.99ubuntu13.1_all.deb
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14561
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Dependency hell

Postby fabben on Mon Feb 11, 2013 11:04 am

Code: Select all
sune boot # dpkg -i initramfs-tools-bin_0.99ubuntu13.1_i386.deb
(Reading database ... 241019 files and directories currently installed.)
Preparing to replace initramfs-tools-bin 0.99ubuntu13 (using initramfs-tools-bin_0.99ubuntu13.1_i386.deb) ...
Unpacking replacement initramfs-tools-bin ...
Setting up initramfs-tools-bin (0.99ubuntu13.1) ...
sune boot # dpkg -i initramfs-tools_0.99ubuntu13.1_all.deb
(Reading database ... 241019 files and directories currently installed.)
Preparing to replace initramfs-tools 0.99ubuntu13.1 (using initramfs-tools_0.99ubuntu13.1_all.deb) ...
Unpacking replacement initramfs-tools ...
Setting up initramfs-tools (0.99ubuntu13.1) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for doc-base ...
Processing 1 changed doc-base file...
Registering documents with scrollkeeper...
Processing triggers for man-db ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-36-generic
Warning: No support for locale: en_US.utf8
sune boot # apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
8 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?
Setting up upstart (1.5-0ubuntu7.2) ...
Setting up mysql-server-5.5 (5.5.29-0ubuntu0.12.04.1) ...
mysql start/running, process 1875
Setting up ubuntu-minimal (1.267.1) ...
Setting up mysql-server (5.5.29-0ubuntu0.12.04.1) ...
Setting up plymouth (0.8.2-2ubuntu31) ...
update-initramfs: deferring update (trigger activated)
Setting up plymouth-theme-ubuntu-text (0.8.2-2ubuntu31) ...
update-initramfs: deferring update (trigger activated)
Setting up plymouth-label (0.8.2-2ubuntu31) ...
Setting up mountall (2.36.4) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-36-generic
Warning: No support for locale: en_US.utf8
sune boot #


\o/

I suppose it worked! Thank you very much!
fabben
Level 1
Level 1
 
Posts: 6
Joined: Mon Feb 11, 2013 8:48 am

Re: Dependency hell

Postby xenopeek on Mon Feb 11, 2013 11:16 am

Well, I hope this was it but it certainly looks good :D
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14561
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: BenTrabetere and 29 guests