Keepass2 or KeepassX auto-type

Questions about applications and software
Forum rules
Before you post please read this

Keepass2 or KeepassX auto-type

Postby Martin1986 on Wed Feb 27, 2013 2:27 pm

i try to use the auto-type function of booth programs, but its not work for me

i just want to keepassx or 2 in the way that i open it and log me to different websites via a shortcut...

in keypassX the button auto-type works for some web-pages but not for all(the shortcut doesn't work)...
in keypass2 the auto-type button doesn't do anything the shortcut as well...

any ideas?
Martin1986
Level 1
Level 1
 
Posts: 3
Joined: Wed Feb 27, 2013 2:15 pm

Linux Mint is funded by ads and donations.
 

Re: Keepass2 or KeepassX auto-type

Postby mustard on Wed Feb 27, 2013 5:04 pm

That seems to be an issue that might get more answers via keepassx support. Just a suggestion.

Sent from my Nexus 7 using Tapatalk HD
User avatar
mustard
Level 1
Level 1
 
Posts: 5
Joined: Mon Jul 25, 2011 4:10 pm

Re: Keepass2 or KeepassX auto-type

Postby grizzler on Thu Feb 28, 2013 2:07 pm

The only 'support' available for KeePassX on Linux is through the KeePassX forum and in my experience the chances of getting a usefull answer there are pretty slim, so I can understand why someone would try here.
That said, I've had no real problems with Auto-Type. It just works. Using KeePassX, that is. KeePass2 needs the .NET replacement Mono and the Auto-Type function doesn't work at all through that.
grizzler
Level 4
Level 4
 
Posts: 437
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: Keepass2 or KeepassX auto-type

Postby Martin1986 on Fri Mar 01, 2013 12:20 pm

okay thanks,
i figured out that the problems from some website are due to other sequences so it works now for all sites...
but the shortcut doesn't work maybe i forget something, i just set in keepassX the global shortcut anything else i have to do?
Martin1986
Level 1
Level 1
 
Posts: 3
Joined: Wed Feb 27, 2013 2:15 pm

Re: Keepass2 or KeepassX auto-type

Postby grizzler on Fri Mar 01, 2013 1:53 pm

Nothing else I can think of. I changed the default (wasn't that Ctrl+Alt+A?) to Ctrl+Alt+\ and used Ctrl+Alt+Z on another computer that had a keyboard with no \ key near the left Ctrl key and it all worked immediately.

There is an option below the global shortcut box which has to be set (the one about selecting the window based on the title of the item - I'm not sure what the English text is as I'm using a non-English version). Is that set by default? Can't remember.

Of course if the title of the item is very different from the title of the browser window, Auto-Type may not work. I have several entries in my database that required the Auto-Type-Window to be set manually.
grizzler
Level 4
Level 4
 
Posts: 437
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

solved: Keepass2 or KeepassX auto-type

Postby Martin1986 on Sat Mar 02, 2013 6:13 am

:D thx close to the solutions i need to go on entry->edit-> tools selected target window and then it works :roll: sry my fault and thanks for you help
Martin1986
Level 1
Level 1
 
Posts: 3
Joined: Wed Feb 27, 2013 2:15 pm

Re: Keepass2 or KeepassX auto-type

Postby rob_sp on Mon Aug 12, 2013 5:56 am

Hi, I have the same problem but none of these solutions seem to work for me. I can't get global auto-type to respond.

I have installed the latest keepass2 from the ppa: https://launchpad.net/~jtaylor/+archive/keepass
I have also installed xdotool which is: 2.20110530.1-3ubuntu1


I have set a global hot key and have tried:
mono /usr/lib/keepass2/KeePass.exe --auto-type
/usr/lib/keepass2/KeePass.exe --auto-type
mono /usr/bin/keepass2 --auto-type
/usr/bin/keepass2 --auto-type

I have my keypass2 open as a window.
I have a test entry entitled 'pluma' with a test username and password.
I have tried using the global auto-key in a new pluma window and nothing happens.
Going to keepass and pressing cntrl-v does work but I really want to get the global auto-type to work.

With a pluma window open as 'Unsaved Document 1 - pluma', I have also tried setting it as a target window.
The target window drop down includes the window title exactly as above and I have set that. Still nothing.

It isn't the set-up of the hotkey itself as 'mono /usr/lib/keepass2/KeePass.exe' (without '--auto-type') will happily open a new keepass instance. When I add '--auto-type', I get nothing.

I figure it must be something to do with not matching the window titles.

Any help would be great.

Edit: Still no luck. I've scoured the internets and have tried all. I'm now using keypassx which works fine on mint with auto-type and everything. However, it means I have to use keypass1 portable on other linux pcs where I have no root access to install keypassx. This means running under wine and means no auto-type functionality.
Installing keypass2 portable on a ubuntu machine where I have no root access and running with mono works fine. I don't understand how the auto-type can be working fine on that ubuntu machine and not on my linux mint machine. keypass2 portable is incompatible with keypassx so I had to change it to keypass1 and I'll just have to deal with no auto-type when using the portable version.
rob_sp
Level 1
Level 1
 
Posts: 1
Joined: Mon Aug 12, 2013 5:43 am

Re: Keepass2 or KeepassX auto-type

Postby gnewt on Sat May 03, 2014 1:24 am

Edit: Still no luck. I've scoured the internets and have tried all. I'm now using keypassx which works fine on mint with auto-type and everything. However, it means I have to use keypass1 portable on other linux pcs where I have no root access to install keypassx. This means running under wine and means no auto-type functionality.


It works fine for me in Mint 16 / Cinnamon / 64bit using this string:
Code: Select all
/usr/bin/cli /usr/lib/keepass2/KeePass.exe --auto-type


(in case you still haven't got it working, these many months later!)
gnewt
Level 1
Level 1
 
Posts: 1
Joined: Sat May 03, 2014 1:19 am

Re: Keepass2 or KeepassX auto-type

Postby fry on Sat Jul 19, 2014 4:17 am

gnewt wrote:
Edit: Still no luck. I've scoured the internets and have tried all. I'm now using keypassx which works fine on mint with auto-type and everything. However, it means I have to use keypass1 portable on other linux pcs where I have no root access to install keypassx. This means running under wine and means no auto-type functionality.


It works fine for me in Mint 16 / Cinnamon / 64bit using this string:
Code: Select all
/usr/bin/cli /usr/lib/keepass2/KeePass.exe --auto-type


(in case you still haven't got it working, these many months later!)


This works for me too. Thanks for taking the time to reply with solution!
fry
Level 1
Level 1
 
Posts: 1
Joined: Sat Jul 19, 2014 4:13 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: wuftanoz and 17 guests