Linux Mint 14 - Libjpeg8 and Libjpeg8:i386 Broken

Questions about applications and software
Forum rules
Before you post please read how to get help

Linux Mint 14 - Libjpeg8 and Libjpeg8:i386 Broken

Postby Spessarite on Thu Feb 28, 2013 11:16 pm

My problem is that my libjpeg8 and libjpeg8:i386 are both broken, they are conflicting with each other and I have tried to uninstall them and ended up with a broken system and being forced to re-install my entire operating system (so don't even suggest for me to uninstall one of them because a lot of applications depend on both). Anyways, I run a 64 Bit version of Linux Mint 14 on a laptop. Everything works fine besides the fact that anything and I mean anything that depends on libjpeg8 cannot be installed because it is broken. If anyone knows a fix to this (hopefully permanent fix) that would be great.
Spessarite
Level 1
Level 1
 
Posts: 2
Joined: Thu Feb 28, 2013 11:09 pm

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 14 - Libjpeg8 and Libjpeg8:i386 Broken

Postby anandrkris on Thu Feb 28, 2013 11:22 pm

Not sure, if this will help. Can you try this, if you haven't already?
Code: Select all
sudo apt-get install --reinstall libjpeg8
sudo apt-get install --reinstall libjpeg8:i386
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 952
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Linux Mint 14 - Libjpeg8 and Libjpeg8:i386 Broken

Postby Spessarite on Thu Feb 28, 2013 11:24 pm

Just tried, got a error:
Code: Select all
sudo apt-get install --reinstall libjpeg8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  libjpeg8
1 upgraded, 0 newly installed, 0 to remove and 514 not upgraded.
24 not fully installed or removed.
Need to get 0 B/134 kB of archives.
After this operation, 268 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libjpeg8
Install these packages without verification [y/N]? y
(Reading database ... 145996 files and directories currently installed.)
Preparing to replace libjpeg8:amd64 8c-2ubuntu7 (using .../libjpeg8_8d-1_amd64.deb) ...
Unpacking replacement libjpeg8:amd64 ...
dpkg: error processing /var/cache/apt/archives/libjpeg8_8d-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libjpeg.so.8', which is also in package libjpeg-turbo8:amd64 1.2.1-0ubuntu2
Errors were encountered while processing:
 /var/cache/apt/archives/libjpeg8_8d-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Spessarite
Level 1
Level 1
 
Posts: 2
Joined: Thu Feb 28, 2013 11:09 pm

Re: Linux Mint 14 - Libjpeg8 and Libjpeg8:i386 Broken

Postby Lacoste on Mon Jul 15, 2013 7:24 pm

This happened to me as well, while trying to install Kali Linux packages on top of Linux Mint 14 (rough steps: http://em3rgency.com/create-your-own-pentesting-operating-system/). Any suggestions?
Code: Select all
mintyfresh apt # apt-get update
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libjpeg8 : Breaks: libjpeg8:i386 (!= 8c-2ubuntu7) but 8d-1 is installed
 libjpeg8:i386 : Breaks: libjpeg8 (!= 8d-1) but 8c-2ubuntu7 is installed
E: Unmet dependencies. Try using -f.

I'll probably try the same steps using Ubuntu, or just use the Kali distro.
Using Linux since 1992 ...
Lacoste
Level 1
Level 1
 
Posts: 1
Joined: Sat Oct 04, 2008 2:17 pm
Location: Washington, D.C.


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 15 guests