Skype in a 64bit linux mint 14 computer- V4l problems

Questions about applications and software
Forum rules
Before you post please read this

Skype in a 64bit linux mint 14 computer- V4l problems

Postby gonzobilbao on Sun Mar 10, 2013 7:10 pm

Hi

I have skype in my 64 bit machine -hp envy4 1050ca. i was getting this blue scrambled video nad the following message

Code: Select all
ERROR: ld.so: object '/usr/lib32/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.


So I found that a possible solution would be to run skype using the following command to start it from v4l2convert.so. I found I have two v4l2convert.so files, so I tried to start the program from both of them, as follows:

Code: Select all
bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so skype'

bash -c 'LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so skype'


so far no success. Neither of them worked. Trying to launch skype from v4l1compat.so did not have any effect as well.

As the skype readme suggests, I installed lib32v4l-0, however it did not work.

Then I followed these steps (can be found in http://community.linuxmint.com/tutorial/view/318)
1. Update repository:

sudo apt-get update

2. Install all stuff:
sudo apt-get install ia32-libs ia32-libs-gtk skype pidgin-skype

3. Run it from your start-men

Now I get this output when running skype from a terminal
Code: Select all
ERROR: ld.so: object '/usr/lib32/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
Gtk-Message: Failed to load module "atk-bridge"
`menu_proxy_module_load': /usr/bin/skype: undefined symbol: menu_proxy_module_load

(skype:6938): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': /usr/bin/skype: undefined symbol: menu_proxy_module_load

(skype:6938): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': /usr/bin/skype: undefined symbol: menu_proxy_module_load

(skype:6938): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': /usr/bin/skype: undefined symbol: menu_proxy_module_load

(skype:6938): Gtk-WARNING **: Failed to load type module: (null)


I tryed to undo the last steps and make a fresh skype installation, but the problem persists, does anybody have a clue on what to do? I still get crappy vieo quality, although in my old 64bit computer the quality is just fine. I cheese the quality isn't great either (and same, Is worst than in my old computer!!)

Thanks for any idea!
gonzobilbao
Level 1
Level 1
 
Posts: 16
Joined: Wed Jun 06, 2012 6:47 am

Linux Mint is funded by ads and donations.
 

Re: Skype in a 64bit linux mint 14 computer- V4l problems

Postby gonzobilbao on Tue Mar 12, 2013 9:06 pm

UPDATE: I got over the error concerning v4l1compat.so, by changing the pathway in usr/bin/skype to v4l2convert.so. Video quality improved quite a lot, however still crapy if compared to the one in my old 64bit computer... still get the rest of the erros in the log above...
gonzobilbao
Level 1
Level 1
 
Posts: 16
Joined: Wed Jun 06, 2012 6:47 am

Re: Skype in a 64bit linux mint 14 computer- V4l problems

Postby gonzobilbao on Sat Mar 23, 2013 9:19 pm

!!!
gonzobilbao
Level 1
Level 1
 
Posts: 16
Joined: Wed Jun 06, 2012 6:47 am


Return to Software & Applications

Who is online

Users browsing this forum: niowluka and 22 guests