xbindkeys startup

Questions about applications and software
Forum rules
Before you post please read this

xbindkeys startup

Postby prabhatjn on Tue Mar 19, 2013 1:55 am

Hi,

my xbindkeys at startup does not run properly. I have made .xbindkeyrc in my home directory and gave it chmod 755. I see in my system monitor that when my system starts it takes that file and start the xbindkey process, however my keyboard shortcuts does not work. They work only if I manually end that process and restart it on terminal by giving command "xbindkeys -f /home/prabhatjn/.xbindkeysrc".

Can someone help?

Thanks,
Prabhat.
User avatar
prabhatjn
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 28, 2011 3:57 pm
Location: Indore, India

Linux Mint is funded by ads and donations.
 

Re: xbindkeys startup

Postby viking777 on Tue Mar 19, 2013 10:53 am

Have you added xbindkeys to the startup programs? The conf file in your home folder isn't going to run it.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: xbindkeys startup

Postby prabhatjn on Wed Mar 20, 2013 3:31 am

Hi viking777,

Thanks for reply. Actually if I put it in the startup applications then two instances of xbindkeys starts. If I change the name of .xbindkeyrc to something else and then load it in startup with -f option then only one instance open. But whatever I do it is not able to bind the keys at startup.

Prabhat.
User avatar
prabhatjn
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 28, 2011 3:57 pm
Location: Indore, India

Re: xbindkeys startup

Postby viking777 on Wed Mar 20, 2013 5:12 am

Sorry, that is a mystery to me, I can't start xbindkeys unless I put it in the startup applications.

Having said that I am not using it on Mint so maybe that is the difference.

BTW. What is the matter with the built in keyboard shortcuts application? I don't run xbindkeys on MInt because it isn't needed. Keyboard>Shortcuts>Custom Shortcuts works for me.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: xbindkeys startup

Postby prabhatjn on Wed Mar 20, 2013 1:22 pm

Hi,
The custom keyboard shortcuts are not working as well (It works for what is defined inside it, but not custom). May be because I am using cinnamon and it is having bugs. Not sure, that is why I have started using xbindkeys.


Prabhat.
User avatar
prabhatjn
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 28, 2011 3:57 pm
Location: Indore, India

Re: xbindkeys startup

Postby prabhatjn on Wed Mar 20, 2013 1:27 pm

I am hoping that for custom keyboard shortcuts the new version of cinnamon will solve it...
https://github.com/linuxmint/Cinnamon/pull/1405

P.
User avatar
prabhatjn
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 28, 2011 3:57 pm
Location: Indore, India

Re: xbindkeys startup

Postby viking777 on Wed Mar 20, 2013 1:51 pm

Well, that is interesting, I use Cinnamon as well and all the custom keyboard shortcuts I have created (11 of them) work perfectly :?

Strange things computers aren't they.

I don't know why this is, or even if it is significant or not, but if you search for 'keyboard' in the main menu there are two entries which look different to each other. When you open them both one is just titled 'Keyboard' the other 'Cinnamon Settings Keyboard'. I put all my shortcuts into the 'Keyboard' one not the 'Cinnamon' one, and they all work.

Have you tried that?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: xbindkeys startup

Postby prabhatjn on Thu Mar 21, 2013 3:33 am

Hi,

Actually there is only one entry that is the cinnamon settings keyboard. I do not get the other one.

P.
User avatar
prabhatjn
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 28, 2011 3:57 pm
Location: Indore, India

Re: xbindkeys startup

Postby viking777 on Thu Mar 21, 2013 6:38 am

Maybe that is your problem then. I don't know why I get two, but I know others do as well, I read it somewhere else on the forum (although I can't find it now). Maybe you could find something in dconf-editor to set the shortcuts. The entries for keybindings are all over the place in there, here are just a few of them:

org/gnome/settings-daemon/plugins/media-keys
org/gnome/mutter/keybindings
org/gnome/desktop/wm/keybindings
org/gnome/shell/keybindings

(You can press ctl/f to search in dconf editor).
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 16 guests