[SOLVED]: Errors on every update

Questions about applications and software
Forum rules
Before you post please read how to get help

[SOLVED]: Errors on every update

Postby RavenLX on Wed Mar 20, 2013 11:21 am

The past 4 or 5 updates (the past month now) I keep getting the following errors below. The only changes I did was upgrade KDE to the latest (using their repository) and upgraded GIMP to the latest (again using their own repository as well). Updates were fine after that and then one day these updates started throwing errors. I can't figure out how to fix this. It's ironic because I run a LAMP server for developing web sites, etc. and usually I'm good at figuring this out but this has me puzzled. Is it something simple I'm missing?

What I've tried so far was the sudo apt-get install -f and that didn't work. Same errors. I tried the sudo apt-get update and sudo-apt-get dist-upgrade and that didn't work. What's blocking this is that it won't configure php5-common (which is installed) for whatever reason. I even tried to force it to configure it and that didn't work either. Again, same problem. I really hate to have to uninstall and reinstall the packages (there are quite a few of them).

Anyone know a fix for this that doesn't involve reinstalling all those packages?

Here's the full errors I'm getting:


E: php5-common: subprocess installed post-installation script returned error exit status 1
E: php5-cli: dependency problems - leaving unconfigured
E: libapache2-mod-php5: dependency problems - leaving unconfigured
E: php5-curl: dependency problems - leaving unconfigured
E: php5-gd: dependency problems - leaving unconfigured
E: php5-intl: dependency problems - leaving unconfigured
E: php5-mysql: dependency problems - leaving unconfigured
E: php5-xmlrpc: dependency problems - leaving unconfigured
E: php5-xsl: dependency problems - leaving unconfigured
E: php-pear: dependency problems - leaving unconfigured
E: php5: dependency problems - leaving unconfigured

(Reading database ... 206264 files and directories currently installed.)
Preparing to replace perl 5.14.2-13ubuntu0.1 (using .../perl_5.14.2-13ubuntu0.2_amd64.deb) ...
Unpacking replacement perl ...
Preparing to replace libperl5.14 5.14.2-13ubuntu0.1 (using .../libperl5.14_5.14.2-13ubuntu0.2_amd64.deb) ...
Unpacking replacement libperl5.14 ...
Preparing to replace perl-base 5.14.2-13ubuntu0.1 (using .../perl-base_5.14.2-13ubuntu0.2_amd64.deb) ...
Unpacking replacement perl-base ...
Processing triggers for man-db ...
Setting up perl-base (5.14.2-13ubuntu0.2) ...
(Reading database ... 206264 files and directories currently installed.)
Preparing to replace perl-modules 5.14.2-13ubuntu0.1 (using .../perl-modules_5.14.2-13ubuntu0.2_all.deb) ...
Unpacking replacement perl-modules ...
Setting up php5-common (5.4.6-1ubuntu1.2) ...
ERROR: pdo module symlink already exists in /etc/php5/conf.d with different content
dpkg: error processing php5-common (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of php5-cli:
php5-cli depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-cli (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapache2-mod-php5:
libapache2-mod-php5 depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing libapache2-mod-php5 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-curl:
php5-curl depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-curl depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing phNo apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
p5-curl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-gd:
php5-gd depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-gd depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-gd (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-intl:
php5-intl depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-intl depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-intl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mysql:
php5-mysql depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-mysql depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-mysql (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-xmlrpc:
php5-xmlrpc depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-xmlrpc depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-xmlrpc (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-xsl:
php5-xsl depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-xsl depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-xsl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php-pear:
php-pear depends on php5-common (>= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.
php-pear depends on php5-cli; however:
Package php5-cli is not configured yet.

dpkg: error processing php-pear (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5:
php5 depends on libapache2-mod-php5 (>= 5.4.6-1ubuntu1.2) | libapache2-mod-php5filter (>= 5.4.6-1ubuntu1.2) | php5-cgi (>= 5.4.6-1ubuntu1.2) | php5-fpm (>= 5.4.6-1ubuntu1.2); however:
Package libapache2-mod-php5 is not configured yet.
Package libapache2-mod-php5filter is not installed.
Package php5-cgi is not installed.
Package php5-fpm is not installed.
php5 depends on php5-common (>= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5 (--configure):
dependency problems - leaving unconfigured
Setting up libperl5.14 (5.14.2-13ubuntu0.2) ...
Setting up perl-modules (5.14.2-13ubuntu0.2) ...
Setting up perl (5.14.2-13ubuntu0.2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
php5-common
php5-cli
libapache2-mod-php5
php5-curl
php5-gd
php5-intl
php5-mysql
php5-xmlrpc
php5-xsl
php-pear
php5
W: Waited for dpkg --assert-multi-arch but it wasn't there - dpkgGo (10: No child processes)
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up php5-common (5.4.6-1ubuntu1.2) ...
ERROR: pdo module symlink already exists in /etc/php5/conf.d with different content
dpkg: error processing php5-common (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of php5-cli:
php5-cli depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-cli (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapache2-mod-php5:
libapache2-mod-php5 depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing libapache2-mod-php5 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-xsl:
php5-xsl depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-xsl depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-xsl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5:
php5 depends on libapache2-mod-php5 (>= 5.4.6-1ubuntu1.2) | libapache2-mod-php5filter (>= 5.4.6-1ubuntu1.2) | php5-cgi (>= 5.4.6-1ubuntu1.2) | php5-fpm (>= 5.4.6-1ubuntu1.2); however:
Package libapache2-mod-php5 is not configured yet.
Package libapache2-mod-php5filter is not installed.
Package php5-cgi is not installed.
Package php5-fpm is not installed.
php5 depends on php5-common (>= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mysql:
php5-mysql depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-mysql depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-mysql (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-intl:
php5-intl depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-intl depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-intl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-gd:
php5-gd depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-gd depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-gd (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-xmlrpc:
php5-xmlrpc depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-xmlrpc depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-xmlrpc (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php-pear:
php-pear depends on php5-common (>= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.
php-pear depends on php5-cli; however:
Package php5-cli is not configured yet.

dpkg: error processing php-pear (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-curl:
php5-curl depends on phpapi-20100525; however:
Package phpapi-20100525 is not installed.
Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
Package php5-cli which provides phpapi-20100525 is not configured yet.
php5-curl depends on php5-common (= 5.4.6-1ubuntu1.2); however:
Package php5-common is not configured yet.

dpkg: error processing php5-curl (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
php5-common
php5-cli
libapache2-mod-php5
php5-xsl
php5
php5-mysql
php5-intl
php5-gd
php5-xmlrpc
php-pear
php5-curl
Last edited by RavenLX on Thu Mar 21, 2013 10:05 am, edited 1 time in total.
RavenLX
Level 2
Level 2
 
Posts: 78
Joined: Tue Jan 15, 2013 4:00 am

Linux Mint is funded by ads and donations.
 

Re: Errors on every update

Postby RavenLX on Thu Mar 21, 2013 10:05 am

I think I may have solved the problem after doing some digging.

1. Copy /var/lib/dpkg/status to maybe /var/lib/dpkg/status-old.bak (just in case).

2. Edit /var/lib/dpkg/status and search for the php5-common entry. Delete all of that entry (including the description text, etc.)

3. sudo mv /etc/php5/conf.d/10-pdo.ini /etc/php5/conf.d/10-pdo.ini-old

4. sudo apt-get install php5-common

This installed it no problems and set it up properly.

I think the whole problem was that the status got stuck on a not-fully-installed mode due to a corrupt or incorrect /etc/php5/conf.d/10-pdo.ini file. Once that was cleared up, php5-common is giving no errors on installing it.

I'll keep my eyes open next time the update manager has to update something. HOW this happened though I have no idea, but at least there's a fix.
RavenLX
Level 2
Level 2
 
Posts: 78
Joined: Tue Jan 15, 2013 4:00 am


Return to Software & Applications

Who is online

Users browsing this forum: gmilo2 and 22 guests