MAME does not detect joystick

Questions about applications and software
Forum rules
Before you post please read this

MAME does not detect joystick

Postby marco75 on Wed May 28, 2008 9:19 am

The joystick is a Sony Dualshock plugged into a USB adapter.

I can get my joystick working using KDE's System Settings automatically, as soon as I plug it in.

I used Adept to install kxmame 2.0-beta + xMAME-SDL 0.106.

I enable joystick in kxmame settings. I have tried normal, SDL (kxmame says:"Joystick type 2 not found"), PS USB joypad checkbox. None of them work.

I point kxmame to the ROM directory on a NTFS partition, run a game, works fine.

But it will not let me map any buttons to joystick input.

This is a puzzle to me, if KDE can detect and use my joystick, shouldn't kxmame interface with the device as well?

Thanks for reading.

P.S.: This PS-to-USB adapter has worked automatically in my Linux guru buddies PC he brought over on a visit -- he was using some debian variant.
Level 1
Level 1
Posts: 1
Joined: Wed May 28, 2008 9:04 am

Linux Mint is funded by ads and donations.

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 35 guests