Mint 14 and wine

Questions about applications and software
Forum rules
Before you post please read how to get help

Mint 14 and wine

Postby xoy on Sat Mar 23, 2013 5:19 am

Code: Select all
sudo dpkg --print-architecture
amd64
sudo dpkg --print-foreign-architectures
i386
sudo apt-get install wine
...
bla bla winetricks and etc
...
wine ./SuperGreatGame.exe


and problem
Code: Select all
....
((wine:14893): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: wrong ELF class: ELFCLASS64

(wine:14893): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstxvid.so': /usr/lib/gstreamer-0.10/libgstxvid.so: wrong ELF class: ELFCLASS64

(wine:14893): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmpeg2enc.so': /usr/lib/gstreamer-0.10/libgstmpeg2enc.so: wrong ELF class: ELFCLASS64

(wine:14893): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstfaac.so': /usr/lib/gstreamer-0.10/libgstfaac.so: wrong ELF class: ELFCLASS64

(wine:14893): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmplex.so': /usr/lib/gstreamer-0.10/libgstmplex.so: wrong ELF class: ELFCLASS64
fixme:gstreamer:GST_Connect Could not make source filter, are gstreamer-plugins-* installed for 32 bits?

arch?

attempt fix yourself
check arch file
Code: Select all
 file /usr/lib/gstreamer-0.10/libgstpython.so
/usr/lib/gstreamer-0.10/libgstpython.so: ELF 64-bit


search package in whish the file
Code: Select all
apt-file search /usr/lib/gstreamer-0.10/libgstpython.so
python-gst0.10: /usr/lib/gstreamer-0.10/libgstpython.so


ok, we need a python i386 arch with established gst.
install!
Code: Select all
sudo apt-get install python-minimal:i386
...
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libmatekbd : Depends: mate-conf (>= 1.1.0) but it is not going to be installed
 python-minimal:i386 : Depends: python2.7-minimal:i386 (>= 2.7.3) but it is not going to be installed
                       Recommends: python:i386 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

what next? help my please...
xoy
Level 1
Level 1
 
Posts: 1
Joined: Sat Mar 23, 2013 4:20 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Alexa [Bot], B-Still and 29 guests