[SOLVED] apt update failure.

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] apt update failure.

Postby cutechaps on Mon Apr 08, 2013 2:58 am

I am running mint 14 nadia, 64 bit version and when I run apt-get update, it gives me following errors and warning. Any idea how to clear it.

Error:
W: Failed to fetch http://glug.nith.ac.in/ubuntu/archives/ ... al/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://repo.mate-desktop.org/ubuntu/dis ... al/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://packages.mate-desktop.org/repo/u ... al/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://packages.linuxmint.com/dists/nadia/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://archive.canonical.com/ubuntu/dis ... al/Release Unable to find expected entry 'partner/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/Release Unable to find expected entry 'free/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://archive.canonical.com/dists/natty/Release Unable to find expected entry 'partner/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch https://download.01.org/gfx/ubuntu/12.1 ... tu/Release Unable to find expected entry '12.10/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/ ... eb/Release Unable to find expected entry 'apps/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.


Source.list File:

deb http://packages.linuxmint.com/ nadia main upstream import backport
deb http://archive.canonical.com/ubuntu/ quantal partner
deb http://packages.medibuntu.org/ quantal free non-free

deb http://archive.getdeb.net/ubuntu quantal-getdeb apps
deb http://archive.canonical.com/ natty partner
deb http://packages.mate-desktop.org/repo/ubuntu quantal main
deb http://repo.mate-desktop.org/ubuntu quantal main
deb http://glug.nith.ac.in/ubuntu/archives/ quantal main universe restricted multiverse

Thanks in Advance...
Last edited by cutechaps on Wed Apr 10, 2013 7:10 am, edited 1 time in total.
cutechaps
Level 1
Level 1
 
Posts: 6
Joined: Thu Dec 13, 2012 4:29 am

Linux Mint is funded by ads and donations.
 

Re: apt update failure.

Postby kc1di on Mon Apr 08, 2013 6:33 am

Hello cutechaps and welcome to mint,

in your Soruces list place a # in front on this line
deb http://archive.getdeb.net/ubuntu quantal-getdeb apps
save the file then run
Code: Select all
sudo apt-get update
again.

you'll have to do this with administrator privileges.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1472
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: apt update failure.

Postby cutechaps on Mon Apr 08, 2013 10:37 am

Hi

Thanks for your update

I followed your steps, still getting the below error.

Failed to fetch http://packages.linuxmint.com/dists/nadia/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Failed to fetch http://glug.nith.ac.in/ubuntu/archives/ ... al/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Failed to fetch http://archive.canonical.com/ubuntu/dis ... al/Release Unable to find expected entry 'partner/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Failed to fetch https://download.01.org/gfx/ubuntu/12.1 ... tu/Release Unable to find expected entry '12.10/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Failed to fetch http://archive.canonical.com/dists/natty/Release Unable to find expected entry 'partner/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Failed to fetch http://packages.medibuntu.org/dists/quantal/Release Unable to find expected entry 'free/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Failed to fetch http://repo.mate-desktop.org/ubuntu/dis ... al/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Failed to fetch http://packages.mate-desktop.org/repo/u ... al/Release Unable to find expected entry 'main/binary-i686/Packages' in Release file (Wrong sources.list entry or malformed file)
Some index files failed to download. They have been ignored, or old ones used instead.

..

Thanks
cutechaps
Level 1
Level 1
 
Posts: 6
Joined: Thu Dec 13, 2012 4:29 am

Re: apt update failure.

Postby cutechaps on Mon Apr 08, 2013 1:52 pm

It is fixed now

I removed the i686 arch, that solved everything....


Thanks
cutechaps
Level 1
Level 1
 
Posts: 6
Joined: Thu Dec 13, 2012 4:29 am

Re: apt update failure.

Postby kc1di on Mon Apr 08, 2013 3:50 pm

Glad you got it going please mark the thread as solved.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1472
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: apt update failure.

Postby cutechaps on Tue Apr 09, 2013 1:55 am

How to mark the thread as resolved...

Thanks
cutechaps
Level 1
Level 1
 
Posts: 6
Joined: Thu Dec 13, 2012 4:29 am

Re: apt update failure.

Postby MtnDewManiac on Tue Apr 09, 2013 2:48 am

cutechaps wrote:How to mark the thread as resolved...

Thanks


Go up to the first post, click on the edit button, and add [SOLVED] to the message's subject.
_____
Proud to be a Mint user. Running 32-bit Mint 14 Xfce (with Xfce 4.10 and 4.12 PPAs). I have the best modern OS and it runs on my really old hardware, lol.
"Change should never be your goal but, instead, only a means to reach your goal."
MtnDewManiac
Level 4
Level 4
 
Posts: 444
Joined: Fri Feb 22, 2013 5:18 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 21 guests