apt-get or application problem?

Questions about applications and software
Forum rules
Before you post please read this

apt-get or application problem?

Postby aj4cp on Sun Jun 15, 2008 12:04 am

Hi everyone.

I am using Linux Mint 4.0 Light.

I just installed SML/NJ using "sudo apt-get install smlnj". When I run the application all seems well until I try to evaluate a particular expression. The messages (see below) are not conclusive. A file seems to be missing; that makes me question the apt-get for this package. However, the sml application doesn't seem very self-confident about what has gone wrong (again, see messages below).

***My question to this forum is this: how do I determine if the problem is with the application specifically, or just with the version installed by apt-get? Is there a general procedure for that?

I suppose I could download and build from the original sources on the SML/NJ website, but dont want to go through that unless necessary...

Any help would be appreciated; if this is not the correct forum, please accept my apologies (and point me to the correct one :-).

Thanks
Jeff

BTW, here is the error message. It may be of interest to anyone using SML.

Error: (stable) $smlnj/smlnj-lib/smlnj-lib.cm: unable to find $SMLNJ-LIB/Util/smlnj-lib.cm (/build/buildd/smlnj-110.62/sml.boot.x86-unix/SMLNJ-LIB/Util/smlnj-lib.cm)

unexpected exception (bug?) in SML/NJ: Format [Format]
raised at: ../cm/stable/stabilize.sml:257.15-257.21
../cm/stable/stabilize.sml:360.44
../cm/compile/compile.sml:579.50
../cm/util/safeio.sml:41.55
../cm/main/autoload.sml:145.53
../compiler/ElabData/basics/env.sml:121.60
../compiler/ElabData/statenv/lookup.sml:93.41
../compiler/Elaborator/print/pputil.sml:149.62
../compiler/Elaborator/print/pputil.sml:149.62
../compiler/TopLevel/interact/evalloop.sml:44.55
-
aj4cp
Level 1
Level 1
 
Posts: 1
Joined: Sat Jun 14, 2008 11:37 pm

Linux Mint is funded by ads and donations.
 

Re: apt-get or application problem?

Postby Husse on Sun Jun 15, 2008 8:09 am

I don't know what kind of application this is but i see
/cm/compile/compile.sml:579.50

When you compile you need build essentials - have you installed them?
viewtopic.php?f=90&t=9234
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Software & Applications

Who is online

Users browsing this forum: Google [Bot] and 14 guests