[solved] cdemu1.0 repos

Questions about applications and software
Forum rules
Before you post please read this

[solved] cdemu1.0 repos

Postby snoer on Tue Jun 17, 2008 11:12 am

Hallo everyone.

EDIT:
i found all needed deb packages for gutsy and hardy built by Henrik Stokseth
they can be found here:
https://launchpad.net/~henrik-kabelkaos/+archive

here is my post on ubuntuusers.de (german):
http://forum.ubuntuusers.de/topic/54834/45/?p=1469834#1469834

for me , cdemu works perfectly with these packages.
-----------------



Has anyone around here succesfully compiled cdemu1 on Mint5 ?
If so could you explain how you managed this?
I'm a bit newb and wasn't able to get it to work.

The sources are available for downloading here:
http://sourceforge.net/project/showfile ... p_id=93175

Wouldn't this application be a cool feature for Linux Mint?
I hope my english is readable.

greetings
snoer
Last edited by snoer on Sat Jun 21, 2008 8:02 am, edited 2 times in total.
snoer
Level 1
Level 1
 
Posts: 2
Joined: Tue Jun 17, 2008 10:27 am

Linux Mint is funded by ads and donations.
 

Re: cdemu1.0

Postby Husse on Tue Jun 17, 2008 5:58 pm

Did you first install build essentials?
viewtopic.php?f=90&t=9234
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: cdemu1.0

Postby snoer on Thu Jun 19, 2008 10:12 am

yes i did.

i was able to build a package via checkinstall for the vhba module after changing
CFLAGS to EXTRA_CFLAGS on line 4 of Makefile
and changing
page to page_link on line 523 of vhba.c

but i don't have a clue what this was good for... i just copied it from another forum
that's why i'm kind of unhappy.

Maybe someone can explain it to me?


Next i tried to compile libmirage but it get the following output:
Code: Select all
checking for glib... configure: error: Package requirements (glib-2.0 >= 2.6) were not met:

No package 'glib-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables glib_CFLAGS
and glib_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


i think the last part of the text could be the solution but i dont know what to do.

There are a lot basics i have to understand before before i can build all the packages myself.
Could one of you who is more experienced build these packages, please?

cdemu seems to be a great tool.

dont get me wrong. it's not that i was too lazy to try building the packages myself, but that i will be succesfull seems
as hopeless as it would be for my grandmother to understand how a cpu works. she doesnt even know how a toaster works.

greetings
snoer
snoer
Level 1
Level 1
 
Posts: 2
Joined: Tue Jun 17, 2008 10:27 am


Return to Software & Applications

Who is online

Users browsing this forum: rbmorse and 23 guests