Error! when attempting to install new kernel!

Questions about applications and software
Forum rules
Before you post please read this

Error! when attempting to install new kernel!

Postby medio-core on Wed Jun 26, 2013 9:13 pm

I installed Mint 15 not too long ago and just like the problem I had with 14, I have absolutely no sound. AT ALL. And my sound output isn't even an HDMI sound output.
I've tried anything people suggested but there just are so few solutions floating around!
So, I heard that updating to a newer kernel would solve the issue, so I tried. BUT every time I try to install the kernel image .deb file, it shows this:
Code: Select all
Selecting previously unselected package linux-image-3.10.0-999-generic.
(Reading database ... 241613 files and directories currently installed.)
Unpacking linux-image-3.10.0-999-generic (from .../linux-image-3.10.0-999-generic_3.10.0-999.201306260405_i386.deb) ...
Done.
Setting up linux-image-3.10.0-999-generic (3.10.0-999.201306260405) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.10.0-999-generic /boot/vmlinuz-3.10.0-999-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.10.0-999-generic /boot/vmlinuz-3.10.0-999-generic
Error!  The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch.  This indicates that it should not be built.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.10.0-999-generic /boot/vmlinuz-3.10.0-999-generic
update-initramfs: Generating /boot/initrd.img-3.10.0-999-generic
Warning: No support for locale: en_US.utf8
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.10.0-999-generic /boot/vmlinuz-3.10.0-999-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.10.0-999-generic /boot/vmlinuz-3.10.0-999-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.10.0-999-generic /boot/vmlinuz-3.10.0-999-generic
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.10.0-999-generic
Found initrd image: /boot/initrd.img-3.10.0-999-generic
Found linux image: /boot/vmlinuz-3.9.0-030900-generic
Found initrd image: /boot/initrd.img-3.9.0-030900-generic
Found linux image: /boot/vmlinuz-3.8.0-25-generic
Found initrd image: /boot/initrd.img-3.8.0-25-generic
Found linux image: /boot/vmlinuz-3.8.0-19-generic
Found initrd image: /boot/initrd.img-3.8.0-19-generic
Found memtest86+ image: /boot/memtest86+.bin
File descriptor 41 (pipe:[24381]) leaked on lvs invocation. Parent PID 1652: /bin/sh
  No volume groups found
done



I just don't know what to do! Please help! I will post all specs you need(but please, give me the terminal code to view them, I'm not too advanced in this all).
Thank you!
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Linux Mint is funded by ads and donations.
 

Re: Error! when attempting to install new kernel!

Postby WharfRat on Wed Jun 26, 2013 11:36 pm

medio-core ,

Can I ask where you got that deb file :?:

Do you have a real peculiar sound card :?:

What does cat /proc/asound/cards and grep -i codec /proc/asound/card*/codec\#* | cut -d: -f3 return :?:
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Wed Jun 26, 2013 11:50 pm

WharfRat wrote:medio-core ,

Can I ask where you got that deb file :?:

Do you have a real peculiar sound card :?:

What does cat /proc/asound/cards and grep -i codec /proc/asound/card*/codec\#* | cut -d: -f3 return :?:


I got it from this index: http://kernel.ubuntu.com/~kernel-ppa/mainline/
Um, I don't think so...I just have whatever this old computer came with haha, it says it has Intel High Definition Audio but that's all the info I could get.
cat /proc/asound/cards gives me
Code: Select all
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x401c0000 irq 44

and grep -i codec /proc/asound/card*/codec\#* | cut -d: -f3 gives me nothing at all...just a blank line!
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Thu Jun 27, 2013 1:00 am

medio-core,

So it doesn't appear to be the card, it looks like the codecs,

Does
Code: Select all
cat /proc/asound/card*/codec\#*
return anything - it should be pretty long-winded in the order of 400+ lines.
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Thu Jun 27, 2013 10:07 am

WharfRat wrote:medio-core,

So it doesn't appear to be the card, it looks like the codecs,

Does
Code: Select all
cat /proc/asound/card*/codec\#*
return anything - it should be pretty long-winded in the order of 400+ lines.

That's good!
It gives me
Code: Select all
Codec: Realtek ALC880
Address: 2
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x10ec0880
Subsystem Id: 0x08600000
Revision Id: 0x90000
No Modem Function Group found
Default PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
State of AFG node 0x01:
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
GPIO: io=2, o=0, i=0, unsolicited=1, wake=0
  IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
  IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
Node 0x02 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
Node 0x03 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
Node 0x04 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
Node 0x05 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital
  Converter: stream=0, channel=0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0x1e]: 16 20 24 32
    formats [0x1]: PCM
Node 0x07 [Vendor Defined Widget] wcaps 0xf0051b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x23, stepsize=0x03, mute=1
  Amp-In vals:
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
  Connection: 0
Node 0x08 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x23, stepsize=0x03, mute=1
  Amp-In vals:  [0x00 0x00]
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0x6]: 16 20
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
  Connection: 7
     0x18 0x19 0x1a* 0x1b 0x1c 0x14 0x15
Node 0x09 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x23, stepsize=0x03, mute=1
  Amp-In vals:  [0x00 0x00]
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0x6]: 16 20
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3
  Power: setting=D0, actual=D0
  Connection: 10
     0x18 0x19 0x1a 0x1b 0x1c* 0x0b 0x14 0x15 0x16 0x17
Node 0x0a [Audio Input] wcaps 0x100391: Stereo Digital
  Converter: stream=0, channel=0
  SDI-Select: 0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0x1e]: 16 20 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x1f
Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Control: name="Beep Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=5, ofs=0
  Control: name="Beep Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=5, ofs=0
  Amp-In caps: ofs=0x23, nsteps=0x41, stepsize=0x03, mute=1
  Amp-In vals:  [0xa3 0xa3] [0xa3 0xa3] [0xa3 0xa3] [0xa3 0xa3] [0xa3 0xa3] [0x80 0x80] [0xa3 0xa3] [0xa3 0xa3]
  Connection: 8
     0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15
Node 0x0c [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x80 0x80]
  Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
  Amp-Out vals:  [0x40 0x40]
  Connection: 2
     0x02 0x0b
Node 0x0d [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x80 0x80]
  Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
  Amp-Out vals:  [0x40 0x40]
  Connection: 2
     0x03 0x0b
Node 0x0e [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x80 0x80]
  Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
  Amp-Out vals:  [0x40 0x40]
  Connection: 2
     0x04 0x0b
Node 0x0f [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x80 0x80]
  Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
  Amp-Out vals:  [0x40 0x40]
  Connection: 2
     0x05 0x0b
Node 0x10 [Audio Selector] wcaps 0x300101: Stereo
  Connection: 4
     0x0c* 0x0d 0x0e 0x0f
Node 0x11 [Audio Selector] wcaps 0x300101: Stereo
  Connection: 4
     0x0c* 0x0d 0x0e 0x0f
Node 0x12 [Audio Selector] wcaps 0x300101: Stereo
  Connection: 4
     0x0c* 0x0d 0x0e 0x0f
Node 0x13 [Audio Selector] wcaps 0x300101: Stereo
  Connection: 4
     0x0c* 0x0d 0x0e 0x0f
Node 0x14 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000003f: IN OUT HP Detect Trigger ImpSense
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x0c
Node 0x15 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000003f: IN OUT HP Detect Trigger ImpSense
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x0d
Node 0x16 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000003f: IN OUT HP Detect Trigger ImpSense
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x0e
Node 0x17 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000003f: IN OUT HP Detect Trigger ImpSense
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 0
Node 0x18 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000133f: IN OUT HP Detect Trigger ImpSense
    Vref caps: HIZ 50 80
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x10
Node 0x19 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000133f: IN OUT HP Detect Trigger ImpSense
    Vref caps: HIZ 50 80
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x11
Node 0x1a [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000133f: IN OUT HP Detect Trigger ImpSense
    Vref caps: HIZ 50 80
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x12
Node 0x1b [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000133f: IN OUT HP Detect Trigger ImpSense
    Vref caps: HIZ 50 80
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x13
Node 0x1c [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x00000020: IN
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x00:
Node 0x1d [Pin Complex] wcaps 0x400000: Mono
  Pincap 0x00000020: IN
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x00:
Node 0x1e [Pin Complex] wcaps 0x400300: Mono Digital
  Control: name="Line Out Phantom Jack", index=0, device=0
  Pincap 0x00000010: OUT
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x00:
  Connection: 1
     0x06
Node 0x1f [Pin Complex] wcaps 0x400200: Mono Digital
  Pincap 0x00000020: IN
  Pin Default 0x00000000: [Jack] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0x0, Sequence = 0x0
  Pin-ctls: 0x00:
Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
  Processing caps: benign=0, ncoeff=10
Node 0x21 [Volume Knob Widget] wcaps 0x600080: Mono
  Volume-Knob: delta=0, steps=64, direct=0, val=0
  Unsolicited: tag=00, enabled=0
  Connection: 0
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Thu Jun 27, 2013 1:50 pm

medio-core,

Do you remember the last time that adapter spit-out any sound :?:

Do you dual boot windows and if so does sound work in windows :?:

Paste back
Code: Select all
lsmod|grep snd
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Thu Jun 27, 2013 8:43 pm

WharfRat wrote:medio-core,

Do you remember the last time that adapter spit-out any sound :?:

Do you dual boot windows and if so does sound work in windows :?:

Paste back
Code: Select all
lsmod|grep snd

The last time my speakers worked with my computer? Um, before I installed Mint 15, when I still had Mint 12 installed. I checked my speakers too today and they're perfectly fine.
I do not dual boot, this computer only runs Linux Mint 15 at the moment. : )
lsmod | grep snd gives me this:
Code: Select all
snd_hda_codec_realtek    41753  1
snd_hda_intel          43104  0
snd_hda_codec         169495  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13276  1 snd_hda_codec
snd_pcm                94629  2 snd_hda_codec,snd_hda_intel
snd_page_alloc         18398  2 snd_pcm,snd_hda_intel
snd_seq_midi           13132  0
snd_seq_midi_event     14475  1 snd_seq_midi
snd_rawmidi            25157  1 snd_seq_midi
snd_seq                55716  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              28930  2 snd_pcm,snd_seq
snd                    61262  10 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
soundcore              12600  1 snd
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Thu Jun 27, 2013 9:33 pm

medio-core,

There's nothing strange with the lsmod output. Have you taken the alsamixer route yet making sure pcm and any other selector isn't muted or at 0 :?:
medio-core wrote:I checked my speakers too today and they're perfectly fine

How did you do that :?:
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Thu Jun 27, 2013 10:11 pm

WharfRat wrote:medio-core,

There's nothing strange with the lsmod output. Have you taken the alsamixer route yet making sure pcm and any other selector isn't muted or at 0 :?:
medio-core wrote:I checked my speakers too today and they're perfectly fine

How did you do that :?:

This is what I get when I open alsa mixer(click to view larger):
Image
Is the beep option supposed to be on? I will turn it all the way up, reboot, and see what happens...

And I'm using a desktop so my speakers are just sort of there ha, and I hooked them up to my iPod, perfect sound, no problem.
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Thu Jun 27, 2013 10:16 pm

So, raising the Beep option didn't do anything. Still nothing. And I also want to just tell you that the only option I have for sound output is called "Dummy Output".
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Thu Jun 27, 2013 10:24 pm

medio-core,

I'm going to assume you tried F6 :!:

What does aplay -l return
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Fri Jun 28, 2013 6:22 pm

WharfRat wrote:medio-core,

I'm going to assume you tried F6 :!:

What does aplay -l return

Yes, I have and it shows this:
Image
The USB device has no volume options, by the way.

aplay -l gives me this
Code: Select all
**** List of PLAYBACK Hardware Devices ****

and then nothing after that, no lines, nada!
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Fri Jun 28, 2013 8:33 pm

medio-cor,

I'm hoping this isn't going to require the big guns :D

What do these give you :?:
Code: Select all
ldd $(which aplay)|awk '{print $3}'|while read f;do  [[ ! -z $f ]] && ls -lh $(readlink -f "${f}");done

Code: Select all
[[ -e /dev/snd ]] && ls -alR /dev/snd
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Fri Jun 28, 2013 9:01 pm

WharfRat wrote:medio-cor,

I'm hoping this isn't going to require the big guns :D

What do these give you :?:
Code: Select all
ldd $(which aplay)|awk '{print $3}'|while read f;do  [[ ! -z $f ]] && ls -lh $(readlink -f "${f}");done

Code: Select all
[[ -e /dev/snd ]] && ls -alR /dev/snd

I hope not either! Haha!

The first gives me:
Code: Select all
ls: cannot access /home/candace/(0xb76ee000): No such file or directory
-rw-r--r-- 1 root root 30K Apr 18 05:14 /lib/i386-linux-gnu/librt-2.17.so
-rw-r--r-- 1 root root 963K May  7 06:34 /usr/lib/i386-linux-gnu/libasound.so.2.0.0
-rwxr-xr-x 1 root root 122K Apr 18 05:14 /lib/i386-linux-gnu/libpthread-2.17.so
-rwxr-xr-x 1 root root 1.7M Apr 18 05:14 /lib/i386-linux-gnu/libc-2.17.so
-rw-r--r-- 1 root root 262K Apr 18 05:14 /lib/i386-linux-gnu/libm-2.17.so
-rw-r--r-- 1 root root 14K Apr 18 05:14 /lib/i386-linux-gnu/libdl-2.17.so

"candace" is my username, by the way

and the second gives me:
Code: Select all
/dev/snd:
total 0
drwxr-xr-x   4 root root      200 Jun 28 15:50 .
drwxr-xr-x  17 root root     4460 Jun 28 17:57 ..
drwxr-xr-x   2 root root       60 Jun 28 15:50 by-id
drwxr-xr-x   2 root root       80 Jun 28 15:50 by-path
crw-rw---T+  1 root audio 116,  3 Jun 28 15:50 controlC0
crw-rw---T+  1 root audio 116,  5 Jun 28 15:50 controlC1
crw-rw---T+  1 root audio 116,  2 Jun 28 15:50 hwC0D2
crw-rw---T+  1 root audio 116,  4 Jun 28 15:51 pcmC1D0c
crw-rw---T+  1 root audio 116,  1 Jun 28 15:50 seq
crw-rw---T+  1 root audio 116, 33 Jun 28 15:50 timer

/dev/snd/by-id:
total 0
drwxr-xr-x 2 root root  60 Jun 28 15:50 .
drwxr-xr-x 4 root root 200 Jun 28 15:50 ..
lrwxrwxrwx 1 root root  12 Jun 28 15:50 usb-046d_081b_11CAC1B0-02 -> ../controlC1

/dev/snd/by-path:
total 0
drwxr-xr-x 2 root root  80 Jun 28 15:50 .
drwxr-xr-x 4 root root 200 Jun 28 15:50 ..
lrwxrwxrwx 1 root root  12 Jun 28 15:50 pci-0000:00:1b.0 -> ../controlC0
lrwxrwxrwx 1 root root  12 Jun 28 15:50 pci-0000:00:1d.7-usb-0:3:1.2 -> ../controlC1

Those "total:0"s scare me a bit!
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Fri Jun 28, 2013 9:25 pm

What is this usb device - is it an optional device or built-in :?:
Code: Select all
lrwxrwxrwx 1 root root  12 Jun 28 15:50 pci-0000:00:1d.7-usb-0:3:1.2 -> ../controlC1


Put yourself in the audio group then logoff and back in again and check for any change
Code: Select all
usermod -a -G audio yourname

Change yourname to your account name.
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Sat Jun 29, 2013 2:20 am

WharfRat wrote:What is this usb device - is it an optional device or built-in :?:
Code: Select all
lrwxrwxrwx 1 root root  12 Jun 28 15:50 pci-0000:00:1d.7-usb-0:3:1.2 -> ../controlC1


Put yourself in the audio group then logoff and back in again and check for any change
Code: Select all
usermod -a -G audio yourname

Change yourname to your account name.

When I run that first command it says that the permission is denied:
Code: Select all
bash: ../controlC1: Permission denied

and so I tried in "superuser" mode and got that the "lrwxrwxrwx" command was not found...
Nope, no change at all with that second method. : (
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Sat Jun 29, 2013 8:52 am

medio-core,

Sorry - I placed the output in code, but you weren't supposed to run that. I just wanted to know what that usb device was :wink:

You can run these:
Code: Select all
sudo lsusb

and
Code: Select all
sudo lspci

and
Code: Select all
id candace

and
Code: Select all
arch
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Sat Jun 29, 2013 3:18 pm

WharfRat wrote:medio-core,

Sorry - I placed the output in code, but you weren't supposed to run that. I just wanted to know what that usb device was :wink:

You can run these:
Code: Select all
sudo lsusb

and
Code: Select all
sudo lspci

and
Code: Select all
id candace

and
Code: Select all
arch

Ha! I thought something was off!
sudo lsusb:
Code: Select all
Bus 001 Device 003: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
Bus 001 Device 004: ID 046d:081b Logitech, Inc. Webcam C310
Bus 002 Device 002: ID 05b8:3155 Agiler, Inc.
Bus 003 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

sudo lspci:
Code: Select all
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
05:05.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 61)
05:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller (rev 03)

id candace:
Code: Select all
uid=1000(candace) gid=1000(candace) groups=1000(candace),4(adm),24(cdrom),27(sudo),29(audio),30(dip),46(plugdev),108(lpadmin),125(sambashare)

and
arch:
Code: Select all
i686

: )
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Re: Error! when attempting to install new kernel!

Postby WharfRat on Sat Jun 29, 2013 4:15 pm

medio-core,

In examining this output I've pinned-down what I 'suspect' could be the problem. The pci device id 00:1d.7 which is a usb2 controller is somehow getting assigned as an audio device.

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)

This was the output from ls -alR /dev/snd. Notice 00:1d.7 :shock:
lrwxrwxrwx 1 root root 12 Jun 28 15:50 pci-0000:00:1b.0 -> ../controlC0
lrwxrwxrwx 1 root root 12 Jun 28 15:50 pci-0000:00:1d.7-usb-0:3:1.2 -> ../controlC1

To look a little further first escalate your privileges with sudo -i in the terminal:Then
Code: Select all
awk '/00:1d.7/,/Kernel/' <(lspci -k)

and
Code: Select all
awk '/00:1b.0/,/Kernel/' <(lspci -k)

and
Code: Select all
awk '/00:1d.3/,/Kernel/' <(lspci -k)


Also one more thing. Do
Code: Select all
lspci -n

Copy the numbers and enter them here http://kmuto.jp/debian/hcl/ then click check ,copy and paste back the results.
Image
User avatar
WharfRat
Level 12
Level 12
 
Posts: 4276
Joined: Thu Apr 07, 2011 8:15 pm

Re: Error! when attempting to install new kernel!

Postby medio-core on Sat Jun 29, 2013 4:53 pm

WharfRat wrote:medio-core,

In examining this output I've pinned-down what I 'suspect' could be the problem. The pci device id 00:1d.7 which is a usb2 controller is somehow getting assigned as an audio device.

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)

This was the output from ls -alR /dev/snd. Notice 00:1d.7 :shock:
lrwxrwxrwx 1 root root 12 Jun 28 15:50 pci-0000:00:1b.0 -> ../controlC0
lrwxrwxrwx 1 root root 12 Jun 28 15:50 pci-0000:00:1d.7-usb-0:3:1.2 -> ../controlC1

To look a little further first escalate your privileges with sudo -i in the terminal:Then
Code: Select all
awk '/00:1d.7/,/Kernel/' <(lspci -k)

and
Code: Select all
awk '/00:1b.0/,/Kernel/' <(lspci -k)

and
Code: Select all
awk '/00:1d.3/,/Kernel/' <(lspci -k)


Also one more thing. Do
Code: Select all
lspci -n

Copy the numbers and enter them here http://kmuto.jp/debian/hcl/ then click check ,copy and paste back the results.

Hmm...I see! That's weird...
awk '/00:1d.7/,/Kernel/' <(lspci -k):
Code: Select all
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
   Subsystem: Gateway, Inc. Device 4037
   Kernel driver in use: ehci-pci

awk '/00:1b.0/,/Kernel/' <(lspci -k):
Code: Select all
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
   Subsystem: Gateway, Inc. Device 4037
   Kernel driver in use: snd_hda_intel

awk '/00:1b.3/,/Kernel/' <(lspci -k):
Code: Select all
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
   Subsystem: Gateway, Inc. Device 4037
   Kernel driver in use: uhci_hcd

Here you go!
Code: Select all
PCI ID   Works?   Vendor   Device   Driver   Kernel
80862580   Yes   Intel Corporation   82915G/P/GV/GL/PL/910GL Memory Controller Hub   agpgart,intel-agp   
80862582   Yes   Intel Corporation   82915G/GV/910GL Integrated Graphics Controller   i915   v2.6.32-
80862668   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller   snd-hda-intel   v3.1.0-
80862660        Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1      
80862662        Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2      
80862664        Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3      
80862666        Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4      
80862658   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1   usb-uhci,uhci-hcd   
80862659   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2   usb-uhci,uhci-hcd   
8086265a   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3   usb-uhci,uhci-hcd   
8086265b   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4   usb-uhci,uhci-hcd   
8086265c   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller   ehci-hcd   
8086244e   Yes   Intel Corporation   82801 PCI Bridge   i810_rng   
80862640   Yes   Intel Corporation   82801FB/FR (ICH6/ICH6R) LPC Interface Bridge   intel-rng,iTCO_wdt   v2.6.25-
8086266f   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller   ata_piix   v2.6.25-
80862651   Yes   Intel Corporation   82801FB/FW (ICH6/ICH6W) SATA Controller   ata_piix   v2.6.25-
8086266a   Yes   Intel Corporation   82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller   i2c-i801   v2.6.25-
11c15811   Yes   LSI Corporation   FW322/323 [TrueFire] 1394a Controller   ohci1394   
80861064   Yes   Intel Corporation   82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller   e100   v2.6.25-

: )
medio-core
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 26, 2013 8:07 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: fo0hzy, Shankaraya and 28 guests