Nightingale Installation

Questions about applications and software
Forum rules
Before you post please read this

Nightingale Installation

Postby bobstead on Thu Jul 04, 2013 2:01 pm

I'm new to Mint, and have just installed Nightingale, but it won't run (although no error messages). Tried Songbird, it loaded but failed duer to missing acc codecs. Tried loading a bunch of codecs but still get same error messages. Any advice re getting Nightingale to launch?
bobstead
Level 1
Level 1
 
Posts: 5
Joined: Thu Jul 04, 2013 1:53 pm

Linux Mint is funded by ads and donations.
 

Re: Nightingale Installation

Postby xenopeek on Thu Jul 04, 2013 2:28 pm

From where have you installed it?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Nightingale Installation

Postby bobstead on Fri Jul 05, 2013 1:56 am

xenopeek wrote:From where have you installed it?


Hi. I got ppa:nightingaleteam/nightingale-release from getnightinmgale.com & added this to software manager & packsage now appears in software manager & in synaptic. Ran installer, which has added all of the repository sources etc but I've obviously failed to understand & do some core part odf this process correctly.
bobstead
Level 1
Level 1
 
Posts: 5
Joined: Thu Jul 04, 2013 1:53 pm

Re: Nightingale Installation

Postby xenopeek on Fri Jul 05, 2013 3:05 am

When you write it didn't give any error messages, did you run it from the terminal? If not, you should. Error messages about it not being able to start will only show on the terminal.

Perhaps there is a clue there, though looking at the topic http://forum.getnightingale.com/thread-661.html it doesn't look promising. Basically the Nightingale developers say they don't support Ubuntu based distros. You may try using the nightly PPA, for a somewhat newer version that perhaps fixes something: https://launchpad.net/~nightingaleteam/ ... le-nightly. I'd recommend you first try running it from the terminal though, and see if you get any errors that way.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Nightingale Installation

Postby bobstead on Fri Jul 05, 2013 11:31 am

Thanks I'll try that & se where I get.
bobstead
Level 1
Level 1
 
Posts: 5
Joined: Thu Jul 04, 2013 1:53 pm

Re: Nightingale Installation

Postby bobstead on Fri Jul 05, 2013 1:03 pm

Nightingale errors.png
bobstead wrote:Thanks I'll try that & se where I get.


Well, being a newbie, I'm not sure if I did this right or not, but I certaily don't understand the output!!

bob@bob-Aspire-One-753 /usr/share $ nightingale

(process:19314): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
ERROR! Could not call boundObserver.observe(). Key = metadata.title
[Exception... "'[JavaScript Error: "mlyrics.pane.gMM.playbackControl is null" {file: "chrome://mlyrics/content/jscripts/paneWindow.js" line: 676}]' when calling method: [sbIRemoteObserver::observe]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: file:///usr/share/nightingale/components/sbDataRemote.js :: anonymous :: line 369" data: yes]
** Message: Unity Integration: loading

(nightingale-bin:19314): GLib-GIO-ERROR **: Settings schema 'com.canonical.indicator.sound' is not installed

Trace/breakpoint trap (core dumped)
bob@bob-Aspire-One-753 /usr/share $
bobstead
Level 1
Level 1
 
Posts: 5
Joined: Thu Jul 04, 2013 1:53 pm

Re: Nightingale Installation

Postby xenopeek on Fri Jul 05, 2013 1:58 pm

Then time to try the other PPA I think. See here the same error: https://github.com/nightingale-media-pl ... issues/184. Seems to indicate the fix is in nightingale-nightly PPA. I hope that fixes it, though I'm not happy with you getting an error for Unity while you aren't using that. So I hope the other PPA works without you needing to use Unity.

Add the other PPA like you did the first. Then open Update Manager, and if needed press the Refresh button, and an upgrade for Nightingale should be available from the new PPA.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Nightingale Installation

Postby bobstead on Sat Jul 06, 2013 2:41 am

xenopeek wrote:Then time to try the other PPA I think. See here the same error: https://github.com/nightingale-media-pl ... issues/184. Seems to indicate the fix is in nightingale-nightly PPA. I hope that fixes it, though I'm not happy with you getting an error for Unity while you aren't using that. So I hope the other PPA works without you needing to use Unity.

Add the other PPA like you did the first. Then open Update Manager, and if needed press the Refresh button, and an upgrade for Nightingale should be available from the new PPA.


Thanks a lot. Using the nightly build worked wonders, it prompted an upgrade & al's now working fine. Thanks.
bobstead
Level 1
Level 1
 
Posts: 5
Joined: Thu Jul 04, 2013 1:53 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: canyon, zolar1 and 21 guests