mintUpdate conflict?

Questions about applications and software
Forum rules
Before you post please read this

mintUpdate conflict?

Postby akshunj on Thu Jul 03, 2008 12:22 am

mintUpdate has marked the package X11-common as a Level 3 update and wants to upgrade it. However, the xorg and xserver-xorg packages are marked as Level 4, and won't be updated. They are both the same version number, and want to be upgraded to the same version number. Will upgrading X11-common break Xorg, or will mintUpdate grab all the dependencies it needs and overrule the Level 4 status?

--Akshun J
User avatar
akshunj
Level 3
Level 3
 
Posts: 151
Joined: Wed Feb 21, 2007 11:24 am
Location: Atlanta, GA

Linux Mint is funded by ads and donations.
 

Re: mintUpdate conflict?

Postby Husse on Thu Jul 03, 2008 7:33 am

X11 common is some kind of helper package - won't break anything or at least should not break anything
When you come to the box where you finally click Apply you can check for Not verified, Updated, Installed and Not changed
In the last category you find X and the kernel....
Always read the short description for each package and then check the Not verified and so on
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: mintUpdate conflict?

Postby akshunj on Fri Jul 04, 2008 12:16 am

Husse wrote:X11 common is some kind of helper package - won't break anything or at least should not break anything
When you come to the box where you finally click Apply you can check for Not verified, Updated, Installed and Not changed
In the last category you find X and the kernel....
Always read the short description for each package and then check the Not verified and so on


Thanks for the reply. I understand all of that. I just wanted to know the basic logic that mintUpdate follows if a Level 3 update is dependent on a Level 4 update that wouldn't ordinarily be marked for upgrade. I figured I could just check what's going on in that final dialog box you're talking about, but I still didn't want to risk breaking Xorg if it failed to update a critical dependency...

--Akshun J
User avatar
akshunj
Level 3
Level 3
 
Posts: 151
Joined: Wed Feb 21, 2007 11:24 am
Location: Atlanta, GA

Re: mintUpdate conflict?

Postby Husse on Fri Jul 04, 2008 7:30 am

Actually X11 common does not depend on a level 4 update - it "stands on its own"
I applied it and no problems
I apply all level 1,2 and 3 updates as soon as I get them. In case there is something odd I know that early on and I have complete backups of my system - no longer everyday but every other day or so
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: mintUpdate conflict?

Postby akshunj on Fri Jul 04, 2008 5:35 pm

Sweet. That's what I needed to know. Thanks!

--Akshun J
User avatar
akshunj
Level 3
Level 3
 
Posts: 151
Joined: Wed Feb 21, 2007 11:24 am
Location: Atlanta, GA


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 24 guests