Sage Placeshifter audio problem

Questions about applications and software
Forum rules
Before you post please read this

Sage Placeshifter audio problem

Postby det4100 on Wed Jul 09, 2008 6:17 am

I was wondering if anyone was using SageTV Placeshifter and encountered audio problems. When I log into the server, Placeshifter plays well but when I shut it down, I loose all sound and have to reboot to get sound again. I'm running Daryna on an intel core duo 2.0 ALSA sound device. I get warnings that the sound device failed to load when I try to play other media programs after using Placeshifter.

det4100
det4100

Running Mint Debian
User avatar
det4100
Level 4
Level 4
 
Posts: 225
Joined: Mon Dec 10, 2007 9:51 am
Location: New York

Linux Mint is funded by ads and donations.
 

Re: Sage Placeshifter audio problem

Postby Husse on Sun Jul 13, 2008 6:29 am

You deserve an answer, been waiting too long
I have none, but I found out that there is a forum for this product
http://forums.sagetv.com/forums/index.php
This is also something that's hard to google as it's hard to make a good search phrase
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sage Placeshifter audio problem

Postby det4100 on Sun Jul 13, 2008 6:48 am

Thanks Husse,

I found the forum, but unlike Mint's forum, very few questions get answers. It took a lot of searching to find folks with the same problem, No answer as of yet. I'm still researching it. I don't think it's a Distro bug, I think it may be a program flaw (or the JVM) or a problem with my own setup.

det4100
det4100

Running Mint Debian
User avatar
det4100
Level 4
Level 4
 
Posts: 225
Joined: Mon Dec 10, 2007 9:51 am
Location: New York

Re: Sage Placeshifter audio problem

Postby Husse on Sun Jul 13, 2008 7:28 am

It's most likely Placeshifter that takes possession of sound somehow to much and when it's down the resources are not released
Try to find a way inside the program to disconnect/disable sound before you close down
No idea if there is an option that can do that though
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sage Placeshifter audio problem

Postby det4100 on Sun Jul 13, 2008 6:26 pm

I think you are right about that. It appears that the program does not release the sound device. As a matter of fact there is no way to shut down the program other than closing the window. The program calls up mplayer to view the video but it does not release it when shut down, it appears that it doesn't do any house cleaning when shutting down. It tends to make me think that the program was not well thought out and holds on to resources when shut down. Not a big deal, I'll look into it some more and if I can't use it, I'll fire up one of the other computers to use it. It worked on one of the MS boxes.

det4100
det4100

Running Mint Debian
User avatar
det4100
Level 4
Level 4
 
Posts: 225
Joined: Mon Dec 10, 2007 9:51 am
Location: New York


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 15 guests