Solved: Firefox 3, broken dependencies

Questions about applications and software
Forum rules
Before you post please read how to get help

Solved: Firefox 3, broken dependencies

Postby Lim-Dul on Mon Jul 14, 2008 1:54 pm

OK, I'm writing this message from my beloved Lynx because I seem to have broken Firefox somehow...
I had some level 1, 2 and 3 updates in MintUpdate (I have virtually all the repos enabled) but I was told that I have to "fix broken packages first"...

sudo apt-get check didn't list anything broken so I just uninstalled everything and force-installed some fancy-pants version of XULrunner (1.9.0.1+build1+nobinonly-0ubuntu0.8.04.1). Now, however I can't install Firefox again... It tells me that Firefox depends on Firefox-3.0 (obviously) and Firefox-3.0 depends on XULrunner >= 1.9, which, like I wrote above, I installed. 0_o
I checked yet again for broken dpendencies with sudo apt-get check and there aren't any... Hmmm...
Last edited by Lim-Dul on Tue Jul 15, 2008 6:19 pm, edited 1 time in total.
War does not determine who is right - only who is left. - Bertrand Russell
User avatar
Lim-Dul
Level 2
Level 2
 
Posts: 71
Joined: Thu Jun 05, 2008 4:59 pm
Location: Europe->Poland->Warsaw

Linux Mint is funded by ads and donations.
 

Re: Firefox 3, broken dependencies (most likely Ubuntu repos)

Postby msuggs on Mon Jul 14, 2008 6:40 pm

Lim-Dul wrote:OK, I'm writing this message from my beloved Lynx because I seem to have broken Firefox somehow...
I had some level 1, 2 and 3 updates in MintUpdate (I have virtually all the repos enabled) but I was told that I have to "fix broken packages first"...

sudo apt-get check didn't list anything broken so I just uninstalled everything and force-installed some fancy-pants version of XULrunner (1.9.0.1+build1+nobinonly-0ubuntu0.8.04.1). Now, however I can't install Firefox again... It tells me that Firefox depends on Firefox-3.0 (obviously) and Firefox-3.0 depends on XULrunner >= 1.9, which, like I wrote above, I installed. 0_o
I checked yet again for broken dpendencies with sudo apt-get check and there aren't any... Hmmm...


Which repos do you have enabled? When you say 'virtually' all does this include some unstable ones?

Unstable repos and force install = problems
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: Firefox 3, broken dependencies (most likely Ubuntu repos)

Postby 67GTA on Mon Jul 14, 2008 8:04 pm

The two packages are xulrunner-1.9 and xulrunner-1.9-gnome-support. They are in the hardy-proposed repo. They are conflicting with Mint's version of Firefox 3. You really have to be careful with all of the repos enabled like that. Try uninstalling those two packages, disabling the hardy repos they are coming from, reloading the repos, and reinstalling FF.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: Firefox 3, broken dependencies (most likely Ubuntu repos)

Postby Lim-Dul on Mon Jul 14, 2008 8:42 pm

Thanks - I got it now. Indeed this was some conflict from the backport or proposed Ubuntu repo... Why haven't I thought of disabling them myself. *doh*
War does not determine who is right - only who is left. - Bertrand Russell
User avatar
Lim-Dul
Level 2
Level 2
 
Posts: 71
Joined: Thu Jun 05, 2008 4:59 pm
Location: Europe->Poland->Warsaw


Return to Software & Applications

Who is online

Users browsing this forum: Bing [Bot], NeoGeo64 and 20 guests