Mint 16 Suspends On Laptop Lid Close Despite Settings

Questions about applications and software
Forum rules
Before you post please read this

Mint 16 Suspends On Laptop Lid Close Despite Settings

Postby Calcipher on Wed Nov 27, 2013 12:56 pm

Hello all. I'm running Mint 16x64 and, no matter what I do, I can't seem to keep my machine from suspending when I close the lid. I've change the settings in system-settings and in gnome-tweak-tool. I've also changed the setting in dconf. The biggest problem is that it will suspend while the system is shutting down (I often close the lid while the system shuts down).

Anyone have any ideas?
Calcipher
Level 1
Level 1
 
Posts: 8
Joined: Tue Feb 28, 2012 10:17 pm

Linux Mint is funded by ads and donations.
 

Re: Mint 16 Suspends On Laptop Lid Close Despite Settings

Postby roblm on Wed Nov 27, 2013 5:31 pm

You can try this method.

To prevent suspending when running on battery power, type this command in the Terminal:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action blank

To prevent suspending when running on AC power, type this command:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action blank

To reverse the settings type these commands:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action 'suspend'
gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action 'suspend'

From what I've read, some laptops can overheat if they are left running using these settings with the lid closed.
User avatar
roblm
Level 4
Level 4
 
Posts: 434
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 16 Suspends On Laptop Lid Close Despite Settings

Postby Calcipher on Wed Nov 27, 2013 6:27 pm

Thanks for those commands, but it would seem that whatever is causing me to always suspend did not honor them.
Calcipher
Level 1
Level 1
 
Posts: 8
Joined: Tue Feb 28, 2012 10:17 pm

Re: Mint 16 Suspends On Laptop Lid Close Despite Settings

Postby roblm on Wed Nov 27, 2013 8:47 pm

Try adding apostrophes around the word blank:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action 'blank'
gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action 'blank'

If that fails then run this command:
gsettings set org.gnome.settings-daemon.plugins.power active 'true'
and then run the other two commands again.

If that fails then run these commands:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action 'nothing'
gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action 'nothing'

If that fails then there may be some bugs in Mint 16 RC, so wait until the Mint 16 final release.
User avatar
roblm
Level 4
Level 4
 
Posts: 434
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 16 Suspends On Laptop Lid Close Despite Settings

Postby roblm on Thu Nov 28, 2013 11:07 am

Here's one more procedure you can try, which is directly editing a configuration file. Type this command in the Terminal to open the file:
gksudo gedit /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.power.gschema.xml

In the Menu go to Search > Find, and in the window type: key name="lid-close-battery-action"
In the opened file just below this line change the word 'suspend' to 'blank'.

Just below this will be the section: key name="lid-close-ac-action"
Repeat the word change and save the file.
User avatar
roblm
Level 4
Level 4
 
Posts: 434
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 16 Suspends On Laptop Lid Close Despite Settings

Postby bdelima on Mon Jan 06, 2014 2:32 pm

I am hitting the same problem. Just updated to Mint 16 and no matter what I do, I can't get the laptop to not suspend on lid close. I've tried everything outlined in this thread.
bdelima
Level 1
Level 1
 
Posts: 1
Joined: Mon Jan 06, 2014 2:30 pm

Re: Mint 16 Suspends On Laptop Lid Close Despite Settings

Postby sswam on Wed Jan 08, 2014 11:42 am

I found the solution on askubuntu here:

http://askubuntu.com/questions/360615/u ... laptop-lid

in short, edit /etc/systemd/logind.conf and add the line:
Code: Select all
HandleLidSwitch=ignore

Then execute the following, or simply reboot:
Code: Select all
sudo restart systemd-logind
sswam
Level 1
Level 1
 
Posts: 4
Joined: Wed Jun 06, 2012 2:44 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 18 guests