Skype audio - impossible

Questions about applications and software
Forum rules
Before you post please read this

Skype audio - impossible

Postby OnlyMe on Tue Jul 29, 2008 1:15 pm

I am not able to pass the Sound test in Skype. It tells me problems with audio playback.

When I check Synaptic, I have the first two Skype packages installed. There is a total of four Skype packages in Synaptic. I am wondering if one of the other two added to my Skype install would help with the audio problem.

I am using a Dell Inspiron 1525 Celeron (shipped with XP) and Mint 5.

Here are the descriptions of the other two packages:

A VoIP software - static variant - Medibuntu package
Skype is a proprietary peer-to-peer Internet telephony (VoIP) software.
The Skype communications system is notable for its broad range of features,
including free voice and video conferencing, and its ability to use peer to
peer (decentralized) technology to overcome common firewall and NAT problems.

This package is in Medibuntu because it is not freely redistribuable.

This package isn't supported by Ubuntu: DON'T REPORT BUGS TO UBUNTU!

Please report any bug to our bug tracker instead:
https://bugs.launchpad.net/medibuntu/+bugs

This package contains the "static" Skype variant, which ships its own Qt4
libraries instead of using the ones available on the user's system.

A VoIP software - static-oss variant - Medibuntu package
Skype is a proprietary peer-to-peer Internet telephony (VoIP) software.
The Skype communications system is notable for its broad range of features,
including free voice and video conferencing, and its ability to use peer to
peer (decentralized) technology to overcome common firewall and NAT problems.

This package is in Medibuntu because it is not freely redistribuable.

This package isn't supported by Ubuntu: DON'T REPORT BUGS TO UBUNTU!

Please report any bug to our bug tracker instead:
https://bugs.launchpad.net/medibuntu/+bugs

This package contains the "static-oss" Skype variant, which ships its own Qt4
libraries instead of using the ones available on the user's system, and uses
the Open Sound System (OSS) instead of the Advanced Linux Sound Architecture
(ALSA).
Last edited by OnlyMe on Thu Aug 14, 2008 7:08 pm, edited 2 times in total.
OnlyMe
Level 2
Level 2
 
Posts: 56
Joined: Sun Mar 16, 2008 4:00 pm
Location: Florida - USA

Linux Mint is funded by ads and donations.
 

Re: Skype audio

Postby merlwiz79 on Tue Jul 29, 2008 1:33 pm

The static-oss should fix your sound problems.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Skype audio

Postby OnlyMe on Tue Jul 29, 2008 8:20 pm

So just add it from synaptic to the two I already have?

Wish I wasn't such a chicken, LOL!
OnlyMe
Level 2
Level 2
 
Posts: 56
Joined: Sun Mar 16, 2008 4:00 pm
Location: Florida - USA

Re: Skype audio

Postby OnlyMe on Tue Jul 29, 2008 10:34 pm

Thank you for your suggestion merlwiz.
I installed the static oss and it removed the first instance of skype.
I can hear my voice on Skype Echo Test but it is of very poor quality with noise in the background.
I have tried probably every conceivable combinations of settings and the above is as good as it gets.
I have all my settings in sound on Alsa. Also tried OSS and Auto detect before that.
I have Recording set for Capture, Digital, Mux 1.
I have headphones as line out and IEC958 1 selected.
When I test sound all but Sound Capture works.
I have tried two sets of earplug & mic.
Skype is a must have app for me.

Please! Are there any other suggestions?

Edit: I am going out of town Friday and would like to bring my laptop with me and show off my nice Minty Linux distro. It will be embarrassing if my Skype isn't working.
OnlyMe
Level 2
Level 2
 
Posts: 56
Joined: Sun Mar 16, 2008 4:00 pm
Location: Florida - USA

Re: Skype audio

Postby OnlyMe on Wed Jul 30, 2008 3:34 pm

No other suggestions to get the audio clear on Skype? It is not usable as it is now.
OnlyMe
Level 2
Level 2
 
Posts: 56
Joined: Sun Mar 16, 2008 4:00 pm
Location: Florida - USA

Re: Skype audio

Postby merlwiz79 on Wed Jul 30, 2008 4:05 pm

Remove skype-static-oss.
Install skype-common skype or just skype-static.
Then try these instructions and make sure to backup and files edited http://www.howtoforge.com/how-to-fix-th ... on-fedora9
In users and groups click your username ans then click manage groups.
Select one of the 3 they show and click properties to add yourself to it.

I don't use skype so I don't know if it works.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Skype audio

Postby OnlyMe on Thu Jul 31, 2008 12:04 pm

vi /etc/pulse/daemon.conf

I can't write to the file. I can see it but cannot write to it.
OnlyMe
Level 2
Level 2
 
Posts: 56
Joined: Sun Mar 16, 2008 4:00 pm
Location: Florida - USA

Re: Skype audio

Postby merlwiz79 on Thu Jul 31, 2008 12:07 pm

Code: Select all
gksu gedit /etc/pulse/daemon.conf
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Skype audio

Postby OnlyMe on Fri Aug 08, 2008 1:20 am

I was able to edit the file doing as you suggested.

The final combination that worked for me was:

From the Mint Menu> Applications> Preferences> Sound> Devices:
I chose Pulse for all the sound playback items.
For sound capture, I chose ALSA.
For Device, I chose HDA Intel (Alsa Mixer).
In the scroll box, I chose Master.

From Package Manager, I chose the regular Skype package as suggested in the link. The Skype-common package is needed no matter which one of the three Skype files is selected and is selected automatically.

In Skype> Options> Sound Devices, for Sound In I chose HDA Intel (hw:Intel,0). For Sound Out and Ringing I left them at default. I removed the check from the box so that Skype will not automatically adjust my mixer levels. I describe this because the pictures in the link are in German.
Edit: I later had problems again. I went in and rechecked the box so that Skype can automatically adust my speaker levels.

I passed the Skype test. My voice playback was clear and I did not hear any background noise. I hope to test it with a real conversation tomorrow.

This is great. Thank you for your help, Merlwiz79. :D
OnlyMe
Level 2
Level 2
 
Posts: 56
Joined: Sun Mar 16, 2008 4:00 pm
Location: Florida - USA

Re: Skype audio - impossible

Postby OnlyMe on Thu Aug 14, 2008 7:15 pm

I hate to report this but Skype audio on my Mint 5 Elyssa is impossible. I have set and reset the settings and they will not stay set and that has me upset! I have resigned myself to using only chat with Skype on Mint on my lappy. If I want to use the audio with Skype on my lappy I will reboot in XP. Because of this, I have removed 'Solved' from the subject of the thread.
OnlyMe
Level 2
Level 2
 
Posts: 56
Joined: Sun Mar 16, 2008 4:00 pm
Location: Florida - USA

Re: Skype audio - impossible

Postby jungar on Wed Aug 20, 2008 12:42 pm

guys, just thought i'd help with some input on the topic.

i find that i CANNOT use skype if i have any other audio/video program playing, that includes youtube, mplayet etc.

if i wanna use skype, i have to close all these applications, and plug the usb mic (if you have one). and then open skype.
User avatar
jungar
Level 3
Level 3
 
Posts: 102
Joined: Fri Apr 25, 2008 10:25 pm

Re: Skype audio - impossible

Postby Guest on Mon Aug 25, 2008 1:56 am

I'm having trouble with Skype audio as well. I have a Gateway M-1625 laptop with a fresh copy of Mint Elyssa. When I test call in Skype, I can hear the audio, but I can't record. I tried going into alsamixer and turning on the mic, but the 2 spots for mic have no level which I can increase (there's no little box there). I increased everything I could, and tried sound record from the menu. Now I get horrible feedback when I switch the source to Capture. I probably screwed it up when I increased all of the levels in alsamixer, anyway I'm not sure I know what I'm doing, or what to do. Can someone give me directions on how to turn on the mic?

Thanks
Guest
 

Re: Skype audio - impossible

Postby kadathseeker on Tue Sep 23, 2008 11:07 am

Don't put the mic volume at full in alsamixer, put it at about half and test it then. I had the same problem, at full volume it was getting feedback.
kadathseeker
Level 1
Level 1
 
Posts: 17
Joined: Sat Aug 30, 2008 10:07 pm

Re: Skype audio - impossible

Postby dnmint on Tue Sep 23, 2008 9:48 pm

Similar situation here
ImageDNMint
User avatar
dnmint
Level 4
Level 4
 
Posts: 393
Joined: Sat Jun 21, 2008 5:00 pm
Location: Hyderabad, India ( mostly travelling)

Re: Skype audio - impossible

Postby jazz on Tue Jan 06, 2009 8:20 am

I found a workaround that works for me.

Execute all of this command on your terminal:
it's a good idea to backup /etc/X11/Xsession.d/70pulseaudio before removing it.
* killall pulseaudio
* sudo apt-get remove pulseaudio
* sudo apt-get install esound
* sudo rm /etc/X11/Xsession.d/70pulseaudio

Reboot the system.
jazz
 

Re: Skype audio - impossible

Postby oakhilltop on Fri Jan 09, 2009 2:24 pm

jazz wrote:I found a workaround that works for me.

Execute all of this command on your terminal:
it's a good idea to backup /etc/X11/Xsession.d/70pulseaudio before removing it.
* killall pulseaudio
* sudo apt-get remove pulseaudio
* sudo apt-get install esound
* sudo rm /etc/X11/Xsession.d/70pulseaudio

Reboot the system.

I tried that and it still doesn't work for me. Frustrating!

When I make a test call, I hear the ringing and the message. Then I record, but nothing gets played back. I'm using a headset that is plugged into the audio connectors on the front of my PC's case.

Does anyone have skype working?
oakhilltop
Level 2
Level 2
 
Posts: 84
Joined: Wed Apr 04, 2007 7:53 am

Re: Skype audio - impossible

Postby manray15 on Thu Jan 22, 2009 11:25 am

jazz - thank you!

The workaround worked really great. After I rebooted the system, Skype now recognized the default audio devices. I wonder why pulse was installed in the first place.. ?
manray15
 

Re: Skype audio - impossible

Postby Vargas on Fri Jan 23, 2009 8:28 am

oakhilltop wrote: I tried that and it still doesn't work for me. Frustrating!
When I make a test call, I hear the ringing and the message. Then I record, but nothing gets played back. I'm using a headset that is plugged into the audio connectors on the front of my PC's case.
Does anyone have skype working?


That happened to my girlfriend's pc. I've done the remove pulseaudio, install esound thing, and then played with the Volume Control preferences that's in the gnome panel and sound in, sound out, etc. in skype options. That fixed it.
Vargas
Level 1
Level 1
 
Posts: 23
Joined: Tue Feb 12, 2008 9:12 am

Re: Skype audio - impossible

Postby dutch1 on Mon Jan 26, 2009 4:49 am

dag,
skype is working for me as follows:

sound in : HDA Intel
sound out: Pulse
sound ringing: Pulse

hans
dutch1
Level 1
Level 1
 
Posts: 34
Joined: Sat Jan 03, 2009 3:37 pm

Re: Skype audio - impossible

Postby infamous on Sun Feb 01, 2009 8:10 pm

I had trouble with anything but USB skype certified headset. I got a logitech 350 USB headset and it was detected. All I had to do was change the settings to use the headset. It cost me 37 dollars. I wish I had bought it on sale for 17 dollars when I had the chance. Still a good investment as the quality is much better than any of the 20 dollar headsets I've used. I hope this helps
infamous
Level 2
Level 2
 
Posts: 73
Joined: Mon Aug 04, 2008 4:21 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 14 guests