cant install programs via apt-get

Questions about applications and software
Forum rules
Before you post please read this

cant install programs via apt-get

Postby adrienkennebec on Fri Dec 27, 2013 8:35 pm

Whenever I try to install a program i get this error message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
eggdrop : Depends: eggdrop-data (= 1.6.19-1.2ubuntu5) but it is not going to be installed
wine : Depends: wine1.4 but it is not going to be installed
wine1.4-common : Depends: wine1.4 (= 1.4.1-0ubuntu1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried apt-get install -f install and then tried again. but it still wont work downloading anything.

Anyone know how to fix this?
adrienkennebec
Level 1
Level 1
 
Posts: 5
Joined: Wed Apr 24, 2013 6:24 pm

Linux Mint is funded by ads and donations.
 

Re: cant install programs via apt-get

Postby Neil Edmond on Fri Dec 27, 2013 8:45 pm

You probably don't have a solid interenet connection, and the download was incomplete. Are you attempting this with a wireless connection?

The -f switch is a command to finish" the incomplete install. The proper syntax for it is: sudo apt-get -f install [package-name-you're-installing]. Plus it's always a good idea to sudo apt-get update, before trying to install anything. Have you done that? See if that makes a difference and report back.
Neil Edmond
Level 3
Level 3
 
Posts: 178
Joined: Thu Dec 26, 2013 10:19 am
Location: N.E.AR USA

Re: cant install programs via apt-get

Postby adrienkennebec on Fri Dec 27, 2013 8:57 pm

I tried sudo apt-get update and got this:

Ign http://dl.google.com stable InRelease
Ign http://security.ubuntu.com quantal-security InRelease
Hit http://dl.google.com stable Release.gpg
Hit http://security.ubuntu.com quantal-security Release.gpg
Hit http://dl.google.com stable Release
Hit http://security.ubuntu.com quantal-security Release
Ign http://archive.ubuntu.com quantal InRelease
Ign http://packages.linuxmint.com nadia InRelease
Ign http://archive.canonical.com quantal InRelease
Ign http://archive.ubuntu.com quantal-updates InRelease
Get:1 http://packages.linuxmint.com nadia Release.gpg [198 B]
Hit http://archive.canonical.com quantal Release.gpg
Ign http://ppa.launchpad.net quantal InRelease
Get:2 http://packages.linuxmint.com nadia Release [18.6 kB]
Hit http://archive.ubuntu.com quantal Release.gpg
Hit http://dl.google.com stable/main i386 Packages
Hit http://security.ubuntu.com quantal-security/main i386 Packages
Hit http://archive.canonical.com quantal Release
Ign http://ppa.launchpad.net quantal InRelease
Hit http://security.ubuntu.com quantal-security/restricted i386 Packages
Hit http://security.ubuntu.com quantal-security/universe i386 Packages
Hit http://archive.ubuntu.com quantal-updates Release.gpg
Hit http://security.ubuntu.com quantal-security/multiverse i386 Packages
Ign http://ppa.launchpad.net quantal InRelease
Get:3 http://packages.linuxmint.com nadia/main i386 Packages [22.3 kB]
Hit http://archive.canonical.com quantal/partner i386 Packages
Hit http://archive.ubuntu.com quantal Release
Hit http://security.ubuntu.com quantal-security/main Translation-en
Hit http://ppa.launchpad.net quantal Release.gpg
Hit http://security.ubuntu.com quantal-security/multiverse Translation-en
Hit http://archive.ubuntu.com quantal-updates Release
Get:4 http://packages.linuxmint.com nadia/upstream i386 Packages [11.3 kB]
Ign http://ppa.launchpad.net quantal Release.gpg
Hit http://security.ubuntu.com quantal-security/restricted Translation-en
Hit http://archive.ubuntu.com quantal/main i386 Packages
Ign http://dl.google.com stable/main Translation-en_CA
Get:5 http://packages.linuxmint.com nadia/import i386 Packages [44.3 kB]
Hit http://security.ubuntu.com quantal-security/universe Translation-en
Hit http://ppa.launchpad.net quantal Release.gpg
Ign http://dl.google.com stable/main Translation-en
Hit http://archive.ubuntu.com quantal/restricted i386 Packages
Hit http://ppa.launchpad.net quantal Release
Hit http://archive.ubuntu.com quantal/universe i386 Packages
Ign http://ppa.launchpad.net quantal Release
Hit http://archive.ubuntu.com quantal/multiverse i386 Packages
Hit http://ppa.launchpad.net quantal Release
Hit http://archive.ubuntu.com quantal/main Translation-en_CA
Hit http://ppa.launchpad.net quantal/main Sources
Hit http://archive.ubuntu.com quantal/main Translation-en
Hit http://ppa.launchpad.net quantal/main i386 Packages
Ign http://security.ubuntu.com quantal-security/main Translation-en_CA
Ign http://security.ubuntu.com quantal-security/multiverse Translation-en_CA
Ign http://security.ubuntu.com quantal-security/restricted Translation-en_CA
Ign http://archive.canonical.com quantal/partner Translation-en_CA
Ign http://security.ubuntu.com quantal-security/universe Translation-en_CA
Hit http://archive.ubuntu.com quantal/multiverse Translation-en
Ign http://archive.canonical.com quantal/partner Translation-en
Hit http://archive.ubuntu.com quantal/restricted Translation-en
Hit http://archive.ubuntu.com quantal/universe Translation-en_CA
Hit http://archive.ubuntu.com quantal/universe Translation-en
Hit http://archive.ubuntu.com quantal-updates/main i386 Packages
Hit http://ppa.launchpad.net quantal/main Sources
Hit http://archive.ubuntu.com quantal-updates/restricted i386 Packages
Hit http://ppa.launchpad.net quantal/main i386 Packages
Hit http://archive.ubuntu.com quantal-updates/universe i386 Packages
Hit http://archive.ubuntu.com quantal-updates/multiverse i386 Packages
Hit http://archive.ubuntu.com quantal-updates/main Translation-en
Hit http://archive.ubuntu.com quantal-updates/multiverse Translation-en
Hit http://archive.ubuntu.com quantal-updates/restricted Translation-en
Ign http://packages.linuxmint.com nadia/import Translation-en_CA
Ign http://packages.linuxmint.com nadia/import Translation-en
Hit http://archive.ubuntu.com quantal-updates/universe Translation-en
Ign http://packages.linuxmint.com nadia/main Translation-en_CA
Ign http://packages.linuxmint.com nadia/main Translation-en
Ign http://packages.linuxmint.com nadia/upstream Translation-en_CA
Ign http://packages.linuxmint.com nadia/upstream Translation-en
Ign http://ppa.launchpad.net quantal/main Translation-en_CA
Ign http://ppa.launchpad.net quantal/main Translation-en
Ign http://archive.ubuntu.com quantal/multiverse Translation-en_CA
Err http://ppa.launchpad.net quantal/main Sources
404 Not Found
Ign http://archive.ubuntu.com quantal/restricted Translation-en_CA
Err http://ppa.launchpad.net quantal/main i386 Packages
404 Not Found
Ign http://archive.ubuntu.com quantal-updates/main Translation-en_CA
Ign http://ppa.launchpad.net quantal/main Translation-en_CA
Ign http://archive.ubuntu.com quantal-updates/multiverse Translation-en_CA
Ign http://ppa.launchpad.net quantal/main Translation-en
Ign http://archive.ubuntu.com quantal-updates/restricted Translation-en_CA
Ign http://ppa.launchpad.net quantal/main Translation-en_CA
Ign http://archive.ubuntu.com quantal-updates/universe Translation-en_CA
Ign http://ppa.launchpad.net quantal/main Translation-en
Fetched 96.7 kB in 5s (17.0 kB/s)
W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... ce/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... 6/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

And then i tried to install the programs with sudo apt-get -f install, but got the same errors. also I'm on a wired connection now.
adrienkennebec
Level 1
Level 1
 
Posts: 5
Joined: Wed Apr 24, 2013 6:24 pm

Re: cant install programs via apt-get

Postby Neil Edmond on Fri Dec 27, 2013 9:03 pm

OK...well, sorry, but we've gone beyond my level of knowledge. Could be that the Ubuntu repo's are down at the moment, or at least some of them are not available. That's the best I can offer right now...hopefully someone with more insight will come along shortly and fill in the blanks.
Neil Edmond
Level 3
Level 3
 
Posts: 178
Joined: Thu Dec 26, 2013 10:19 am
Location: N.E.AR USA

Re: cant install programs via apt-get

Postby TheDynamicHamza21 on Sat Dec 28, 2013 5:08 am

adrienkennebec wrote:W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... ce/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... 6/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.


These ppas failed because they don't exist.

there's no ppa for Quantal
https://launchpad.net/~gwibber-team/+archive/ppa

Same for here
http://ppa.launchpad.net/gwibber-daily/ ... ntu/dists/

I would comment out that ppa in sources list or uncheck it in the other tab in your software sources . Then run sudo apt-get update again in the terminal.
Linux Registered User: # 573034

www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 730
Joined: Thu Oct 04, 2012 7:24 pm
Location: California

Re: cant install programs via apt-get

Postby adrienkennebec on Sat Dec 28, 2013 3:29 pm

TheDynamicHamza21 wrote:
adrienkennebec wrote:W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... ce/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... 6/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.


These ppas failed because they don't exist.

there's no ppa for Quantal
https://launchpad.net/~gwibber-team/+archive/ppa

Same for here
http://ppa.launchpad.net/gwibber-daily/ ... ntu/dists/

I would comment out that ppa in sources list or uncheck it in the other tab in your software sources . Then run sudo apt-get update again in the terminal.


Okay, i tried removing those from my sources list, then run sudo apt-get update and it updated without errors. But then i tried sudo apt-get -f install again and it gave me these errors:



sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
wine1.4
The following NEW packages will be installed:
wine1.4
0 upgraded, 1 newly installed, 0 to remove and 475 not upgraded.
3 not fully installed or removed.
Need to get 1,001 kB of archives.
After this operation, 2,651 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ quantal/universe wine1.4 i386 1.4.1-0ubuntu1 [1,001 kB]
Fetched 1,001 kB in 2s (461 kB/s)
Preconfiguring packages ...
(Reading database ... 177348 files and directories currently installed.)
Unpacking wine1.4 (from .../wine1.4_1.4.1-0ubuntu1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/wine1.4_1.4.1-0ubuntu1_i386.deb (--unpack):
trying to overwrite '/usr/share/man/man1/wineserver.1.gz', which is also in package libwine-unstable 1.5.5-0.1
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Errors were encountered while processing:
/var/cache/apt/archives/wine1.4_1.4.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
adrienkennebec
Level 1
Level 1
 
Posts: 5
Joined: Wed Apr 24, 2013 6:24 pm

Re: cant install programs via apt-get

Postby Monsta on Sat Dec 28, 2013 3:54 pm

adrienkennebec wrote:dpkg: error processing /var/cache/apt/archives/wine1.4_1.4.1-0ubuntu1_i386.deb (--unpack):
trying to overwrite '/usr/share/man/man1/wineserver.1.gz', which is also in package libwine-unstable 1.5.5-0.1

This shouldn't be there.
Please post the output of:
Code: Select all
inxi -Sr
Code: Select all
apt-cache policy libwine-unstable

BTW, please use the "code" tag this time, things pasted from the terminal look much better with it.
Monsta
Level 8
Level 8
 
Posts: 2318
Joined: Fri Aug 19, 2011 3:46 am

Re: cant install programs via apt-get

Postby adrienkennebec on Sat Dec 28, 2013 7:59 pm

Here is the output of those commands:
Code: Select all
inxi -Sr
System:    Host: chris-AOD255 Kernel: 3.5.0-17-generic i686 (32 bit) Desktop: Xfce 4.10.0 Distro: Linux Mint 14 Nadia
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ nadia main upstream import
           deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ quantal partner

apt-cache policy libwine-unstable
libwine-unstable:
  Installed: 1.5.5-0.1
  Candidate: 1.5.5-0.1
  Version table:
 *** 1.5.5-0.1 0
        100 /var/lib/dpkg/status
adrienkennebec
Level 1
Level 1
 
Posts: 5
Joined: Wed Apr 24, 2013 6:24 pm

Re: cant install programs via apt-get

Postby Monsta on Sun Dec 29, 2013 4:34 am

The repos look alright. Now you just need to remove libwine-unstable:
Code: Select all
sudo apt-get remove --purge libwine-unstable

Where did you get that package, BTW?
Monsta
Level 8
Level 8
 
Posts: 2318
Joined: Fri Aug 19, 2011 3:46 am

Re: cant install programs via apt-get

Postby adrienkennebec on Sun Dec 29, 2013 12:27 pm

From apt-get. It mustve got installed when I was trying to install wine.

I tried "sudo apt-get remove --purge libwine-unstable" and got this:

Code: Select all
sudo apt-get remove --purge libwine-unstable
[sudo] password for chris:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libwine-alsa-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed
 libwine-bin-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed
 libwine-oss-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed
 libwine-sane-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed
 wine : Depends: wine1.4 but it is not going to be installed
 wine1.4-common : Depends: wine1.4 (= 1.4.1-0ubuntu1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
adrienkennebec
Level 1
Level 1
 
Posts: 5
Joined: Wed Apr 24, 2013 6:24 pm

Re: cant install programs via apt-get

Postby Monsta on Sun Dec 29, 2013 1:01 pm

adrienkennebec wrote: libwine-alsa-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed
libwine-bin-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed
libwine-oss-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed
libwine-sane-unstable : Depends: libwine-unstable (= 1.5.5-0.1) but it is not going to be installed[/code]

Wow. Where did you get all this? These packages are not in the Ubuntu repos. You must have added some unreliable PPA...
Anyway, I'd remove them all then try to remove libwine-unstable once more.
Monsta
Level 8
Level 8
 
Posts: 2318
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: TheDynamicHamza21 and 15 guests