[SOLVED] How to save ALSA settings?

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] How to save ALSA settings?

Postby Althorion on Sun Dec 29, 2013 11:17 pm

Every time I reboot my computer, I have to set my ALSA settings again — set default sound card and change output. I have tried using sudo alsactl store, but it didn’t work. What can I do to make Mint remember my sound settings?
Last edited by Althorion on Mon Dec 30, 2013 10:56 am, edited 1 time in total.
Part of that power which would
Do evil constantly and constantly does good.
User avatar
Althorion
Level 1
Level 1
 
Posts: 2
Joined: Sun Aug 14, 2011 11:01 pm

Linux Mint is funded by ads and donations.
 

Re: How to save ALSA settings?

Postby perham on Mon Dec 30, 2013 7:53 am

you should also run
Code: Select all
sudo alsactl restore
at each boot. probably it's best to add it to your startup programs.
Last edited by perham on Mon Dec 30, 2013 11:54 am, edited 1 time in total.
AMD Phenom II X6 1090T 3.2GHz DDR3-1600 12GB ]LinuxMint 16 Cinnamon
Intel Pentium 4 540 3.2GHz DDR-400 2GB LinuxMint 16 Mate
Intel Pentium 4 1.5 GHz 512MB Debian Jessie LXDE
User avatar
perham
Level 3
Level 3
 
Posts: 118
Joined: Sat Dec 28, 2013 7:52 pm
Location: Belgium

Re: How to save ALSA settings?

Postby Althorion on Mon Dec 30, 2013 10:55 am

You probably meant sudo alsactl restore (alsa is just a deamon). Thanks, now it works and I should have remembered that. Oh well, on my defence, I haven’t used a multi-soundcard PC for quite a while.

If anyone would have the same problem, I would advise you to change your sudoers file to enable running that command without typing password, just for your convenience.
Part of that power which would
Do evil constantly and constantly does good.
User avatar
Althorion
Level 1
Level 1
 
Posts: 2
Joined: Sun Aug 14, 2011 11:01 pm

Re: How to save ALSA settings?

Postby perham on Mon Dec 30, 2013 11:49 am

Althorion wrote:You probably meant sudo alsactl restore (alsa is just a deamon). Thanks, now it works and I should have remembered that. Oh well, on my defence, I haven’t used a multi-soundcard PC for quite a while.

If anyone would have the same problem, I would advise you to change your sudoers file to enable running that command without typing password, just for your convenience.


yeah, sorry, typed fast without checking. I'm happy that you figured it out ;)
AMD Phenom II X6 1090T 3.2GHz DDR3-1600 12GB ]LinuxMint 16 Cinnamon
Intel Pentium 4 540 3.2GHz DDR-400 2GB LinuxMint 16 Mate
Intel Pentium 4 1.5 GHz 512MB Debian Jessie LXDE
User avatar
perham
Level 3
Level 3
 
Posts: 118
Joined: Sat Dec 28, 2013 7:52 pm
Location: Belgium


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 31 guests