Uyghur/Unicode not displaying Properly

Questions about applications and software
Forum rules
Before you post please read this

Uyghur/Unicode not displaying Properly

Postby alborzka on Sat Jan 04, 2014 12:22 pm

Hello,

I recently installed Linux Mint 16 and for some reason Uyghur script won't display properly on Mozilla Firefox. For example, my recent Facebook status appears as such:
http://i40.tinypic.com/2gy39mc.png
Note how the font for some letters are different than the standard font, as well as the fact that the letters aren't joined as they're supposed to be.

This same text in LibreOffice Writer shows up fine (i.e. the correct way it should), however:
http://i39.tinypic.com/23vx2zr.png
The first text is from a UKIJ (Uyghur font) I downloaded via the Software Manager, while the second line below is using this font called "Aboriginal Sans" since I couldn't find any font called Sans Serif or Serif on LibreOffice Writer. I included this second line to show that even not using a specialized UKIJ font, Uyghur should still display properly.

I'm not sure why it doesn't display properly on Mozilla Firefox. I tried changing the default font to UKIJ and even then the same problem happens. Even fonts such as Burmese or Amharic show up properly, so I don't know if this is a Unicode related problem or not (it might be, though -- I see squares sometimes for some characters, but not for these languages). What's going on here and how can I solve this?

I'd appreciate any help!
alborzka
Level 1
Level 1
 
Posts: 10
Joined: Fri Dec 20, 2013 12:04 pm

Linux Mint is funded by ads and donations.
 

Re: Uyghur/Unicode not displaying Properly

Postby alborzka on Tue Jan 07, 2014 12:19 am

bump!
alborzka
Level 1
Level 1
 
Posts: 10
Joined: Fri Dec 20, 2013 12:04 pm

Re: Uyghur/Unicode not displaying Properly

Postby Tejas_0 on Tue Jan 07, 2014 10:18 am

Can see what's happening, the letters are being written like in the the alphabet, and the joining varant not being used. However have no idea where you can strart looking. :roll:
Release: Linux Mint 16 "petra"
Edition: Cinnamon 32-bit
Linux mint 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:12:00 UTC 2013 i686 athlon i686 GNU/Linux
Tejas_0
Level 3
Level 3
 
Posts: 185
Joined: Tue May 17, 2011 6:06 pm

Re: Uyghur/Unicode not displaying Properly

Postby alborzka on Tue Jan 07, 2014 11:33 am

Tejas_0 wrote:Can see what's happening, the letters are being written like in the the alphabet, and the joining varant not being used. However have no idea where you can strart looking. :roll:


And thats the thing, it worked on my previous Linux Mint 14/15, so not sure what happened here. Update Manager says nothing needs to be updated so what could be the problem?? :roll:
alborzka
Level 1
Level 1
 
Posts: 10
Joined: Fri Dec 20, 2013 12:04 pm

Re: Uyghur/Unicode not displaying Properly

Postby Tejas_0 on Tue Jan 07, 2014 3:23 pm

Suppose you'll have to ask Ubuntu then. :?
Release: Linux Mint 16 "petra"
Edition: Cinnamon 32-bit
Linux mint 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:12:00 UTC 2013 i686 athlon i686 GNU/Linux
Tejas_0
Level 3
Level 3
 
Posts: 185
Joined: Tue May 17, 2011 6:06 pm

Re: Uyghur/Unicode not displaying Properly

Postby alborzka on Tue Jan 07, 2014 4:08 pm

Tejas_0 wrote:Suppose you'll have to ask Ubuntu then. :?


Do you mean the administrators directly? :| I wouldn't have figured they would listen lol, http://www.linuxmint.com/contactus.php the website says to come here for help :|
alborzka
Level 1
Level 1
 
Posts: 10
Joined: Fri Dec 20, 2013 12:04 pm

Re: Uyghur/Unicode not displaying Properly

Postby Tejas_0 on Tue Jan 07, 2014 4:37 pm

No :lol: Mean the forum. Also wouldn't hurt to google for an answer. :idea:
Release: Linux Mint 16 "petra"
Edition: Cinnamon 32-bit
Linux mint 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:12:00 UTC 2013 i686 athlon i686 GNU/Linux
Tejas_0
Level 3
Level 3
 
Posts: 185
Joined: Tue May 17, 2011 6:06 pm

Re: Uyghur/Unicode not displaying Properly

Postby alborzka on Wed Jan 08, 2014 4:43 pm

Tejas_0 wrote:No :lol: Mean the forum. Also wouldn't hurt to google for an answer. :idea:


Extensively googled for an answer without any help, hence why I asked here lmao, thanks for the suggestion though :/
Hmm, I'd have to register for the Ubuntu forum and everything, I'll see what happens here first before doing that.

Anyone else have any suggestions? Anything? :D
alborzka
Level 1
Level 1
 
Posts: 10
Joined: Fri Dec 20, 2013 12:04 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 17 guests